Everything just switched to another language?????

Discuss the word processor

Everything just switched to another language?????

Postby MathFool » Fri Oct 05, 2012 10:51 pm

I closed all my files and restarted my PC. When I came back, one of the 4 ODT. files asked me.........

Chart1.png



Then this is what showed up when I hit ok.........(Not what I originally saved.)

Chart2.png



Strange as my other three files are fine.
OpenOffice 3.3.0 on Windows 7
MathFool
 
Posts: 40
Joined: Mon Apr 25, 2011 2:47 am

Re: Everything just switched to another language?????

Postby RoryOF » Fri Oct 05, 2012 11:06 pm

Corrupted file, possibly due to over hasty close down of computer. Nothing to be done, unless there is an arbitrarily named temporary file in OpenOffice's temporary directory.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31538
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Everything just switched to another language?????

Postby MathFool » Sat Oct 06, 2012 12:40 am

Where is the OpenOffice's temporary directory?
OpenOffice 3.3.0 on Windows 7
MathFool
 
Posts: 40
Joined: Mon Apr 25, 2011 2:47 am

Re: Everything just switched to another language?????

Postby MathFool » Sat Oct 06, 2012 12:47 am

Also, I have it set to auto save every 15 minutes. I have never had this issue before.........So sad.
OpenOffice 3.3.0 on Windows 7
MathFool
 
Posts: 40
Joined: Mon Apr 25, 2011 2:47 am

Re: Everything just switched to another language?????

Postby thomasjk » Sat Oct 06, 2012 5:25 am

Look for filename.bak in the user profile viewtopic.php?f=74&t=12426. BTW, the autosave does not save your file. It saves the auto recovery information used in the event of a crash. Use Tools--->Options--->Load/Save-->General and check "Always create backup copy" to save a filename.bak each time you manually save the file.
Tom K.
Windows 10 Home version 1803 17134.165
LibreOffice 5.4.7.2
thomasjk
Volunteer
 
Posts: 4428
Joined: Tue Dec 25, 2007 4:52 pm
Location: North Carolina

Re: Everything just switched to another language?????

Postby RoryOF » Sat Oct 06, 2012 8:45 am

The paths used by OpenOffice are given in /Tools /Options /OpenOffice.org : Paths (under Preferences on Macs). If a change is made in these settings, it may be necessary to restart OpenOffice, including Quickstarter, for them to take. Often the easiest way is to properly power down the computer and restart it.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31538
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Everything just switched to another language?????

Postby Hagar Delest » Sat Oct 06, 2012 2:52 pm

Sadly, quite nothing to do, see: 22 pages term paper replaced with pound signs.
Any power shortage for example? It's a common root cause of such problem.

Check the temporary folder of the system (see in OOo Tools>Options>OOo>Paths). If there are folders like sgmlf.tmp with a file having the same name inside, make a copy of that file, rename it in .odt and cross your fingers.

I think there are less reports about such problems, upgrading to AOO 3.4.1 may help.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28997
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Everything just switched to another language?????

Postby gerard24 » Sat Oct 06, 2012 4:04 pm

Since you are running OOo on Win 7, if shadow copy is enabled you can acced to a previous version : http://www.pcmag.com/article2/0,2817,2342534,00.asp
Right clic on the file, then "properties" and look if you have "previous version".

You can also try Shadow explorer.
LibreOffice 6.4.5 on Windows 10
gerard24
Volunteer
 
Posts: 956
Joined: Sat Oct 30, 2010 5:12 pm
Location: France


Return to Writer

Who is online

Users browsing this forum: Hagar Delest and 21 guests