[Solved] Spell check underlines every word

Discuss the word processor

[Solved] Spell check underlines every word

Postby Bill Stephens » Mon Sep 03, 2012 10:04 pm

I tried the uninstall re-install fix and it did not help. What can I do now. (canadian English)
Last edited by Hagar Delest on Sun Sep 09, 2012 12:01 pm, edited 1 time in total.
Reason: tagged [Solved].
Open Office 3.4 on Window 7
Bill Stephens
 
Posts: 10
Joined: Mon Sep 03, 2012 8:47 pm

Re: Spell check underlines every word

Postby Hagar Delest » Mon Sep 03, 2012 10:35 pm

Hi and welcome to the forum!

See: [Troubleshooting] Spell check in OOo 3.x.

Please add '[Solved]' at the beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25087
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Spell check underlines every word

Postby Bill Stephens » Tue Sep 04, 2012 5:24 am

I've tried everything here, my screens are a bit different from what you show, but in any case nothing has worked. If I type in capitals there are no wavy lines but no spell check either. I f I type in lower case every word has a wavy line.
I've been using Open Office for several years and never had a problem until I upgraded.
Open Office 3.4 on Window 7
Bill Stephens
 
Posts: 10
Joined: Mon Sep 03, 2012 8:47 pm

Re: Spell check underlines every word

Postby Hagar Delest » Tue Sep 04, 2012 8:04 am

What is the language in the status bar?
Do you see the blue checkmark in front of the language in the Font properties?

NB: please don't post in a tutorial, I've deleted your other post.
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25087
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Spell check underlines every word

Postby RoryOF » Tue Sep 04, 2012 8:16 am

"Check uppercase words" is unchecked by default in /Tools /Options/ Language settings / Writing Aids : options.
Every word with a wavy line is most probably an incorrect setting for default language or selection of a wrong language dictionary.

 Edit: Note that each version of English uses its own dictionary; spellcheck will not work across different strains of English. 
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14335
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell check underlines every word

Postby esperantisto » Tue Sep 04, 2012 2:49 pm

I think, there’s an all-in-one English spellcheck extension that covers all Englishes.
AOO 4.0.1 / LibO 4.1.2 / Win 7 / openSUSE Linux 11.3/12.3
esperantisto
 
Posts: 250
Joined: Mon Oct 08, 2007 1:31 am

Re: Spell check underlines every word

Postby acknak » Tue Sep 04, 2012 2:59 pm

RoryOF wrote:... spellcheck will not work across different strains of English.

Pardon my butting in here--I'm not sure I understand what that means.

Doesn't the "all words underlined" most likely point to an internal problem with the profile settings or dictionary installation? I mean, the only way you get everything underlined is if OOo has (or thinks it has) a dictionary installed that matches the document language setting, but the dictionary is either broken, or the document language setting is completely wrong, set to a language that shares no words at all with the actual document text. If the document contained English (Canada) spellings and the language setting was English (US), you wouldn't find all words underlined--unless the spellcheck/dictionary system was broken.

I believe I had this problem when I installed AOO 3.4, until I had occasion to reset my user settings profile. I'm not 100% sure because I don't use the automatic spellcheck very often.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17395
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Spell check underlines every word

Postby twelvestocks » Tue Sep 04, 2012 5:54 pm

I have this exact problem. Spell check only allows words which I have manually added. If I run spell check it believes that every word is wrongly spelt and if I have 'check spelling as you type' enabled then it underlines every word in wiggly red.

It has English [English (UK)] enabled in Options/Language/Writing Aids and I'm at a loss as to what can be done to rectify this behaviour.

Thanks.
OpenOffice 3.4.1 on Windows 7 Pro
twelvestocks
 
Posts: 1
Joined: Tue Sep 04, 2012 5:49 pm

Re: Spell check underlines every word

Postby Hagar Delest » Tue Sep 04, 2012 9:31 pm

Have you gone through the tutorial linked above? Especially extension manager and the blue check mark?

Does the language shown in the status bar match the desired setting?
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25087
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Spell check underlines every word

Postby Bill Stephens » Wed Sep 05, 2012 5:49 am

Under tools-options-languages I have the following -
User Interface Default English USA
Locale Setting Default English Canada

Default Language for Documents English Canada (with the abc spell check mark in front)
Open Office 3.4 on Window 7
Bill Stephens
 
Posts: 10
Joined: Mon Sep 03, 2012 8:47 pm

Re: Spell check underlines every word

Postby RoryOF » Wed Sep 05, 2012 7:06 am

When you are in a document, on Status bar at screen bottom is English Canada shown? In /Tools /Options /Language Settings/Writing aids under Available Language Modules is Hunspell SpellChecker enabled?
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14335
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell check underlines every word

Postby Bill Stephens » Thu Sep 06, 2012 5:10 am

yes to both.
Open Office 3.4 on Window 7
Bill Stephens
 
Posts: 10
Joined: Mon Sep 03, 2012 8:47 pm

Re: Spell check underlines every word

Postby Hagar Delest » Thu Sep 06, 2012 8:12 am

Have you tried to uncheck and recheck the Hunspell module? See this post.
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25087
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Spell check underlines every word

Postby Villeroy » Thu Sep 06, 2012 11:45 am

OK, here is another question.
Open the document in question where every word is underlined.
Call menu:File>Properties and activate the first tab of that dialog.
Near the bottom you find property "Template". Does it show any template name?
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17264
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Spell check underlines every word

Postby Bill Stephens » Fri Sep 07, 2012 4:25 am

I tried the unchecking and rechecking Hunspell, no help there.
There is no name shown in the template area.
Open Office 3.4 on Window 7
Bill Stephens
 
Posts: 10
Joined: Mon Sep 03, 2012 8:47 pm

Re: Spell check underlines every word

Postby Hagar Delest » Fri Sep 07, 2012 8:20 am

I'm at loss.
Can you upload a sample file (see How to attach a document here)?
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25087
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Spell check underlines every word

Postby Bill Stephens » Sat Sep 08, 2012 12:03 am

Here is a sample from my Open Office files. All are the same.
Attachments
Bill's Letterhead.odt
(20.65 KiB) Downloaded 120 times
Open Office 3.4 on Window 7
Bill Stephens
 
Posts: 10
Joined: Mon Sep 03, 2012 8:47 pm

Re: Spell check underlines every word

Postby Hagar Delest » Sat Sep 08, 2012 12:15 am

Well, works fine for me so it's not a problem with the file:
Spell check.png

Do you confirm you had reset your profile?
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25087
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Spell check underlines every word

Postby Bill Stephens » Sat Sep 08, 2012 4:34 am

I knew it wasn't the file as every file is the same and some I have had for years, they are all 100% underlined with wavy lines! If you mean the profile that you find under tools-options-user data, then it has not changed, if there is another profile you'll have to tell me how to find it. This is getting rather discouraging.
Open Office 3.4 on Window 7
Bill Stephens
 
Posts: 10
Joined: Mon Sep 03, 2012 8:47 pm

Re: Spell check underlines every word

Postby RoryOF » Sat Sep 08, 2012 6:51 am

The User Profile of which Hagar speaks is accessed outside of OpenOffice, with OpenOffice closed. It should be a directory named something like
C:\Users\<user name>\AppData\Roaming\OpenOffice.org\3\user
where <user name> is replaced with your login name under Windows. In your case I hazard that this may be Bill; rename this from (say)
C:\Users\Bill\AppData\Roaming\OpenOffice.org\3\user to C:\Users\Bill\AppData\Roaming\OpenOffice.org\3\user.old

Now restart OpenOffice; I'm oldfashioned and would recommend restarting the computer (Power off and on after a short delay).

Details are given in
Tutorial: The User Profile
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14335
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell check underlines every word

Postby Bill Stephens » Sat Sep 08, 2012 8:14 pm

I can't figure out how to change my user profile. I read the tutorial, but it doesn't seem to work for Windows 7, or perhaps I'm not doing it properly. When I open Widows Explorer there is no Tools, or File options shown. I'm opening Explorer by searching for it, but I just get it showing all the contents of the computer - desk top, libraries, documents, etc.
Open Office 3.4 on Window 7
Bill Stephens
 
Posts: 10
Joined: Mon Sep 03, 2012 8:47 pm

Re: Spell check underlines every word

Postby Bill » Sun Sep 09, 2012 3:24 am

Bill Stephens wrote:I can't figure out how to change my user profile. I read the tutorial, but it doesn't seem to work for Windows 7, or perhaps I'm not doing it properly. When I open Widows Explorer there is no Tools, or File options shown. I'm opening Explorer by searching for it, but I just get it showing all the contents of the computer - desk top, libraries, documents, etc.

Close AOO. Click Start and type %appdata% in the Search box. Click "Roaming". Right-click the OpenOffice.org folder and select Rename. Type a different name and press Enter. Restart AOO. AOO won't find the OpenOffice.org folder and will create a new one.
Bill
 
Posts: 3310
Joined: Sat Nov 24, 2007 6:48 am

Re: Spell check underlines every word

Postby Bill Stephens » Sun Sep 09, 2012 4:28 am

Wonderful, that worked!! Can I delete the old renamed folder? Thanks for all your help.
Open Office 3.4 on Window 7
Bill Stephens
 
Posts: 10
Joined: Mon Sep 03, 2012 8:47 pm

Re: Spell check underlines every word

Postby RoryOF » Sun Sep 09, 2012 5:18 am

Yes, you can delete the old renamed folder, unless it contains much customisation. If one had been writing a work over time and had specialised dictionaries, say containing proper names and terms, autocorrect lists and whatever else, these would be contained in the old renamed folder. Such individual items could be brought forward one by one to the new folder - one by one lest an individual item caused the user profile corruption - to restore that user's editing environment. But for a casual/non critical User, deletion is appropriate.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14335
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell check underlines every word

Postby charityaprill » Tue Feb 26, 2013 9:49 pm

OMG! That totally worked! Ahh, I have been struggling with that for months now. Thank you!
OpenOffice 3.4.1
Windows Vista
charityaprill
 
Posts: 1
Joined: Tue Feb 26, 2013 9:46 pm

Re: [Solved] Spell check underlines every word

Postby somersbyman » Mon May 27, 2013 6:33 am

I had to rename the "user" folder twice. Lordy knows why. But I did. And it worked. I now have "user", "userold" and "userold2" folders...but normal spell-checking. Hoorah!
OpenOffice 3.4 on Windows Vista Basic
somersbyman
 
Posts: 2
Joined: Mon Jun 04, 2012 1:44 pm


Return to Writer

Who is online

Users browsing this forum: Habaccuc and 22 guests