[Solved] Restarting Footnote Numbers for Each Chapter

Discuss the word processor

[Solved] Restarting Footnote Numbers for Each Chapter

Postby kenmorgan » Thu Aug 30, 2012 2:20 am

I'm combining chapters to make a single manuscript. Each chapter is a separate odt document with footnotes staring at 1. I used Insert ---> File for a test run on two chapters. The footnotes should start at 1 for each new chapter appended, but of course attaching a second document like this made the footnotes for the second chapter begin where the first chapter left off. I need to reset each first footnote for each chapter to 1. I found a thread from 2010 on this forum about this issue, and apparently at that time there was no way to do it, although the originator said Microsoft Word had a simple way to do this very thing. I am hoping that OpenOffice/LibreOffice now can do it too. How can I reset a footnote number to start a new sequence?

Thanks.

Bill
Last edited by Hagar Delest on Sun Sep 02, 2012 12:01 am, edited 1 time in total.
Reason: tagged [Solved].
CentOS 6 Linux
Native Apache Open Office 4.1.3
User avatar
kenmorgan
 
Posts: 120
Joined: Sat Sep 13, 2008 2:03 pm
Location: Georgia

Re: Restarting Footnote Numbers for Each Chapter

Postby JohnV » Thu Aug 30, 2012 3:32 am

Tools > Footnote/Endnote > Footnote tab. Set Counting to Per Chapter.
JohnV
Volunteer
 
Posts: 1585
Joined: Mon Oct 08, 2007 1:32 am
Location: Kentucky, USA

Re: Restarting Footnote Numbers for Each Chapter

Postby kenmorgan » Thu Aug 30, 2012 3:49 am

Thanks, John.

But I did do this. It doesn't recognize the beginning of a new chapter.

I also read the Help page, "Inserting a Chapter Name and Number in a Header or a Footer." I followed every step. The result was that "Chapter 1" appeared in the headers of every page on both chapters, so there was no way of telling whether the footnote setting would have worked or not. And of ocurse, the chapter number and title must not appear on EVERY page. Plus, who wants "Chapter 1" plus its title in a HEADER? Most published books have it even lower than the point where the first line appears on normal pages.
CentOS 6 Linux
Native Apache Open Office 4.1.3
User avatar
kenmorgan
 
Posts: 120
Joined: Sat Sep 13, 2008 2:03 pm
Location: Georgia

Re: Restarting Footnote Numbers for Each Chapter

Postby JohnV » Thu Aug 30, 2012 4:49 pm

It doesn't recognize the beginning of a new chapter.
Did you use the Heading 1 paragraph style for your chapter titles? If you are using a master document then did you do Tools > Footnote/Endnote > Footnote tab. Set Counting to Per Chapter in the master doc?
JohnV
Volunteer
 
Posts: 1585
Joined: Mon Oct 08, 2007 1:32 am
Location: Kentucky, USA

Re: Restarting Footnote Numbers for Each Chapter

Postby RGB » Thu Aug 30, 2012 5:14 pm

billquinn wrote:It doesn't recognize the beginning of a new chapter.

Writer defines a "Chapter" as something started by a first outline level heading: if you use a second outline level for your chapters this (and other thing, like TOCs for chapters) will not work.
There are two types of people: those who believe that there are two types of people and those who do not.

openSUSE Leap with KDE Plasma / LibO
User avatar
RGB
 
Posts: 1454
Joined: Mon Oct 08, 2007 1:34 am

Re: Restarting Footnote Numbers for Each Chapter

Postby kenmorgan » Thu Aug 30, 2012 7:02 pm

Okay, here's where I am right now.

(1) I've combined two chapters, each an odt file, to create one single odt file.
(2) I removed the header.
(3) The footnotes currently form one sequence, starting at 1 for chapter 1 and 11 for chapter 2.
(4) These chapters already have the lines "Chapter 1" and "Chapter 2" as the first line of the first page of each chapter, respectively.
(5) I went to Tools ---> Footnotes/Endnotes and set "Counting" to "Per Chapter."
(6) I highlighted the line "Chapter 1" and then went to Format ---> Paragraph and clicked the tab "Outline & Numbering." In that window I set "Outline level" to read "Level 1." Then I repeated the process for the line "Chapter 2" in the first page of chapter 2.

I had high hopes! It was such a simple routine. But it didn't work. The footnotes still run in a single sequence from 1 to 56, where chapter 2 still starts with footnote 11 instead of 1 for a new sequence.

What am I doing wrong?

Thanks so much.

Bill
CentOS 6 Linux
Native Apache Open Office 4.1.3
User avatar
kenmorgan
 
Posts: 120
Joined: Sat Sep 13, 2008 2:03 pm
Location: Georgia

Re: Restarting Footnote Numbers for Each Chapter

Postby RGB » Thu Aug 30, 2012 8:00 pm

It seems this do not work if you set the outline level as direct formatting. But if you use a paragraph style that have an outline level associated (for example, under Tools → Outline numbering you have Heading 1 as level one and then use that paragraph style for your heading) it works without problems.

In general it is a bad idea to use direct formatting for such matters (IMO, it is always bad idea to use direct formatting... ;))
There are two types of people: those who believe that there are two types of people and those who do not.

openSUSE Leap with KDE Plasma / LibO
User avatar
RGB
 
Posts: 1454
Joined: Mon Oct 08, 2007 1:34 am

Re: Restarting Footnote Numbers for Each Chapter

Postby Bill » Thu Aug 30, 2012 8:36 pm

billquinn wrote:Okay, here's where I am right now.

(1) I've combined two chapters, each an odt file, to create one single odt file.
(2) I removed the header.

Headers don't determine where a new chapter starts.

billquinn wrote:(3) The footnotes currently form one sequence, starting at 1 for chapter 1 and 11 for chapter 2.
(4) These chapters already have the lines "Chapter 1" and "Chapter 2" as the first line of the first page of each chapter, respectively.

This tells a reader where a new chapter starts, but Writer uses a particular paragraph style to determine where a new chapter starts.

billquinn wrote:(5) I went to Tools ---> Footnotes/Endnotes and set "Counting" to "Per Chapter."
(6) I highlighted the line "Chapter 1" and then went to Format ---> Paragraph and clicked the tab "Outline & Numbering." In that window I set "Outline level" to read "Level 1." Then I repeated the process for the line "Chapter 2" in the first page of chapter 2.

Directly setting the Outline level should never be necessary. The paragraph style applied to chapter titles should automatically set the level to Level 1.

billquinn wrote:I had high hopes! It was such a simple routine. But it didn't work. The footnotes still run in a single sequence from 1 to 56, where chapter 2 still starts with footnote 11 instead of 1 for a new sequence.

What am I doing wrong?

The paragraph style associated with Outline level 1 in Tools > Outline numbering must be applied to the first line (the chapter title) of a new chapter. By default, the Heading 1 paragraph style is associated with Outline level 1. If a different paragraph style is associated with Outline level 1, then you must apply that style to the chapter titles.
Bill
Volunteer
 
Posts: 7331
Joined: Sat Nov 24, 2007 6:48 am

Re: Restarting Footnote Numbers for Each Chapter

Postby kenmorgan » Thu Aug 30, 2012 9:15 pm

Thanks for the perseverance, RGB. I got it working--and made an amazing discovery. What I described in my steps above actually does work, but not until you close and then reload the file. Then the footnotes for chapter 2 are renumbered and start with 1.

However, if you reverse my steps (5) and (6) above, then the footnotes in chapter 2 renumber immediately without closing and reopening the file.

I started this new experiment from scratch by recombining the original two files to make sure I was starting with "fresh game." All this worked without ever going to Tools → Outline Numbering. Also, I DID have some direct formatting on the lines "Chapter 1" and "Chapter 2" when I highlighted those lines: before the two files were combined, these two lines had direct formatting consisting of centering and a different font and font size from the rest of the chapter.

Isn't that interesting!?!?!

Bill
CentOS 6 Linux
Native Apache Open Office 4.1.3
User avatar
kenmorgan
 
Posts: 120
Joined: Sat Sep 13, 2008 2:03 pm
Location: Georgia

Re: [Solved] Restarting Footnote Numbers for Each Chapter

Postby DavideAndrea » Mon Jun 17, 2019 3:21 pm

Solution.

1. Place each chapter into its own section
- menu Insert / Section...

2. Edit each section to restart endnote numbering
- menu Format / Sections ...
- Edit sections dialog opens
- Click Options... button on the right
- Select Footnotes/Endnotes tab
- Endnotes section (bottom half of dialog)
- Check Collect at end of section
- Check Restart numbering
OpenOffice 4.1.1 on Windows Vista
DavideAndrea
 
Posts: 10
Joined: Thu Aug 23, 2018 1:35 am


Return to Writer

Who is online

Users browsing this forum: No registered users and 14 guests