[Solved] Unable to change read-only doc to edit it

Discuss the word processor

[Solved] Unable to change read-only doc to edit it

Postby Jimblue » Wed Apr 23, 2008 10:21 pm

Welcome beginner. Please answer all of the questions below which may provide information necessary to answer your question.
-----------------------------------------------------------------------------------------------------------
Which version of OpenOffice.org are you using? 4.2
What Operating System (version) are you using? WinXP sp2
What is your question or comment?

I am trying to use a job application file that is set to read only. I checked the options, tools, security and it doesn't have anything there for me to uncheck. I tried to 'save as' a file that is editble, but I didn't find anything to let me do that. I did try to save to a different filename, still read-only when I load it. I also tried saving it to various Word formats, again no difference.

I did try the 'edit file' button, but it wouldn't allow access to the file either.

The Word doc consists of tables to fill in with information. As my hand writting is very bad, I spend lots of time typing on a computer, I would prefer to fill it out using the keyboard over a pen.

I did search both the OpenOffice 4.2 help file in the program and here. No info on how to change a read-only document to an editible one.

Its probably something that is obvious, but not to me.

Thanks,
Jim
Last edited by Jimblue on Fri Apr 25, 2008 4:22 pm, edited 1 time in total.
Jimblue
 
Posts: 7
Joined: Wed Apr 23, 2008 10:08 pm

Re: unable to change read-only doc to edit it

Postby Villeroy » Wed Apr 23, 2008 11:41 pm

The file may be stored at some location where you don't have permission to write or where writing is physically impossible (CD-Rom, DVD).
Menu:File>SaveAs... lets you save a copy of that file somewhere in your personal folder ("My Files") where you can write and delete whatever you like.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17245
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: unable to change read-only doc to edit it

Postby Jimblue » Wed Apr 23, 2008 11:50 pm

I downloaded the file from their web site to my hard drive.

Doing a save as to a different filename has no effect. It still says 'read-only' in the title bar.
Jimblue
 
Posts: 7
Joined: Wed Apr 23, 2008 10:08 pm

Re: unable to change read-only doc to edit it

Postby Villeroy » Wed Apr 23, 2008 11:58 pm

Sorry, I don't use Windows and this seems to be one of these typical Windows related problems. I can't help further. Let's wait for the cavalry to arrive soon.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17245
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: unable to change read-only doc to edit it

Postby keme » Thu Apr 24, 2008 12:04 am

The file may have the "read only" (or "write protected") attribute set. Try right clicking the file in Explorer and select Properties. The read only atribute should be a checkbox near the bottom left of the dialog. Untick.
Attachments
fileproperties.gif
Dialog from Norwegian WinXP version
OOo 3.3.0 and Apache OOo 3.4.1/4.0.0, on Ms Windows 7 and Mac OS-X.
User avatar
keme
Volunteer
 
Posts: 1601
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway

Re: unable to change read-only doc to edit it

Postby Villeroy » Thu Apr 24, 2008 12:07 am

Jimblue wrote:I downloaded the file from their web site to my hard drive.

Doing a save as to a different filename has no effect. It still says 'read-only' in the title bar.

keme wrote:The file may have the "read only" (or "write protected") attribute set.

Does that mean that you can download (generate a copy of) a file and then you don't have write access to it?
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17245
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: unable to change read-only doc to edit it

Postby keme » Thu Apr 24, 2008 12:15 am

Villeroy wrote:
Jimblue wrote:I downloaded the file from their web site to my hard drive.

Doing a save as to a different filename has no effect. It still says 'read-only' in the title bar.

keme wrote:The file may have the "read only" (or "write protected") attribute set.

Does that mean that you can download (generate a copy of) a file and then you don't have write access to it?

If the "download" is a file system copy operation (which it sometimes is under Windows), the file attributes may be kept. Normally you don't have write access to a remote file, so Windows will set the readonly attribute on the target file. I see the same thing when copying files from CDs.
OOo 3.3.0 and Apache OOo 3.4.1/4.0.0, on Ms Windows 7 and Mac OS-X.
User avatar
keme
Volunteer
 
Posts: 1601
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway

Re: unable to change read-only doc to edit it

Postby Villeroy » Thu Apr 24, 2008 12:22 am

For a Linux user this sounds completely absurd.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17245
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: unable to change read-only doc to edit it

Postby Jimblue » Thu Apr 24, 2008 12:41 am

I checked Properties, its not set to read only.

I even went in and reset it via command line attrib -r no change. I did try editing it again. For a moment it asked me if I wanted to edit a copy of the file. I said yes and saved it to another filename. But it only helps with part of the document. Other parts are still read only.

For the download, I did a 'save as' from their web site to my hard drive.
Jimblue
 
Posts: 7
Joined: Wed Apr 23, 2008 10:08 pm

Re: unable to change read-only doc to edit it

Postby Dave » Thu Apr 24, 2008 12:50 am

If an open link [no membership or any such] can you post the URL here and I'll download the file and take a look before commenting.

David.
Dave
 
Posts: 1011
Joined: Sun Dec 23, 2007 6:53 pm

slightly OT Re: unable to change read-only doc to edit it

Postby keme » Thu Apr 24, 2008 12:58 am

Wandering off the "beginners" turf, I guess (though maybe not). In any case, as far as the original question is concerned, this posting can be safely disregarded.
Can't test linux at the moment, but in OpenBSD 3.9 the file system copy command (cp) behaves exactly like I describe for Windows. When copying files with varying file permissions, those permissions (or file mode) are kept on the copies (targets). The cp manpage says the utility is "expected to be POSIX.2 compatible", which goes for linux too, I believe, though that may not be all there is to it...

I did a "quick and dirty" test under the following conditions:
- Tested the "user" mode settings only (they're untouched by the umask)
- umask 022
- didn't use the "preserve" (-p) option
Last edited by keme on Thu Apr 24, 2008 1:04 am, edited 1 time in total.
OOo 3.3.0 and Apache OOo 3.4.1/4.0.0, on Ms Windows 7 and Mac OS-X.
User avatar
keme
Volunteer
 
Posts: 1601
Joined: Wed Nov 28, 2007 10:27 am
Location: Egersund, Norway

Re: unable to change read-only doc to edit it

Postby Jimblue » Thu Apr 24, 2008 12:59 am

open link. Just scroll down the page and look for the Word Job Application for Employment doc.

http://www.mgccc.edu/jobs.htm

I just went into Windows properties and changed the author's name to mine, saved it, and it appears to be editable now. I get 'Textnumber' for each part of the tables. There are 5 []s in every field for unprintable characters. Writer now lets me takes those 5 squares out and put my own text in, it didn't before.

edit:

I can edit by double clicking on the text field, a prompt comes up with 'Input Field' as a header. I take out the 5 []s and add my own text. I couldn't remove the []s earlier, nor add my own text.

I get the impression they messed up the permissions when they created the document.
Jimblue
 
Posts: 7
Joined: Wed Apr 23, 2008 10:08 pm

Re: unable to change read-only doc to edit it

Postby Jimblue » Thu Apr 24, 2008 5:04 pm

Odd. Now I have some strange thing.

Some of the text comes out as Bold and some comes out as Normal text. I don't have Bold selected.
Jimblue
 
Posts: 7
Joined: Wed Apr 23, 2008 10:08 pm

Re: unable to change read-only doc to edit it

Postby Jimblue » Fri Apr 25, 2008 3:31 am

Someone I know locally will help me Friday and see if he can remove the read-only from the document. He suspects that the creator of the document passworded the tables in the file.
Jimblue
 
Posts: 7
Joined: Wed Apr 23, 2008 10:08 pm

Re: unable to change read-only doc to edit it

Postby Hagar Delest » Fri Apr 25, 2008 9:28 am

Open the Navigator (F5), go to the Sections tree, right click on the section entry, Edit and uncheck the Protected option in the Write protection area. Then, do what you want in the fields.

For the 5 []s, that's a known issue, there should be a thread about that here IIRC.

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.

NB: moved the thread to the Writer forum.
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25072
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: unable to change read-only doc to edit it

Postby Jimblue » Fri Apr 25, 2008 4:21 pm

Yes, this fixes the problem.
Jimblue
 
Posts: 7
Joined: Wed Apr 23, 2008 10:08 pm

Re: [Solved] Unable to change read-only doc to edit it

Postby ANTHONY.G » Tue Sep 08, 2009 9:15 pm

Hi there,

I made a copy of the original document, and was then able to edit and write on the copy.
Hope this helps.
OpenOffice 3.1 on Windows Xp home
ANTHONY.G
 
Posts: 1
Joined: Tue Sep 08, 2009 9:08 pm

Re: [Solved] Unable to change read-only doc to edit it

Postby JBNF » Tue Jan 26, 2010 11:42 pm

Save the file as *.RTF -- this works for me!
Joshua Foreman
Open Office 3.1.1
Windows XP SP3
JBNF
 
Posts: 1
Joined: Tue Jan 26, 2010 11:37 pm

Re: [Solved] Unable to change read-only doc to edit it

Postby RoryOF » Wed Jan 27, 2010 12:05 am

JBNF wrote:Save the file as *.RTF -- this works for me!


Saving to .rtf may do horrible things to your formatting - be warned!
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14328
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Another solution to a similar problem.

Postby MRCAB » Fri Dec 31, 2010 4:21 am

I just thought I'd share my experience here in case others run into the same problem I had. Basically I had the same issue but none of the solutions here worked for me. Here's what happened:

I'd just recently installed Windows XP onto a new HDD and went thought the whole proses of taking ownership of the files on my old HDD (that was a hassle in itself) when I came across an .odt file that gave me the issue in question. As it turned out, that particular .odt file had crashed when I had my previous HDD installed and it still had the ".~lock.(file name)#" file sitting there, hidden, and was causing the .odt file to be locked. [This is the file that allows recovery of a Open Office Write document if it crashed(or similar instance) before you were able to save your progress.]

Instead of swapping out the new HDD and placing to old one back and restarting Windows with that, opening the .odt file and allowing it to "restore the crashed file", I knew that I'd saved the .odt file before I had the issue of Open Office crashing (along with other programs —it was my fault). So what I did was go to Tools>Folder Options, then the "View" tab, selected “show hidden files and folders”; next I simply removed the hidden recovery file[".~lock.(file name)#"], and I was able to open the .odt file fine; and it was no longer "read only".

I know this is odd and this might not ever happen to anyone else, but there's always the chance that this same thing might happen with someone else and they might not know it's that darn recovery file preventing them from opening their .odt document. :knock:
OOo 3.2.1 on desktop Windows XP Professional & EeePC w/ Windows 7 + Jolicloud
MRCAB
 
Posts: 4
Joined: Wed Jan 21, 2009 7:10 am

Re: [Solved] Unable to change read-only doc to edit it

Postby suzicoleman » Wed Jan 12, 2011 12:54 am

I had this trouble with version 3.2 and Win 7. I right-clicked on the open document and chose "edit" option and was able to edit my document. No other solution posted here worked for me.
Open Office 3.2 Windows 7
suzicoleman
 
Posts: 1
Joined: Wed Jan 12, 2011 12:50 am

Re: [Solved] Unable to change read-only doc to edit it

Postby norinrad » Wed Jan 19, 2011 12:16 am

same problem. everything working fine until yesterday. Then today, every file I tried to open in openoffice would be read only. Ive not had any crashes, none of the files have changed location. The only solution above that worked for me was the the one from suzicoleman Tue Jan 11, 2011 11:54 pm
Openoffice 3.2.1 on Windows Vista Home
norinrad
 
Posts: 1
Joined: Tue Jan 18, 2011 11:41 pm

Re: [Solved] Unable to change read-only doc to edit it

Postby Hagar Delest » Wed Jan 19, 2011 2:14 pm

Any MS update?
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25072
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Unable to change read-only doc to edit it

Postby coopenic » Wed Jan 08, 2014 6:36 am

Often people will have locked a "section" of the document; often they will make the whole document a section. After you have made sure that the document is not read only, and have turned on the "edit" button described by others, go to menu item "Format ... Sections" where you can un-tick the write protection or remove the section marker. If the "Sections ..." menu item is not available then it probably means that there are no sections so this is not your problem.
OpenOffice 3.4.1 on Windows 7 professional
coopenic
 
Posts: 1
Joined: Wed Jan 08, 2014 6:25 am

Re: [Solved] Unable to change read-only doc to edit it

Postby Villeroy » Thu Jan 09, 2014 12:30 am

coopenic wrote:Often people will have locked a "section" of the document; often they will make the whole document a section. After you have made sure that the document is not read only, and have turned on the "edit" button described by others, go to menu item "Format ... Sections" where you can un-tick the write protection or remove the section marker. If the "Sections ..." menu item is not available then it probably means that there are no sections so this is not your problem.

+1
Sections in Writer, sheets and cells in Calc, macro code can be protected within some document.
Then there are two protection methods on document level (File>SaveAs... with password) against loading and against editing while you can push the edit button on the main toolbar (mistakenly) at any time which is a useful feature against accidental editing.
Finally there are different permissions on file system level depending on the file system type. Windows has a read-only flag inherited from its DOS anchestor. The absurd thing is that this flag applies to every new copy too, even when you let the respective application save the file via File>SaveAs. In addition the NTFS file system has a "normal" set of file permissions for users and groups.
Oh, and then there are internet applications (browser, mail client etc) which save viewed internet content in temporary read-only files which makes perfect sense because the user decided not to download these files to a permanent directory. People blame OpenOffice for these files although OpenOffice did not create them. OO just opens a read-only file dropped by some other application.
Not to mention network access and the Base component with its various backends and frontend tools.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17245
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Solved] Unable to change read-only doc to edit it

Postby sunilsen » Wed Mar 26, 2014 11:13 am

Simply right click on document and open its properties and then uncheck read-only option and click on apply.
OpenOffice 3.3 on Windows XP-Professional SP3
sunilsen
 
Posts: 1
Joined: Wed Mar 26, 2014 11:08 am

Re: [Solved] Unable to change read-only doc to edit it

Postby Villeroy » Wed Mar 26, 2014 3:50 pm

sunilsen wrote:Simply right click on document and open its properties and then uncheck read-only option and click on apply.

IF it happens to be locked on file system level AND IF you have the file system privileges to unlock the file. However, there are many levels of locking on file system level, on document level, within the document plus encryption of the entire document. Possibly you may need a copy of the file within your own part of the file system where you have write privileges ("My Files", home folder, temp folder).

If you see the document on the screen while not being able to edit, hit the edit button on the standard tool bar. Either one of the following will happen:
You will be prompted for a new working copy if the file is protected on file system level. You can work with the new working copy and you may save it elsewhere.
You will be prompted for a password if it had been write-protected on document level with a password. Saving the same document elsewhere will also save the write-protect password so this won't help without knowing the password.
You will be able to edit that document if it was write-protected without password.
If you still can't edit the document, document sections, spreadsheet cells, frames, shapes etc. have been locked individually. In most cases this can be resolved without giving any password or with some cheating.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17245
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany


Return to Writer

Who is online

Users browsing this forum: No registered users and 36 guests