[Solved] Language Not Set for Newly Created Document

Discuss the word processor

[Solved] Language Not Set for Newly Created Document

Postby 3guesses » Tue Feb 21, 2012 9:29 pm

Hi,

I have been using OO on Windows XP for a number of years (curently on 3.3.0), and I thought this problem had been fixed a few versions ago. Anyway, my problem is that when I create a new OO text document via Windows Explorer (right click in a folder, select New->OpenDocument Text), there is no language set for the document when I open it - I have to manually set it each time using the 3rd segment along (after "Page 1/1" segment, and then "Default" = page style segment) on the status bar which is always defaulted to "[None]".

Also, when I install OO (fresh install on a fresh Windows install), at the end of the install I go to ->Start->Programs->OpenOffice.org 3.3->OpenOffice.org, click on Text Document and go to ->Tools->Options->Language Settings->Languages to check that "Default language for documents - Western" is set to "English (UK)", but then, after creating a new document via Windows Explorer as above, opening that document and going to ->Tools->Options->Language Settings->Languages I find that "Default language for documents - Western" is now set to "German (Germany)"!

Basically, I want any new document created to default its language to "English (UK)" - how do I do that, and is what I have described above a bug or bugs?

Thanks,

Alex
Last edited by Hagar Delest on Tue Feb 21, 2012 11:23 pm, edited 3 times in total.
Reason: tagged [Solved].
OpenOffice 3.3.0 (Build 9567) on Windows XP Pro SP3
3guesses
 
Posts: 19
Joined: Tue Feb 21, 2012 9:05 pm

Re: Language Not Set for Newly Created Document

Postby Hagar Delest » Tue Feb 21, 2012 9:38 pm

Hi and welcome to the forum!

See Spellcheck not working with new file by right click.

Please add '[Solved]' at the beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28681
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Language Not Set for Newly Created Document

Postby 3guesses » Tue Feb 21, 2012 11:00 pm

OK, thanks very much - I guess that means it is a bug. I was sure I noticed that it had been fixed a few versions ago!
OpenOffice 3.3.0 (Build 9567) on Windows XP Pro SP3
3guesses
 
Posts: 19
Joined: Tue Feb 21, 2012 9:05 pm

Re: [Solved](Really) Language Not Set for Newly Created Docu

Postby Maelstorm » Tue May 01, 2012 7:54 am

I'm kinda surprised as to why such a long standing bug is still around considering the fix is quite simple. :? The problem is not OpenOffice in and of itself. The problem is the template file that is used when you select New>OpenDocument Text. When you do that, the file at (On Win XP Machines) C:\Documents and Settings\All Users\Templates\soffice.odt is copied to the current location and renamed by what is in the registry prefixed with "New." Here are the steps to permanently fix the problem on Windows XP machines.

1. Navigate C:\Documents and Settings\All Users\Templates The directory is hidden, so you may need to enable displaying hidden files to see it. To do this on the menus, Tools Menu>Folder Options>View Tab and click Show Hidden Files and Folders.

2. Locate soffice.odt and make a backup copy of it.

3. Open soffice.odt and make changes to it.

4. Save file.

All subsequent new documents will have the new settings when you select New>OpenDocument Text. Note that you cannot add files to this directory and have them show up on the menu automatically. Not only does the file have to be present, but there also must be an entry in the registry for it as well.

Other than that,

Enjoy :D
OpenOffice 4.1.2 on Microsoft Windows 10 Professional
Maelstorm
 
Posts: 2
Joined: Tue May 01, 2012 7:29 am


Return to Writer

Who is online

Users browsing this forum: No registered users and 14 guests