[Solved] Spellcheck not working??

Discuss the word processor

[Solved] Spellcheck not working??

Postby jaycee6828 » Thu Jan 19, 2012 6:34 pm

I have a document in Writer open and when I select Tools>Spellcheck I get a window pop up saying spellcheck complete and it is showing no errors or results of any kind.

I thought this was strange as it happened every time and my spelling isn't that perfect so I introduced some spelling errors into the document but it still comes up and tells me the spellcheck is complete with no errors and the only option I have is that of closing the window.

Surely this is not normal behaviour is it?

Any comments on what may be happening here?
Last edited by Hagar Delest on Thu Jan 19, 2012 10:45 pm, edited 1 time in total.
Reason: tagged [Solved].
Open Office 3.4.1 on Ms Windows 7
jaycee6828
 
Posts: 124
Joined: Mon May 05, 2008 10:16 am

Re: Spellcheck not working??

Postby Villeroy » Thu Jan 19, 2012 6:40 pm

Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17243
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Spellcheck not working??

Postby jaycee6828 » Thu Jan 19, 2012 6:55 pm

I have been through the link you gave and at the end cannot even see the wavy lines in the examples although abc does have the red line beneath it.
As far as I can make out it is the English (UK) dictionary I have.

But still no errors appear on the spellcheck.

Should I re-install LibreOffice?
Open Office 3.4.1 on Ms Windows 7
jaycee6828
 
Posts: 124
Joined: Mon May 05, 2008 10:16 am

Re: Spellcheck not working??

Postby Hagar Delest » Thu Jan 19, 2012 7:04 pm

What is the language shown in the status bar?
Do you have multiple documents opened from a long time? Try to close them all, shut down the quickstarter and restart OOo.
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25071
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Spellcheck not working??

Postby Bill » Thu Jan 19, 2012 7:16 pm

jaycee6828 wrote:As far as I can make out it is the English (UK) dictionary I have.

Having the dictionary is necessary, but it is also necessary to set the language for the document. A document language setting of [none] turns off spellcheck.
Bill
 
Posts: 3309
Joined: Sat Nov 24, 2007 6:48 am

Re: Spellcheck not working??

Postby jaycee6828 » Thu Jan 19, 2012 7:51 pm

The language shown in the bar at the bottom is English (UK), I only have one document open at a time normally.

I have tried starting from within Program Files but do not use the quickstarter.

Each seperate part of LibreOffice is programmed onto an F Key and that is where it starts if I want a new doc or spreadsheet etc; normally it is opened from an existing doc or spreadsheet.

Tools>Language>For Selection has English(UK) ticked.
Open Office 3.4.1 on Ms Windows 7
jaycee6828
 
Posts: 124
Joined: Mon May 05, 2008 10:16 am

Re: Spellcheck not working??

Postby Hagar Delest » Thu Jan 19, 2012 9:34 pm

Do you see the blue tick and the English (UK) entry in the field at top of the spellcheck dialog when you open it (F7)?
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25071
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Spellcheck not working??

Postby jaycee6828 » Thu Jan 19, 2012 9:48 pm

No, when you click spellcheck (F7) a window opens which says spellcheck complete but at the op of the spellcheck window itself it says spellcheck none
Open Office 3.4.1 on Ms Windows 7
jaycee6828
 
Posts: 124
Joined: Mon May 05, 2008 10:16 am

Re: Spellcheck not working??

Postby Hagar Delest » Thu Jan 19, 2012 9:53 pm

Select the text and hit Ctrl+M. Does it work better?
If you go to the menu Tools>Options>Language Settings>Writing Aids, click the Edit modules button, do you see the dictionary entry in the drop-down list?
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25071
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Spellcheck not working??

Postby Bill » Thu Jan 19, 2012 10:22 pm

jaycee6828 wrote:No, when you click spellcheck (F7) a window opens which says spellcheck complete but at the op of the spellcheck window itself it says spellcheck none


Spelling [None] means that no dictionary is available for the document language. If the English dictionary was installed with OOo, it includes Englist (UK). To make it available, select Tools > Options > Language Settings > Writing Aids. Untick, then retick the Hunspell Spellchecker check box. That should make all installed language modules available.
Bill
 
Posts: 3309
Joined: Sat Nov 24, 2007 6:48 am

Re: Spellcheck not working??

Postby jaycee6828 » Thu Jan 19, 2012 10:44 pm

Thanks Bill, that works now - easy when you know how!!!
Open Office 3.4.1 on Ms Windows 7
jaycee6828
 
Posts: 124
Joined: Mon May 05, 2008 10:16 am

Re: Spellcheck not working??

Postby Hagar Delest » Thu Jan 19, 2012 10:45 pm

Bill wrote:To make it available, select Tools > Options > Language Settings > Writing Aids. Untick, then retick the Hunspell Spellchecker check box. That should make all installed language modules available.

:super:
Nice trick, had never heard of that before!
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25071
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spellcheck not working??

Postby dwelch » Thu Aug 16, 2012 1:25 am

I recently downloaded 3.4. The spellcheck underlines all words. I've read the tutorials and checked all the settings, made sure the English dictionary is downloaded also. I've read all the post on this topic.
Now I'm at this point. I want to change the name of AppData\Roaming\OpenOffice.org\3\user to "user.old" as suggested. I get a message that says I need permission. I'm logged in as administrator and have all the boxed checked under security tab.
What do I do now?
OpenOffice 34., Windows Vista
dwelch
 
Posts: 4
Joined: Fri Aug 10, 2012 9:12 pm

Re: [Solved] Spellcheck not working??

Postby RoryOF » Thu Aug 16, 2012 1:30 am

You should only try this when OpenOffice is closed.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14325
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spellcheck not working??

Postby Bill » Thu Aug 16, 2012 3:48 am

dwelch wrote:I want to change the name of AppData\Roaming\OpenOffice.org\3\user to "user.old" as suggested. I get a message that says I need permission. I'm logged in as administrator and have all the boxed checked under security tab.
What do I do now?

Being logged in as administrator isn't required to rename the folder. When OOo is running, a lock file will be opened inside the folder and permission to rename the folder will be denied. Shut down OOo, includiing the Quickstarter. The lock file will be deleted and the folder can then be renamed even if logged in as a standard user instead of administrator.
Bill
 
Posts: 3309
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Spellcheck not working??

Postby splatman » Tue Aug 28, 2012 3:09 am

This is pathetic. I download OO, I install OO, and I expect the spellcheck to just work. No amount of setting the default language etc makes it NOT forget on new documents.

I am just a user. Trying to use an office suite. I am not a geek and should not have read eye-glazing instructions on how to hack files, download new bits or anything else beyond setting some options.

So listen up all you developers: If you want to take on the Big Boys in Redmond, you have to produce something that Just Works.

And no, I am not ungrateful. I sit in a roomfull of geeks and I am the only one who has the patience to persist or even bother with OO. Seriously, you have to get rid of these kinds of glitches.

And yes, I am frustrated.
splatman
 
Posts: 3
Joined: Fri Mar 07, 2008 4:53 am

Re: [Solved] Spellcheck not working??

Postby splatman » Tue Aug 28, 2012 6:17 am

After that above outburst I observe this: I am typing a document. I highlight everything and set the language - English (Australia). I happily type away. Then I insert a new line and select style Heading2. The language indicator in the status bar immediately goes to language (none)

That is (surely!) a clear bug. I have had these problems with spell checking for many years.

It doesn't appear to happen if the new line is at the end of my document.
splatman
 
Posts: 3
Joined: Fri Mar 07, 2008 4:53 am

Re: [Solved] Spellcheck not working??

Postby RoryOF » Tue Aug 28, 2012 6:58 am

What is your standard language? By that, I mean the normal language in which you type most of your documents? If you have set up OpenOffice correctly (and remember, you are the one who wants to set up options) this language should be automatically chosen when you start a new document - no need to select everything and set a language explicitly each time; this indicates clearly that you have not set everything as it should be set.

Look at the tutorial
[Troubleshooting] Spell check in OOo 3.x
and also
[Tutorial] Spell check and Language configuration
and make the few settings suggested, then restart OpenOffice. Best to restart your computer entirely.

If following the tutorial instructions is too much for you as instanced by your "eye-glazing" comment, perhaps it is time to request help from some of the "roomfull of geeks" around you. It can also be helpful to print out the tutorial and mark off each setting as you make it.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14325
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spellcheck not working??

Postby Bill » Tue Aug 28, 2012 9:21 am

splatman wrote:This is pathetic. I download OO, I install OO, and I expect the spellcheck to just work. No amount of setting the default language etc makes it NOT forget on new documents.

It does "just work" if you set your default language correctly and you create new documents using File > New > Text Document on the AOO Menu Bar. Highlighting text and changing the language for the highlighted text WILL NEVER change the default language. If you create new documents by right-clicking and selecting New > OpenDocument Text, you will have to take additional steps to ensure that those documents have a default language setting. See this thread for details: 3.3 spellcheck default template fails on right-click
Bill
 
Posts: 3309
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Spellcheck not working??

Postby Villeroy » Tue Aug 28, 2012 9:51 am

splatman wrote:After that above outburst I observe this: I am typing a document. I highlight everything and set the language - English (Australia). I happily type away. Then I insert a new line and select style Heading2. The language indicator in the status bar immediately goes to language (none)

That is (surely!) a clear bug. I have had these problems with spell checking for many years.

It doesn't appear to happen if the new line is at the end of my document.

Why? There must be a reason for this. I can not reproduce this.

Spell checking always worked for me and in all those years I could never reproduce any of the reported problems with it. New documents from scratch use the language of my system. New documents from template use the language of that template. With languages defined in styles it uses the language of the respective style. If you are totally unaware of templates and styles you should use a more simple word processor such as word pad or abiword.
http://abiword.org/ is a great program. I use it more often than Writer.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17243
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Solved] Spellcheck not working??

Postby Bill » Tue Aug 28, 2012 4:33 pm

Villeroy wrote:Spell checking always worked for me and in all those years I could never reproduce any of the reported problems with it. New documents from scratch use the language of my system.

Is the language of your system German? Creating a new document in Windows by right-clicking and selecting New > OpenDocument Text creates a copy of the soffice.odt file which is installed by OOo/AOO. German is the default language set in that file even if the en-US version is installed. This bug was confirmed in OOo 2.0 and there are now more than a dozen bug reports about this problem.

https://issues.apache.org/ooo/show_bug.cgi?id=58014
Bill
 
Posts: 3309
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Spellcheck not working??

Postby Danfree » Thu Oct 11, 2012 2:10 am

splatman wrote:This is pathetic. I download OO, I install OO, and I expect the spellcheck to just work. No amount of setting the default language etc makes it NOT forget on new documents.

I am just a user. Trying to use an office suite. I am not a geek and should not have read eye-glazing instructions on how to hack files, download new bits or anything else beyond setting some options.

So listen up all you developers: If you want to take on the Big Boys in Redmond, you have to produce something that Just Works.

And no, I am not ungrateful. I sit in a roomfull of geeks and I am the only one who has the patience to persist or even bother with OO. Seriously, you have to get rid of these kinds of glitches.

And yes, I am frustrated.


Amen. Upgrading should not screw up SPELLCHECK. I have uninstalled, downloading and installing 3 times including using Revo Uninstall Free verison. The spellcheck still does not work. I am considering going back to a previous version.
OpenOffice 3.4.1 on Window 7
Danfree
 
Posts: 1
Joined: Thu Oct 11, 2012 1:53 am

Re: [Solved] Spellcheck not working??

Postby Bill » Thu Oct 11, 2012 6:59 am

Danfree wrote:
splatman wrote:This is pathetic. I download OO, I install OO, and I expect the spellcheck to just work. No amount of setting the default language etc makes it NOT forget on new documents.

I am just a user. Trying to use an office suite. I am not a geek and should not have read eye-glazing instructions on how to hack files, download new bits or anything else beyond setting some options.

So listen up all you developers: If you want to take on the Big Boys in Redmond, you have to produce something that Just Works.

And no, I am not ungrateful. I sit in a roomfull of geeks and I am the only one who has the patience to persist or even bother with OO. Seriously, you have to get rid of these kinds of glitches.

And yes, I am frustrated.



Amen. Upgrading should not screw up SPELLCHECK. I have uninstalled, downloading and installing 3 times including using Revo Uninstall Free verison. The spellcheck still does not work. I am considering going back to a previous version.

You're wasting your time reinstalling or going back to a previous version. Reset your user profile. If that doesn't solve the problem, provide a description of the problem.
Bill
 
Posts: 3309
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Spellcheck not working??

Postby Richardb123 » Tue Oct 16, 2012 2:15 am

I too have endless problems with this. Got it working a few months back (after searching the web and trying different things for hours), then along came the latest version of OO and now no spell check again. Very frustrating. And the potential fix listed here no longer works, btw, because that box is no longer there to be clicked and unclicked. Open a brand new file, no spell check. Set language again, no spell check. Not solved. Doesn't Just Work. Too bad. A few years ago it worked nicely.

Any ideas that do not require a degree in computer science?
OpenOffice 3.3
Richardb123
 
Posts: 4
Joined: Fri May 25, 2012 6:21 am

Re: [Solved] Spellcheck not working??

Postby Bill » Tue Oct 16, 2012 4:23 am

OpenOffice 3.3 isn't the latest version. What is your OS?
Bill
 
Posts: 3309
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Spellcheck not working??

Postby bayouman » Mon Nov 26, 2012 12:30 am

I have been looking for an answer, but have yet to find one that solves the spell check problem. I found some possible answers with seeming long drawn out procedures. I'm sorry, but I just got lost with one of those jumping through hoops fixes. I tried downloading the English dictionary with no results. I just don't understand that if supposedly there isn't anything wrong with the new update to 3.4.1, why doesn't the spell check work when it is installed. Even uninstalling it and re-installing it, the results are the same. Since I have updated to 3.4.1, spell check has never worked. I have language set to English USA and yes the check mark is there. When I click spell check/grammar button, it shows each word misspelled. In the suggestions box it will either show something weird like 2 or 3 letters as a suggestions for possible correction, or will show No Suggestions". When I click IGNORE ALL, it simply goes to the next word although it too is correctly spelled. It continues to do so each time I hit IGNORE ALL, yet all the words are correctly spelled.
Open Office 3.4.1 Windows XP
bayouman
 
Posts: 2
Joined: Sun Nov 25, 2012 11:50 pm

Re: [Solved] Spellcheck not working??

Postby Bill » Mon Nov 26, 2012 5:22 am

bayouman wrote:I just don't understand that if supposedly there isn't anything wrong with the new update to 3.4.1, why doesn't the spell check work when it is installed.

Did you update an old version? Did you reset the user profile?
Bill
 
Posts: 3309
Joined: Sat Nov 24, 2007 6:48 am

Re: [Solved] Spellcheck not working??

Postby bayouman » Mon Nov 26, 2012 10:15 pm

Yes, I clicked update, but the response was that my version was up to date, but it was doing this before my updating. I uninstalled and reinstalled with no change. Is a profile reset a requirement after updating or are you asking me if I did something to reset it? I'm not aware of how to reset the user profile.

I forgot to mention in my post that when I click Auto SPELL CHECK, most all words are underlined in a red wavy line. I also forgot to mention I now get a crash report on the document I was working on, most everytime I open Open Office the next time. Fortunately, every time this happens, recovery is easy and has never failed yet, but I do notice this is a regular event now. I checked to see if the older version was still out there for download, but didn't see one unless I missed it. The previous version worked fine. Your help appreciated
Open Office 3.4.1 Windows XP
bayouman
 
Posts: 2
Joined: Sun Nov 25, 2012 11:50 pm

Re: [Solved] Spellcheck not working??

Postby Hagar Delest » Mon Nov 26, 2012 10:21 pm

AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25071
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spellcheck not working??

Postby akeisato » Wed Jul 17, 2013 7:56 pm

Alright take this with a grain of salt and try again.

English is NOT my first language. I study in English, because it's universal. I can not spell perfectly in English. I have two projects that should be typed up and handed in tomorrow. My Problem: Originally (a month ago) my spell checker would not check my spelling at all, that was fine I read the forums and fixed it. It was okay. Yesterday the program was still working fine - but now suddenly today NO MATTER what English Language I use South African, USA, UK - you bloody name it - NONE of them work: It underlines ALL my text as incorrect. I saw that this problem has occurred before... Fine, I followed the forum thread - tried all the solutions. NONE OF THEM WORK. WHAT THE FUCK! Now thanks to your sad excuse for a program, which I as the user may full well assume has all the basic elements of a word processor down, I am incapable of completing my work.

I am sorry, but this is shit service. I would never release a product with such a major bug, you test it thoroughly before the release. At least with other open source programs if the latest software is buggy you can download previous stable versions - but, Oh No! Not with you - you're just regular geniuses. I am sorry if I seem a bit brutal, but honestly have enough pride in your own work to do it right. OpenOffice.org3.4.1 is disgusting. FIX THIS BUG.
OpenOffice.org3.4.1
akeisato
 
Posts: 2
Joined: Wed Jul 17, 2013 7:29 pm

Next

Return to Writer

Who is online

Users browsing this forum: Exabot [Bot], sbar99920 and 34 guests