[Solved] Wrong chapter numbering

Discuss the word processor

[Solved] Wrong chapter numbering

Postby mimmon » Wed Mar 26, 2008 8:55 am

I'm using Heading 1 - Heading 4 Styles to hierarchize the chapters. Chapters are numbered up to third level.
My document has 8 chapters. The problem is this: if I create a new 2nd level chapter in chapters 1-4, 5.1 is created, but if I create it within 5, numbering starts with 5.2, and in chapters after 5, the numbering starts with 5.4. (Not 6.1, 7.1, but 5.4). What is the problem with chapter 5?
I use the page breaks before each 1st level chapter to start it on a new page.
Last edited by mimmon on Fri Mar 28, 2008 12:46 pm, edited 1 time in total.
mimmon
 
Posts: 2
Joined: Wed Mar 26, 2008 8:41 am

Re: Wrong chapter numbering

Postby Hagar Delest » Wed Mar 26, 2008 9:25 am

Can you upload a small file sample here?

It may come from a heading with hidden character style manually applied. Do you see a any strange heading in the Navigator (F5)?

Try to select all the headings of a same level (use the Find & Replace dialog, you can search for styles in More options) and apply the Default formatting (either by right click or hit CTRL+SHIFT+Space bar).

Thanks to add '[Solved]' in your first post title (edit button) if your issue has been fixed.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28998
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Wrong chapter numbering

Postby mimmon » Fri Mar 28, 2008 12:45 pm

I probably caused the problem with mixing bullets and numbering with outline numbering. The problem with number 5 was caused by setting start value to 5 and it applied to the whole document, not only chapter 5, where I needed that.
I did not manage to fix it within the document, so now I'm working on copying and pasting text to the new document :) Maybe this solution sounds silly, but I'm satisfied, because the problem that appears several months ago will be soon solved (hopefully) and I even learned something more about outline numbering :)
Thanks for your help.
mimmon
 
Posts: 2
Joined: Wed Mar 26, 2008 8:41 am

Re: Wrong chapter numbering - [SOLVED]

Postby Hagar Delest » Fri Mar 28, 2008 12:52 pm

mimmon wrote:I probably caused the problem with mixing bullets and numbering with outline numbering.

Yes. They don't mix together. Use Outline numbering for headings only and Bullets/Numbering for lists inside the text.

Usually, applying the default formatting works fine but sometimes, you've to :
1. Remove outline numbering in the Tools>Outline numbering dialog
2. Select all the headings of a same level (done with the Search & Replace dialog) and apply default formatting
3. Click the Bullet/Numbering until the context toolbar disappears
4. Do steps 2 & 3 for each heading level
5. Reactivate Outline Numbering.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28998
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Wrong chapter numbering

Postby TheRealOrion » Sun Oct 12, 2008 7:20 am

I'm still having trouble with this. Can someone explain this process step by step?

1. What do I have to do in order to "remove" Outline Numbering. I go to Tools -> Outline Numbering, but all I can do to 'remove' the formatting is go to the <Numbering> tab and set "1 - 10" to "None" under Number.

3. What do I click until the Bullets/Numbering "goes away"?

5. What do I do to "reactivate" Outline Numbering?

I've been fiddling with this option for the last hour and I can't sort out what I'm supposed to do, in the right sequence. I'd love to just blank the whole set of options and build them from scratch.
LibreOffice 5.2.5.1 on MacBook OS X 10.12.3, "Sierra"
TheRealOrion
 
Posts: 302
Joined: Tue Mar 04, 2008 9:43 am
Location: Vancouver, BC

Re: [Solved] Wrong chapter numbering

Postby Hagar Delest » Sun Oct 12, 2008 3:40 pm

TheRealOrion wrote:go to the <Numbering> tab and set "1 - 10" to "None" under Number.

That's it.

TheRealOrion wrote:3. What do I click until the Bullets/Numbering "goes away"?

Just click the button until the context toolbar disappears.

TheRealOrion wrote:5. What do I do to "reactivate" Outline Numbering?

Go to Tools>Outline Numbering and set the numbering as you want.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28998
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Wrong chapter numbering

Postby TheRealOrion » Tue Oct 14, 2008 11:20 am

TheRealOrion wrote:3. What do I click until the Bullets/Numbering "goes away"?

Just click the button until the context toolbar disappears.


Yes, which button and what toolbar?
LibreOffice 5.2.5.1 on MacBook OS X 10.12.3, "Sierra"
TheRealOrion
 
Posts: 302
Joined: Tue Mar 04, 2008 9:43 am
Location: Vancouver, BC

Re: [Solved] Wrong chapter numbering

Postby Hagar Delest » Tue Oct 14, 2008 1:09 pm

There are only 2 buttons for that on the standard toolbar:
Toolbar.png
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28998
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Writer

Who is online

Users browsing this forum: No registered users and 16 guests