Few images turned to black in Writer

Discuss the word processor

Few images turned to black in Writer

Postby Gamax » Tue Jan 25, 2011 4:20 pm

Hello!
I have problem, that few images in document turned to black. My procedure with images is:
- printscreen into png file
- crop in OOo draw
- convert in OOo draw to contour (i want to group image with lines, arrows,.. in write)
- copy and paste to OOo writer

After few hours of work I noticed, that few images are black (see attachment). I can't go back and I don't have backup. Can you help me?

I know, that here is another thread with black images, but there is no solution for me.
Attachments
BuggyFile.odt
(85.28 KiB) Downloaded 133 times
OpenOffice 3.2.1 on WindowsXP SP3, HP8710w
Gamax
 
Posts: 10
Joined: Tue Jan 25, 2011 4:10 pm

Re: Few images turned to black in write

Postby RoryOF » Tue Jan 25, 2011 4:48 pm

They were in glorious technicolor for me. Rename a copy of the file to buggyfile.zip, open with an archive manager (Winzip or similar) and extract the files from the Pictures folder. I suggest you then convert them to some other format (perhaps .tif?) and reinsert them into your document to allow you to proceed with it immediately, pending analysis and resolution of the problem with the .png format files.

 Edit: The image files in the Pictures directory in the archive opened correctly using an image editor, in this case Eye of Gnome under Ubuntu 10.10, so they should be accessible. The problem may be the .png filter in OOo. 
Last edited by RoryOF on Tue Jan 25, 2011 4:58 pm, edited 1 time in total.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14328
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Few images turned to black in write

Postby thomasjk » Tue Jan 25, 2011 4:54 pm

I see the same black images on 3.2.1 with Win 7.
Tom K.
Windows 7 Home Premium
LibreOffice 4.2.1.1
thomasjk
Moderator
 
Posts: 3594
Joined: Tue Dec 25, 2007 4:52 pm
Location: North Carolina

Re: Few images turned to black in write

Postby Gamax » Tue Jan 25, 2011 4:56 pm

OK, if I understeand right, this problem should not happen with tiff images?

I don't have problem with images, I have them as separated files, but I'm not happy with reinserting if it could happen again.

Thanks for reply!
Last edited by Gamax on Tue Jan 25, 2011 5:05 pm, edited 3 times in total.
OpenOffice 3.2.1 on WindowsXP SP3, HP8710w
Gamax
 
Posts: 10
Joined: Tue Jan 25, 2011 4:10 pm

Re: Few images turned to black in write

Postby RoryOF » Tue Jan 25, 2011 5:01 pm

Try a sample file with a tiff image and a .png image before you do any more work. Save the file, shut down computer, have a coffee and then restart computer and reopen the file to see if all survives through the save/shutdown/reopen process.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14328
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Few images turned to black in write

Postby Gamax » Tue Jan 25, 2011 5:07 pm

Coffee.. I hope there is time for it. :) I'll make some tests.

Concerning images. After unzip files and folders, there are only visible images and one png file with 8x8 white pixels. :(
OpenOffice 3.2.1 on WindowsXP SP3, HP8710w
Gamax
 
Posts: 10
Joined: Tue Jan 25, 2011 4:10 pm

Re: Few images turned to black in write

Postby RoryOF » Tue Jan 25, 2011 5:20 pm

I extracted one of your files, an icon panel of about 26.8 KB, inserted it into Writer 3.3 RC10, saved the file, shut down the computer (to make sure nothing was being buffered/remembered) and it opened perfectly after I restarted the computer (Ubuntu 10.10). I am seeing 14 pictures in the Pictures directory, of which only the first is of an 8x8 white pixels, all the rest are icon panels, toolbars, illustrations of building components etc. I suggest Tiff, but some other format may also be suitable.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14328
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Few images turned to black in write

Postby Gamax » Tue Jan 25, 2011 5:26 pm

Problem is, that I opened, saved, closed document many times during last week. I don't know whet it happens, because this back images are on the top of document and I worked on the bottom of document.
OpenOffice 3.2.1 on WindowsXP SP3, HP8710w
Gamax
 
Posts: 10
Joined: Tue Jan 25, 2011 4:10 pm

Re: Few images turned to black in write

Postby RoryOF » Tue Jan 25, 2011 6:48 pm

Something has changed in the saving mechanism. Each time you save a file, the entire file is saved, not just the latest section. As I see your file, it is not rendering the pictures correctly, yet they are stored correctly within it. Thomasjk had a similar result. Perhaps there can be an entry edited in one of the ancillary files that will display the pictures correctly, but I do not know enough about their internals to advise what this might be. The old OpenOffice solution may help, of deleting your User Profile; I suspect that will allow new files to save correctly, but doubt it will help your existing file.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14328
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Few images turned to black in Writer

Postby Hagar Delest » Tue Jan 25, 2011 7:05 pm

All images before section 2 are black indeed no W2k, display correctly afterward. PNG is the best format for that IMHO. But why convert to contour??? The pics have been converted to backgrounds and that's rather weird. Why not just paste them and then group with the Writer elements (from the Draw toolbar in Writer)?
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25074
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Few images turned to black in Writer

Postby Bill » Tue Jan 25, 2011 7:35 pm

Gamax wrote:Coffee.. I hope there is time for it. :) I'll make some tests.

Concerning images. After unzip files and folders, there are only visible images and one png file with 8x8 white pixels. :(


If I understand correctly, the "black" images are not in the file. In that case, importing them may solve the problem, but I don't know if it would be a permanent fix. Right-click one of the images and select Group > Edit Group. Click the black image to select it, then right-click the image and select Area > Bitmaps > Import. Navigate to the image to be imported and select Open.
Bill
 
Posts: 3309
Joined: Sat Nov 24, 2007 6:48 am

Re: Few images turned to black in Writer

Postby Gamax » Tue Jan 25, 2011 8:03 pm

Bill wrote:If I understand correctly, the "black" images are not in the file. In that case, importing them may solve the problem, but I don't know if it would be a permanent fix. Right-click one of the images and select Group > Edit Group. Click the black image to select it, then right-click the image and select Area > Bitmaps > Import. Navigate to the image to be imported and select Open.

Yes, it is easier way to fix it. Thanks! I hope, it is permanent solution..


Hagar de l'Est wrote:... But why convert to contour??? The pics have been converted to backgrounds and that's rather weird. Why not just paste them and then group with the Writer elements (from the Draw toolbar in Writer)?

Why convert? Because I didn't find way how to group it. I click on the line (from Draw toolbar), then on the image with shift pressed and... nothing is selected. When I try to select with rectangle (select tool in Draw toolbar), only line is selected. So, only way that I found (on google) is convert to contour.

RoryOF wrote:... As I see your file, it is not rendering the pictures correctly, yet they are stored correctly within it...

I don't agree. Images are not in file. I mean they are not stored in Pictures folder after unpacking...
OpenOffice 3.2.1 on WindowsXP SP3, HP8710w
Gamax
 
Posts: 10
Joined: Tue Jan 25, 2011 4:10 pm

Re: Few images turned to black in Writer

Postby RoryOF » Tue Jan 25, 2011 8:13 pm

Gamax wrote:
RoryOF wrote:... As I see your file, it is not rendering the pictures correctly, yet they are stored correctly within it...

I don't agree. Images are not in file. I mean they are not stored in Pictures folder after unpacking...


I see 14 images in the Pictures folder of the expanded file. The Pictures folder is (from memory - now on another machine) about 68k.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14328
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Few images turned to black in Writer

Postby Gamax » Tue Jan 25, 2011 8:20 pm

RoryOF wrote:
Gamax wrote:
RoryOF wrote:...

I don't agree. Images are not in file. I mean they are not stored in Pictures folder after unpacking...
I see 14 images in the Pictures folder of the expanded file. The Pictures folder is (from memory - now on another machine) about 68k.

Yes, I have same size. But I'm sure, that few images are missing. 13 images are visible in document and 14 images are in picture folder after unpack. This 14th image is 8x8 px white png. Another 9 images are not in "zip file" and in document are missed too.

PS: I hope, that my english doesn't irritating you.. :)
OpenOffice 3.2.1 on WindowsXP SP3, HP8710w
Gamax
 
Posts: 10
Joined: Tue Jan 25, 2011 4:10 pm

Re: Few images turned to black in Writer

Postby Hagar Delest » Tue Jan 25, 2011 9:47 pm

In fact, you can group images if they are first pasted in Draw and then just copied and pasted to Writer. This way they are converted in a Draw object in Writer!

See that funny screenshot of the file under Ubuntu 10.10 and 3.3 RC9:
Buggy.png

You can see that the bitmap background (that has disappeared) has been replaced by something else.
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25074
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Few images turned to black in Writer

Postby RoryOF » Wed Jan 26, 2011 12:07 am

Hagar de l'Est wrote:See that funny screenshot of the file under Ubuntu 10.10 and 3.3 RC9:
You can see that the bitmap background (that has disappeared) has been replaced by something else.


That's what I got also under Ubuntu. Much nicer than just black, isn't it? :-)
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14328
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Few images turned to black in Writer

Postby Gamax » Wed Jan 26, 2011 12:41 am

Sure and thanks for easier way to paste images. But I hope, that I'll never get black images again. :)
OpenOffice 3.2.1 on WindowsXP SP3, HP8710w
Gamax
 
Posts: 10
Joined: Tue Jan 25, 2011 4:10 pm

Re: Few images turned to black in Writer

Postby Hagar Delest » Wed Jan 26, 2011 1:44 pm

Note that if you want the devs to have a look, you can upload your file in a bug report: [Tutorial] Reporting bugs or suggestions. It's worth it IMHO because there is clearly a bug here.
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25074
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Writer

Who is online

Users browsing this forum: No registered users and 22 guests