[Solved] Table of Contents shows every paragraph

Discuss the word processor

[Solved] Table of Contents shows every paragraph

Postby Jörgi2 » Fri Dec 17, 2010 5:36 am

I have a document (sxw) which is structured with some headlines of different levels. In most sections there are some paragraphs of text which use the style "Standard".
When I now update my table of contents, not only headlines, but also paragraphs styled with "Standard" are shown in the TOC.

How can I avoid that?

PS: When I assign another styling to one of these paragraphs, it is no longer displayed in the TOC; unfortunatelly styling rules force me to stick to the default style. :-(
Last edited by TheGurkha on Sat Dec 18, 2010 7:25 pm, edited 2 times in total.
Reason: Tagged Solved, TheGurkha.
OpenOffice 3.3 on Windows XP
Jörgi2
 
Posts: 10
Joined: Fri Dec 17, 2010 5:26 am

Re: Table of Contents shows every paragraph - I don't want t

Postby Hagar Delest » Fri Dec 17, 2010 9:05 am

Hi and welcome to the forum!

First open the Tools>Outline Numbering dialog. Make sure that the Standard paragraph style is not listed as an outline level.
Then make sure that the Standard paragraph style properties have not been set to Outline level x in the Outline & Numbering tab.

Please add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).

Off-line until Aug. 31.
User avatar
Hagar Delest
Moderator
 
Posts: 28529
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Table of Contents shows every paragraph - I don't want t

Postby Jörgi2 » Fri Dec 17, 2010 3:53 pm

Hagar de l'Est wrote:Hi and welcome to the forum!

First open the Tools>Outline Numbering dialog. Make sure that the Standard paragraph style is not listed as an outline level.


Hi Hagar and thanks for the warm welcome.
I found this dialogue:
http://www.taming-openoffice-org.com/ne ... ne-num.png
as "Extras > Kapitelnummerierung". I hope that is the right one?
Standard was listed there for level 3. I set that to heading3 now.

Hagar de l'Est wrote:Then make sure that the Standard paragraph style properties have not been set to Outline level x in the Outline & Numbering tab.


Where can I set the properties of the paragraph style? Do you mean in the tab shown in the picture called "Numbering"? I don't see "standard" there.
The paragraphs are still part of the TOC...
OpenOffice 3.3 on Windows XP
Jörgi2
 
Posts: 10
Joined: Fri Dec 17, 2010 5:26 am

Re: Table of Contents shows every paragraph - I don't want t

Postby Hagar Delest » Fri Dec 17, 2010 3:56 pm

Jörgi2 wrote:Where can I set the properties of the paragraph style? Do you mean in the tab shown in the picture called "Numbering"? I don't see "standard" there.

Open the Navigator (F5) then right click the Standard paragraph style and click Modify. Go to the Outline & Numbering tab and set Outline level to Body text.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).

Off-line until Aug. 31.
User avatar
Hagar Delest
Moderator
 
Posts: 28529
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Table of Contents shows every paragraph - I don't want t

Postby Jörgi2 » Fri Dec 17, 2010 4:21 pm

I have opened the navigator. There are sections for headlines, tables, text borders, pictures and so on, but none for Default or Standard.
I can however rightclick on any paragraph styled with Standard and choose "Absatzvorlage bearbeiten", which might translate to "Modify Paragraph Style". There also is Outline and Numbering then, but there I can only choose "Standard" (which is currently chosen) and Level 1, Level 2 and so on. "Body Text" is not in that list.

See screenshot:
screenb.gif
OpenOffice 3.3 on Windows XP
Jörgi2
 
Posts: 10
Joined: Fri Dec 17, 2010 5:26 am

Re: Table of Contents shows every paragraph - I don't want t

Postby RoryOF » Fri Dec 17, 2010 4:28 pm

Perhaps Hagar should have said "Styles and Formatting" (F11). Even Homer nods...!
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29299
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Table of Contents shows every paragraph - I don't want t

Postby Jörgi2 » Fri Dec 17, 2010 4:54 pm

OK. I now have the dialogue "Paragraph-Template: Standard" opened. I see the tab "Outline and Numbering".
In that tab I can only choose "Standard" (which is currently chosen) and Level 1, Level 2 and so on. "Body Text" is not in that list.

See screenshot:
screenb.gif

What now?
Last edited by Hagar Delest on Fri Dec 17, 2010 6:27 pm, edited 1 time in total.
Reason: pic embedded.
OpenOffice 3.3 on Windows XP
Jörgi2
 
Posts: 10
Joined: Fri Dec 17, 2010 5:26 am

Re: Table of Contents shows every paragraph - I don't want t

Postby Hagar Delest » Fri Dec 17, 2010 6:27 pm

That's the entry. Standard is the German translation of the English UI Body text.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).

Off-line until Aug. 31.
User avatar
Hagar Delest
Moderator
 
Posts: 28529
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Table of Contents shows every paragraph - I don't want t

Postby Jörgi2 » Fri Dec 17, 2010 6:29 pm

I used Standard for my text paragraphs. But there also is a styling for "Textkörper", which might translate to "Text Body".
Does that cause the confusion?

Standard is chosen, Text Body is not shownin the list.
However, the text is still displayed inside the TOC. :-(

Do you have other ideas?
OpenOffice 3.3 on Windows XP
Jörgi2
 
Posts: 10
Joined: Fri Dec 17, 2010 5:26 am

Re: Table of Contents shows every paragraph - I don't want t

Postby Hagar Delest » Fri Dec 17, 2010 6:43 pm

Can you upload a sample file (see: How to attach a document here)?
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).

Off-line until Aug. 31.
User avatar
Hagar Delest
Moderator
 
Posts: 28529
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Table of Contents shows every paragraph - I don't want t

Postby Jörgi2 » Fri Dec 17, 2010 7:14 pm

You find the file here.
http://rapidshare.com/files/437855427/Test.sxw

This is the current version. It is the one, in which I first saw the problem. The change you proposed is not in there.
OpenOffice 3.3 on Windows XP
Jörgi2
 
Posts: 10
Joined: Fri Dec 17, 2010 5:26 am

Re: Table of Contents shows every paragraph - I don't want t

Postby acknak » Fri Dec 17, 2010 8:10 pm

It seems there are a couple of problems...

First, under Tools > Outline Numbering, you have document outline level 3 connected to the paragraph style "Default" ("Standard" in de_DE).

Second, it seems there is also some direct formatting on the text paragraphs, setting the "outline level" to 3. So, even if you change the outline level configuration, Writer still thinks the text paragraphs are part of the document outline.

Unfortunately, it's quite tricky to remove that direct formatting. Normally, Format > Default Formatting would do it, but not in this case. I had to actually assign a different paragraph style, then re-assign the Default/Standard style to remove the direct formatting and get rid of the outline numbering property.

Here's a copy of your document where I've fixed those two problems; it seems to update the ToC correctly now:
(document removed).
Last edited by acknak on Sat Dec 18, 2010 11:07 pm, edited 1 time in total.
Reason: removed sample file
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Table of Contents shows every paragraph - I don't want t

Postby Hagar Delest » Sat Dec 18, 2010 12:07 pm

Strange, once Default/Standard has been removed from the Outline Numbering dialog, I just selected all with Ctrl+A and hitting Ctrl+M did the trick, everything is fine afterward.

Please add '[Solved]' at the beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).

Off-line until Aug. 31.
User avatar
Hagar Delest
Moderator
 
Posts: 28529
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Table of Contents shows every paragraph - I don't want t

Postby acknak » Sat Dec 18, 2010 5:46 pm

Hmm, that works for me now also. I'm not sure what I was doing differently yesterday.

Good catch!
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Table of Contents shows every paragraph - I don't want t

Postby Jörgi2 » Sat Dec 18, 2010 7:15 pm

Hagar de l'Est wrote:Strange, once Default/Standard has been removed from the Outline Numbering dialog, I just selected all with Ctrl+A and hitting Ctrl+M did the trick, everything is fine afterward.

Please add '[Solved]' at the beginning of your first post title (edit button) if your issue has been fixed.



Hi guys,

thanks for your work! Especially to acknak! The TOC is working correctly with your changes. :-)

As a wrote I also tried removing the style by setting it to something else and then back to "Default", but that preserved the wrong TOC information.
I now tried again on the broken version using Strg-A and then Strg-M, but this does not fix it for me.
Well, I just have to take care not to break that again, I think.

Thanks again for your hints!
OpenOffice 3.3 on Windows XP
Jörgi2
 
Posts: 10
Joined: Fri Dec 17, 2010 5:26 am

Re: [Solved] Table of Contents shows every paragraph

Postby mver » Sun Jun 03, 2012 9:56 pm

I believe this thread may have been solved for some, but I submit the following for which I need help.

I have Headings 1, 2, 3, 4 set to outline levels with indents. This works.
But, the TOC also includes the full text of paragraphs in text body style.
E.g.: {where TOC has been set to put Page# first, then Entry (and I want to add Entry# in front of Entry.)}
Page# Heading Entry - result
1 APPOINTMENT OF ATTORNEY-IN-FACT --OK
1 GENERAL GRANT OF POWERS --OK
2 SPECIFIC POWERS RELATING TO PROPERTY --OK
2 Support --OK
2 Personal Affairs --OK
2 The power to do any acts, including the disbursing of any monies belonging to me, which, in the opinion of my Attorney-in-Fact, may be necessary or proper in connection with the conduct of my personal affairs, including, but not limited to, -NOT OK
2 continuation, use or termination of any charge or credit accounts, -NOT OK
2 payments or contributions to any charitable, religious or educational organizations, -NOT OK

The NOT OK's are actual text paragraphs in their entirety; they should not be in TOC at all.

This behavior is the same from WinXp and from Ubuntu (libre office)

Thanks for your assistance.
OO 3.3.0 or 3 : WinXP; also Libre Office: Ubuntu 12.04
mver
 
Posts: 3
Joined: Sun Jun 03, 2012 9:26 pm

Re: [Solved] Table of Contents shows every paragraph

Postby Hagar Delest » Sun Jun 03, 2012 10:47 pm

Can you upload a sample file (see How to attach a document here)?
Have you checked the Numbering tab of the paragraph properties?
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).

Off-line until Aug. 31.
User avatar
Hagar Delest
Moderator
 
Posts: 28529
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Table of Contents shows every paragraph

Postby mver » Mon Jun 04, 2012 3:42 pm

Thank you Hagar.
test file attached. contains a couple of headings and text. TOC is at end, not start, but it behaves the same way in either location.
Attachments
DPOAG-test-2012.odt
(26.74 KiB) Downloaded 194 times
OO 3.3.0 or 3 : WinXP; also Libre Office: Ubuntu 12.04
mver
 
Posts: 3
Joined: Sun Jun 03, 2012 9:26 pm

Re: [Solved] Table of Contents shows every paragraph

Postby Hagar Delest » Mon Jun 04, 2012 4:54 pm

Hagar Delest wrote:Have you checked the Numbering tab of the paragraph properties?

Select the paragraphs that should not be in the ToC.
Right click and go to the Outline & Numbering tab.
In the Outline field at top, change Level 2 to Body text.
Click OK
Update the ToC (note that you can also see the change in live in the Navigator - F5).

Now you can see that the ToC at the end is included in the Navigator as headings!
In the Stylist (F11), right click the Contents 2 entry, do the same as above.

NB: all had been said in the topic...
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).

Off-line until Aug. 31.
User avatar
Hagar Delest
Moderator
 
Posts: 28529
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Table of Contents shows every paragraph

Postby mver » Tue Jun 05, 2012 8:41 pm

Hagar Delest wrote:
Hagar Delest wrote:Have you checked the Numbering tab of the paragraph properties?
NB: all had been said in the topic...


Dear Hagar, Thanks for your gentle nudge about reading .... (I did try but found it difficult to meld disparate comments). However I did glean some principles there, and then at

http://jorgenmodin.net/index_html/archi ... noffice-21

I found an important key: how headings and text body cascade down from Heading and Default and how setup should start there and then modify as needed at lower levels.

My own set of headings in the document had become hopelessly entangled.

The big resolution was to copy my existing text into a txt file (no formatting at all) and then copy that into a NEW OO file and then apply headings as needed, leaving text body alone. Voila! TOC generates very nicely.

Color me fully solved, with thanks. :D
OO 3.3.0 or 3 : WinXP; also Libre Office: Ubuntu 12.04
mver
 
Posts: 3
Joined: Sun Jun 03, 2012 9:26 pm

Re: [Solved] Table of Contents shows every paragraph

Postby DNA333 » Fri Jun 20, 2014 8:01 am

Hi - I have the same issue but I cant seem to follow the steps shown in the reply - maybe they are not available on my version of OOo...?

I have Level 1, 2 and 3 headings in my paper. Level 1 and 2 are fine when translated to my TOC because I hit Enter and start text on the next line. For the level 3 heading, I need the heading and text to be on the same line - same paragraph. For my paper (APA formatting) level 3 is 1 tab indent and bold with a period after the heading, then kept on the same line as the text of the paragraph - like this:

Level 3. Then the text starts immediately after the heading.

My TOC includes the entire paragraph instead of just the heading. When I select the text (without the heading) it changes the heading as well, if I select just the heading, it changes the whole paragraph. I realize it is because the level is applied to the whole paragraph but I do not know how to make it apply to just the 1-2 words of the level heading "Level 3" then switch back to default for the paragraph text.

If the solution is to make it just a character style (not sure I know how) then how do I just apply character style and how do I translate that in my TOC (seems like the TOC just includes things formatted under "Level 1, Level 2, Level 3, etc".

Thanks for any help!

Dna
Dna
OOo 3.4.1
Mac OS X 10.6.8
DNA333
 
Posts: 3
Joined: Fri Jun 20, 2014 7:42 am

Re: [Solved] Table of Contents shows every paragraph

Postby jrkrideau » Fri Jun 20, 2014 4:16 pm

DNA333 wrote:Hi - I have the same issue but I cant seem to follow the steps shown in the reply - maybe they are not available on my version of OOo...?

I have Level 1, 2 and 3 headings in my paper. Level 1 and 2 are fine when translated to my TOC because I hit Enter and start text on the next line. For the level 3 heading, I need the heading and text to be on the same line - same paragraph. For my paper (APA formatting) level 3 is 1 tab indent and bold with a period after the heading, then kept on the same line as the text of the paragraph - like this:

Level 3. Then the text starts immediately after the heading.

My TOC includes the entire paragraph instead of just the heading. When I select the text (without the heading) it changes the heading as well, if I select just the heading, it changes the whole paragraph. I realize it is because the level is applied to the whole paragraph but I do not know how to make it apply to just the 1-2 words of the level heading "Level 3" then switch back to default for the paragraph text.

If the solution is to make it just a character style (not sure I know how) then how do I just apply character style and how do I translate that in my TOC (seems like the TOC just includes things formatted under "Level 1, Level 2, Level 3, etc".

Thanks for any help!

Dna


I don't think there is a clean solution for this. I would just have a third level heading Style and manually change everything after the period to regular text rather than italic. Not nice but it works. See the attached template for an example.

The real question is, "Why do you want a Table of Contents for an APA paper?"
Attachments
Apa.6th.2012.ott
(15.28 KiB) Downloaded 134 times
OpenOffice 4.1.6; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3690
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada

Re: [Solved] Table of Contents shows every paragraph

Postby DNA333 » Sun Jun 22, 2014 6:19 pm

Ha - because it is a final thesis project and must include a TOC.

I tried that, but it changes the entire "paragraph". For example, I highlight just the word I want at Level 3 and set it as Level 3 and the entire paragraph becomes LEvel 3, so then I highlight the text following the period and set it as default or text body and then the entire paragraph (including the "word and period" go to default - no matter what I do it switched everything in the paragraph to whatever I set for formatting doesn't matter that I highlight the words I want or not... changes everything.

here is one example:

Definition of Terms (Level 2)

Automaticity (Level 3). Definition of automaticity follows...

Of course I just want the word Automaticity to show in the TOC.

I also have issues with the two headers (first page and rest of doc) - seems like it doesn't maintain the formatting when I submit to my professor via web-based app where they use Word. Is there a trick to converting to Word?

Thanks for the template!
Dna
OOo 3.4.1
Mac OS X 10.6.8
DNA333
 
Posts: 3
Joined: Fri Jun 20, 2014 7:42 am

Re: [Solved] Table of Contents shows every paragraph

Postby RoryOF » Sun Jun 22, 2014 6:31 pm

For level 3 try this Workaround:
In /Format /Styles and Formatting, define Level 3 Style to use 2 point type in white. Enter your Level 3 word on its own line - you might (or not) adjust the trailing line space of the preceding paragraph to absorb the 2 pts of the white line.
Now Enter your complete paragraph starting with the keyword, but this time in the paragraph style. Define a Character style for the keyword which gives it the correct emphasis,

The ToC Contents 3 style will not use the Heading 3 Font attributes (2pt, white). If it does, it is easy redefined not to use them.

Another way, if the Level 3 entries are keywords in a glossary, might be to use a two column table, with the Level 3 keyword in the first column (existing Level 3 style), and the definition in the second column in your body text style. You can set the table borders to be invisible.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29299
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Table of Contents shows every paragraph

Postby DNA333 » Mon Jun 23, 2014 2:39 am

Thanks - I will try both of those...
Dna
OOo 3.4.1
Mac OS X 10.6.8
DNA333
 
Posts: 3
Joined: Fri Jun 20, 2014 7:42 am

Re: [Solved] Table of Contents shows every paragraph

Postby jrkrideau » Mon Jun 23, 2014 4:02 pm

DNA333 wrote:Ha - because it is a final thesis project and must include a TOC.

I tried that, but it changes the entire "paragraph". For example, I highlight just the word I want at Level 3 and set it as Level 3 and the entire paragraph becomes LEvel 3, so then I highlight the text following the period and set it as default or text body and then the entire paragraph (including the "word and period" go to default - no matter what I do it switched everything in the paragraph to whatever I set for formatting doesn't matter that I highlight the words I want or not... changes everything.

here is one example:

Definition of Terms (Level 2)

Automaticity (Level 3). Definition of automaticity follows...

Of course I just want the word Automaticity to show in the TOC.

I also have issues with the two headers (first page and rest of doc) - seems like it doesn't maintain the formatting when I submit to my professor via web-based app where they use Word. Is there a trick to converting to Word?

Thanks for the template!


I see the problem now. I second Rory's approach. It sounds like it should work.

On the other hand 'I'd check with the style experts for your university and maybe poke around the APA Style blog. It is my impression that one would not normally have a ToC with those levels of heading entry and that the first three levels are sufficient but each uni has their own bizarre formatting rules for theses.
OpenOffice 4.1.6; Ubuntu 18.04
jrkrideau
Volunteer
 
Posts: 3690
Joined: Sun Dec 30, 2007 10:00 pm
Location: Kingston Ontario Canada


Return to Writer

Who is online

Users browsing this forum: Google [Bot] and 22 guests