[Solved] How do I stop Writer changing date format ?

Discuss the word processor

[Solved] How do I stop Writer changing date format ?

Postby Kerubu » Wed Jun 02, 2010 12:59 pm

Hello all,

This problem is extremely annoying.

I need to write a date as 'Mar 2010' (due to space restrictions) but as soon as I put it in this format, stupid Writer keeps changing it to 01/03/10 !

I don't want it to do this but I can't find out how to stop it from doing so ! :crazy:

Please help me ! I want to switch all these irritating auto-correcting functions off !
Last edited by Kerubu on Wed Jun 02, 2010 4:12 pm, edited 1 time in total.
OpenOffice 3.2 ubuntu 10.04
Kerubu
 
Posts: 17
Joined: Tue May 25, 2010 3:34 pm

Re: How do I stop Writer automatically changing date format

Postby RoryOF » Wed Jun 02, 2010 1:07 pm

How are you inserting your date?
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14355
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How do I stop Writer automatically changing date format

Postby Kerubu » Wed Jun 02, 2010 1:19 pm

I just type it :

Mar 2010

Write the proceeds to change it to how *it* wants it !
OpenOffice 3.2 ubuntu 10.04
Kerubu
 
Posts: 17
Joined: Tue May 25, 2010 3:34 pm

Re: How do I stop Writer automatically changing date format

Postby RoryOF » Wed Jun 02, 2010 1:27 pm

If you were entering it as a Field, then Writer would definitely change it to match the Field formatting.

Try Tools / Autocorrect options ;/ Word Completion tab and uncheck Enable Word Completion. On Replace tab make sure Mar 2010 is not in the Replace selections.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14355
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: How do I stop Writer automatically changing date format

Postby acknak » Wed Jun 02, 2010 3:18 pm

Or, if you're working in a table, right-click and toggle off "Number recognition" (or change the cell format to a date format you like).
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17403
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: How do I stop Writer automatically changing date format

Postby Kerubu » Wed Jun 02, 2010 4:11 pm

Thanks RoryOF and acknak.

It was a date in a table and I stumbled on how to switch off number recognition .

All is calm now :p
OpenOffice 3.2 ubuntu 10.04
Kerubu
 
Posts: 17
Joined: Tue May 25, 2010 3:34 pm

Re: [Solved] How do I stop Writer changing date format ?

Postby icerabbit » Sat Nov 17, 2012 5:14 pm

Thanks for sharing!

At least I've got a way out now for the documents I'm working on in the future.

Honestly, this date auto-correction has been very aggravating, and makes no sense to me.

When I deliberately type 05/2002 (no day) and OO decides to change the date to 05/01/02 the result is:
a] wrong as no day was specified
&
b] could mean anything: 2005-Jan-2nd --- 5th-Jan-2002 --- May-1st-2002 ?!

Is there some option to not have to do this per document or per table?
Can one disable or customize these auto-correction things in preferences? Like make it spell out the month as three characters and the year as 4 digits at least.

I've looked through the preferences - OO v 3.4.1 on Mac OS X - before and again today, but haven't found anything specific.
OpenOffice 3.2.1 Mac OS X 10.6.5 Intel C2D
icerabbit
 
Posts: 16
Joined: Sun Jan 09, 2011 12:29 am

Re: [Solved] How do I stop Writer changing date format ?

Postby Villeroy » Sat Nov 17, 2012 6:01 pm

icerabbit wrote:Honestly, this date auto-correction has been very aggravating, and makes no sense to me.

No auto-correction is taking place and the behaviour makes perfect sense. Your input is recognized as some number or date and you striktly refuse to apply any number format. Since any number has to be displayed somehow there is a default formatting that takes place every time when the user did not specify anything.
If your input would be formatted automagically according to the way you entered the value, that would be auto-formatting and it would be a devastating feature. Instead the formatting is always the same and you have dozends of ways to enter a numeric value while there are thousands of ways to display a numeric value.
12345.9 can be formatted to any currency, percent value, fraction in any language with or without leading zeroes.
12345.9 can be formatted in thousands of different ways and you still enter 12345.9 into the cell. It must not make any difference if you enter 1,2345.9 or 00012345.9 or 12345.900. The number will be entered and formatted according to your requirement or some default if not specified otherwise.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 12.04, Apache OpenOffice 4.x
User avatar
Villeroy
Volunteer
 
Posts: 17295
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Solved] How do I stop Writer changing date format ?

Postby icerabbit » Sat Nov 17, 2012 8:51 pm

No auto-correction is taking place and the behaviour makes perfect sense.


I disagree.

The facts are that:
A] I type a number into a text document
&
B] OO changes it at will into something different and incorrect

If I type 05/2002 or 1234,56 or any other number in a text document; then that is what I want to appear on paper. Nothing more. Nothing less.

Changing 05/2002 automatically into 05/01/02 is not proper and results in an incorrect date; as I did not specify which day in March of 2002. At best, had I even specified the complete date, the resulting change is open for misinterpretation based on different formats used internationally.

Also note, that I am talking about typing plain text in a simple text document. I am not using a spreadsheet, template, ... with required formats in specific fields so that proper calculation can happen, everything lines up neatly, ...

So, whether we call it auto-correction, auto-formatting or auto-something-or-another; I don't want OO to do so.
OpenOffice 3.2.1 Mac OS X 10.6.5 Intel C2D
icerabbit
 
Posts: 16
Joined: Sun Jan 09, 2011 12:29 am

Re: [Solved] How do I stop Writer changing date format ?

Postby RoryOF » Sat Nov 17, 2012 9:21 pm

I don't know just which program you are using (as opposed to the program you think you are using), but Writer behaves perfectly for me with the examples given. See attached file

dates.odt
(11.89 KiB) Downloaded 34 times
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14355
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] How do I stop Writer changing date format ?

Postby acknak » Sun Nov 18, 2012 2:49 am

icerabbit wrote:...
Also note, that I am talking about typing plain text in a simple text document. ...

So, whether we call it auto-correction, auto-formatting or auto-something-or-another; I don't want OO to do so.

Did you not see the solution given above, that turns this behavior off? Or did you try it and it didn't work for you?

Note that this interpretation of input only occurs in a table, so I'm not sure it's fair to call it a "plain text" document.

It has been suggested that Writer's default behavior should have number recognition OFF by default, but so far the change has not been made. I don't know who is arguing for it--as far as I can see from the forum, it causes a lot of confusion.

Issue 100936: Tables - Turn number recognition off by default
You can register there and add your vote (up to two) or comment.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17403
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: [Solved] How do I stop Writer changing date format ?

Postby icerabbit » Mon Nov 19, 2012 9:23 pm

Acknack, thanks for sharing the solution in that earlier post - should have mentioned that more clearly. Yes, I saw it :)

Thank you, Acknack for mentioning that table number recognition option :)

You saved the day over the weekend, when I had this table full of dates spanning several years, that had to be typed out a specific way and temporarily needed to be able to be mm/yyyyy until an actual day was found.

Also thanks for sharing the bug report. I registered and voted to have that behavior turned off by default.

PS: Wanted to add that OO does seem to keep number recognition for tables off, after having turned it off for that one on Saturday, the new table seems fine. Crossing fingers.

Still it was very much unexpected behavior that I couldn't find an option or preference for.
Last edited by icerabbit on Mon Nov 19, 2012 9:46 pm, edited 1 time in total.
OpenOffice 3.2.1 Mac OS X 10.6.5 Intel C2D
icerabbit
 
Posts: 16
Joined: Sun Jan 09, 2011 12:29 am

Re: [Solved] How do I stop Writer changing date format ?

Postby icerabbit » Mon Nov 19, 2012 9:42 pm

RoryOF wrote:I don't know just which program you are using (as opposed to the program you think you are using), but Writer behaves perfectly for me with the examples given. See attached file

dates.odt


:bravo:

How constructive and mature of you, Rory

Writer may behave perfectly fine for you, but that is more than likely because you turned off number recognition at one point or another, or it never hit your system.

This was an issue for me on a brand new system with a brand new install of OO 3.4.1 and despite plenty of experience with Office and OpenOffice I couldn't find the setting or preference for it nor did I recall experiencing this behavior, possibly because I have used Word at work mostly.

Two thumbs up for Acknak. He/She recognized the issue, gave a solution and provided a bug report on top of it.

Now am I still imagining I saw this behavior in OO Writer over the weekend?

...
OpenOffice 3.2.1 Mac OS X 10.6.5 Intel C2D
icerabbit
 
Posts: 16
Joined: Sun Jan 09, 2011 12:29 am

Re: [Solved] How do I stop Writer changing date format ?

Postby RoryOF » Mon Nov 19, 2012 9:50 pm

My number recognition is as installed by AOO 3.4.1 "out of the box". Your problem arose because you were editing a table, and as acknak says, it is hardly fair to call that " a plain text document". My sample document was plain text.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14355
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] How do I stop Writer changing date format ?

Postby icerabbit » Tue Nov 20, 2012 3:33 pm

I called it plain text as far as the text goes because there was no formatting applied, as in:

new writer install
default settings
default template
default font
no font changes
no paragraph settings
no styles
no fields
no conditional formatting
...

in an attempt to explain under which conditions this was happening, ruling out "If it was entered as a field" or "Your input is recognized as some number or date and you striktly refuse to apply any number format. Since any number has to be displayed somehow there is a default formatting that takes place every time when the user did not specify anything"

In my opinion, it was and is unexpected behavior for a text editor to change dates & numbers in tables when it doesn't do so in regular text and the user did not specify how anything that is entered in a certain cell/column/row/table should be interpreted or "formatted".
OpenOffice 3.2.1 Mac OS X 10.6.5 Intel C2D
icerabbit
 
Posts: 16
Joined: Sun Jan 09, 2011 12:29 am


Return to Writer

Who is online

Users browsing this forum: alxobr and 20 guests