[Solved] Roman numerals in table of contents

Discuss the word processor

[Solved] Roman numerals in table of contents

Postby wbk » Fri May 21, 2010 2:43 am

My document is shaping up nicely.

    There is a first page, with no headers and such.
    Then there's a bunch of introductory pages (abstract, intro, ToC), with roman numerals for the pages (I...IX)
    The rest of the document uses arabic numerals (1, 2, you know the math).


The problem lies with the table of contents. Instead of showing roman numerals for the first chapters, it shows arabic numerals and then starts again at 1 when the real contents of the document start.

Is there a workaround for this situation? I have checked the tabs of the contents-styles to no avail, and apart from changing the ToC to read/write and making the changes manually, I have found no solution.
Last edited by wbk on Fri May 21, 2010 10:32 pm, edited 1 time in total.
OOo 3.2.0 build 9483 on Kubuntu 10.04 x86-64
wbk
 
Posts: 42
Joined: Wed May 19, 2010 12:13 pm

Re: Roman numerals in table of contents

Postby acknak » Fri May 21, 2010 4:41 am

The page number format is normally set by the page style: Format > Page > Page > Layout settings > Format

With the usual steps, the ToC will always use the same numbering format as that used on the pages--I'm not sure how you'd make it do something different.

 Edit: PS: 
Oops--wait. Did you apply a number format to the page number field? If so, I think you have to remove that number format and go back to the one set in the page style.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Roman numerals in table of contents

Postby wbk » Fri May 21, 2010 9:35 pm

acknak wrote:
 Edit: PS: 
Oops--wait. Did you apply a number format to the page number field? If so, I think you have to remove that number format and go back to the one set in the page style.


Correct reasoning ;-)

I do not have access to the document at the moment, but I am quite sure it will work out with your help. I'll update the topic subject after I saw it working with my own eyes.

Thanks!
OOo 3.2.0 build 9483 on Kubuntu 10.04 x86-64
wbk
 
Posts: 42
Joined: Wed May 19, 2010 12:13 pm

Re: Roman numerals in table of contents

Postby wbk » Fri May 21, 2010 10:31 pm

Great, it works!

I removed the roman page numerals, went to the page style. The bottom half right side of the "page" tab for the page style is called "Layout settings".

Apart from the layout settings, it also controls the "Format" of the page numbering.

After having been told to look in the page style it is straightforward, though it didn't catch my eye while composing the page style in the first place.

[SOLVED]
OOo 3.2.0 build 9483 on Kubuntu 10.04 x86-64
wbk
 
Posts: 42
Joined: Wed May 19, 2010 12:13 pm


Return to Writer

Who is online

Users browsing this forum: Yahoo [Bot] and 21 guests