[Solved] Turning off Smart Quotes

Discuss the word processor

[Solved] Turning off Smart Quotes

Postby John of Chico » Mon Mar 29, 2010 7:50 pm

Many if not most web browsers interpret the smart quotes (the curly " marks that auto-replace the normal quote marks) with broken icons. I tried tools: auto-correct options: replace "standard" quotes with "custom" quotes" but they still come up. How can I get normal quotes?

Thanks
Last edited by Hagar Delest on Tue Mar 30, 2010 11:24 am, edited 1 time in total.
Reason: tagged [Solved].
Open Office 3.20 / Windows XP
John of Chico
 
Posts: 9
Joined: Mon Mar 29, 2010 7:42 pm

Re: Turning off Smart Quotes

Postby franx » Mon Mar 29, 2010 8:32 pm

Hi,
disable Replace under Custom Quotes
custom_quotes.png


[see also the information under Options
[M]: Replace while modifying existing text]
LibreOffice 4.0.4 · WinXP
User avatar
franx
Volunteer
 
Posts: 540
Joined: Wed Nov 12, 2008 9:25 pm
Location: FRA 'n' QXB

Re: Turning off Smart Quotes

Postby acknak » Mon Mar 29, 2010 10:53 pm

Many if not most web browsers interpret the smart quotes (the curly " marks that auto-replace the normal quote marks) with broken icons.

Can you give an example of this? I've not noticed it before.

Also, I'm not entirely clear on what the quotes in Writer have to do with your web browser. Can you explain a little more about what you're trying to do?
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17403
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Turning off Smart Quotes

Postby John of Chico » Tue Mar 30, 2010 12:05 am

Thanks, that worked.
[
quote="franx"]Hi,
disable Replace under Custom Quotes
custom_quotes.png


[see also the information under Options
[M]: Replace while modifying existing text][/quote]
Open Office 3.20 / Windows XP
John of Chico
 
Posts: 9
Joined: Mon Mar 29, 2010 7:42 pm

Re: Turning off Smart Quotes

Postby floris v » Tue Mar 30, 2010 12:14 am

Many if not most web browsers interpret the smart quotes (the curly " marks that auto-replace the normal quote marks) with broken icons.


That may depend on Menu - View - Character set. You may want to experiment with Western (ISO8859-1), Unicode (UTF8), etc, until a page with curly quotation marks looks okay.
MS Windows Vista - AOO 4.0.1 - LibreOffice 4.1.0.4.
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 3028
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: Turning off Smart Quotes

Postby John of Chico » Tue Mar 30, 2010 12:31 am

Hmmm...

Well... I made a web page to demonstrate the problem for you, but both worked fine (i.e. with and without the smart quotes).
When I first began working on the Web in the late 90's I composed most of my posts using Word, then copy and pasted to my site. That was when I first noticed the problem. I used to I got a little box where the quotes were supposed to be, and so I always kept "smart quotes" turned off. I just assumed the same would be true with Open Office. We are having a storm right now so I decided to use my lap top for a study I am working on instead of my desk top in case we lose power, and it uses Open Office. Apparently this is no longer a problem.
Thanks for your help.

acknak wrote:
Many if not most web browsers interpret the smart quotes (the curly " marks that auto-replace the normal quote marks) with broken icons.

Can you give an example of this? I've not noticed it before.

Also, I'm not entirely clear on what the quotes in Writer have to do with your web browser. Can you explain a little more about what you're trying to do?
Open Office 3.20 / Windows XP
John of Chico
 
Posts: 9
Joined: Mon Mar 29, 2010 7:42 pm

Re: Turning off Smart Quotes

Postby acknak » Tue Mar 30, 2010 12:40 am

Thanks for the follow up. I guessed that might be the case.

The problem was that Microsoft implemented their "smart quotes" in a way that was not standard or compatible with the rest of the web. OOo has always used the standard Unicode characters for the typographic ("curly") quotation marks, and they work fine with any recent browser.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17403
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Turning off Smart Quotes

Postby franx » Tue Mar 30, 2010 4:51 am

:bravo:
That's definitely the better approach.
I was too much focused on the topic "Turning off Smart Quotes".
But we shouldn't throw out the baby with the bathwater ...
[... or "reset the user profile" for every undetermined discrepancy ... ;) ]
LibreOffice 4.0.4 · WinXP
User avatar
franx
Volunteer
 
Posts: 540
Joined: Wed Nov 12, 2008 9:25 pm
Location: FRA 'n' QXB

Re: [Solved] Turning off Smart Quotes

Postby OnoSendi » Fri Dec 23, 2011 6:43 pm

How quotes effects your browser: document writing programs such as Microsoft Word and OpenOffice Writer change a left quote to a curly left quote, and a right quote to a curly right quote. Your browser interprets the curly quote as a special character, which it can't read, and replaces the quote with a big ugly question mark. However, you SHOULD NOT be using quotes within your text strings. They should be replaced with " Example: "The brown fox jumped over the fence"
Open Office 3.3 Windows 7 (64 bit)
OnoSendi
 
Posts: 1
Joined: Fri Dec 23, 2011 6:38 pm

Re: [Solved] Turning off Smart Quotes

Postby acknak » Fri Dec 23, 2011 7:42 pm

Sorry, I'm not sure I understand your point.

As far as I know, there should be no problem using standard typographic (curly) quotes in html document text.

For example, does your browser have trouble with these? “ ”

OOo Writer uses the standard quote characters, and no special treatment is needed.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17403
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3


Return to Writer

Who is online

Users browsing this forum: No registered users and 17 guests