[Solved] Document won't print

Discuss the word processor

[Solved] Document won't print

Postby novice » Tue Mar 24, 2009 9:22 pm

I have a rather lengthy (34-page) document which was created in Microsoft Office but which I have converted (with help from forum friends; thanks!) to an OO document and have done some editing. Now, I'm trying to print it. The "print" screen comes up, I select "print", and it either flashes briefly the "now printing" box (but nothing happens), or it shows a little icon (I call it a "paragraph" symbol) at the end of every hard return on the document, and again, nothing happens. I am using an HP Deskjet 4280. Other OO documents do print with no trouble. I called HP support and they said it was a problem with OO. I tried copying the whole text into a new document, but the same thing happened.
Last edited by novice on Fri Apr 03, 2009 5:22 am, edited 1 time in total.
OOo 3.0.X on MS Windows Vista
novice
 
Posts: 9
Joined: Mon Mar 09, 2009 1:17 am

Re: Document won't print

Postby Hagar Delest » Tue Mar 24, 2009 9:43 pm

Well, that's strange indeed. Can you at least export it to PDF and then print it?

Can you upload it so that someone can try (see here: How to attach a document here)?
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Document won't print

Postby acknak » Tue Mar 24, 2009 10:22 pm

Double-check when you do File > Print, that it's configured to print to the correct printer.

Try changing the setting Tools > Options > Load/Save > General > Load > Load printer settings with the document: OFF (unchecked).

If neither of those helps, it you can try to re-install the printer driver, or even re-install the printer.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17420
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Document won't print

Postby csutton » Wed Mar 25, 2009 11:51 pm

I am having the same problem
I can print a spreadsheet but cannot print a document
The problem started when I installed 3.0 so I uninstalled 3.0 and reinstalled 2.0
2.0 won't print a document either
Also cannot export to a PDF It builds an empty file.
This occurs on .doc and OpenOffice formatted documents
OOo 2.0.X on Ms Windows XP
csutton
 
Posts: 2
Joined: Wed Mar 25, 2009 11:44 pm

Re: Document won't print

Postby Hagar Delest » Thu Mar 26, 2009 9:23 am

csutton wrote:The problem started when I installed 3.0 so I uninstalled 3.0 and reinstalled 2.0

Try to reset your OOo user profile. But during the welcome process, don't transfer your personal data, former configuration files might corrupt the new profile.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Document won't print

Postby csutton » Fri Mar 27, 2009 12:56 am

Txs Hagar. Printer output now works ok on both printers.
Am staying with 2.x for now.
OOo 2.0.X on Ms Windows XP
csutton
 
Posts: 2
Joined: Wed Mar 25, 2009 11:44 pm

Re: Document won't print

Postby Hagar Delest » Fri Mar 27, 2009 9:05 am

Have you tried to install 3.0.1 without transferring your personal data? Both 2.x and 3.x versions can run in parallel.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Document won't print

Postby novice » Thu Apr 02, 2009 4:37 am

Thanks for all the suggestions. I tried to export the document to PDF but just got a blank document. I uninstalled my HP printer and reinstalled it, but that didn't fix the problem. Then I tried to research why some of my OO documents will print and others won't, and I discovered that the documents that are "Open Document Text" print just fine, but those that are labeled "OpenOffice.org1.1TextDocument" will not. (If I knew how to change those to an "Open Document Text" type, I would; but I don't.) Then I thought I would try to reset my user profile; I got as far as the "Paths" step but couldn't figure out what to do to reset. (I don't call myself "novice" for nothing!) So...still stuck! Any further help would be greatly appreciated. (One thing I haven't tried yet is posting the document for someone else to try to print; I will do that if nothing else works!) Thank you.
OOo 3.0.X on MS Windows Vista
novice
 
Posts: 9
Joined: Mon Mar 09, 2009 1:17 am

Re: Document won't print

Postby novice » Thu Apr 02, 2009 5:01 am

Oops...just tried again, and even the "open document text" documents won't print any more. Apparently all my OO documents are infected with the same problem.
OOo 3.0.X on MS Windows Vista
novice
 
Posts: 9
Joined: Mon Mar 09, 2009 1:17 am

Re: Document won't print

Postby acknak » Thu Apr 02, 2009 6:20 am

Maybe an easier way to check is to add a new user to your computer. I've never used Vista but on XP it's under the Control Panel, which you can get to from the Start Menu. If you can find the "Users and Groups" category, it should be easy to add a new user.

Once that's done, you can log in as the new user and try running OOo again. That will give you all new settings. Your "new user" won't have access to your old documents, so just make a new document, type a few words and print it: if that works, you'll at least know that it's just a settings problem.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17420
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Document won't print

Postby novice » Thu Apr 02, 2009 8:12 pm

Thank you! I did work to create a new user. I could never have gotten through this maze without your help, forum friends! Now I need to mark this "solved" but I don't know how to do that, either!
OOo 3.0.X on MS Windows Vista
novice
 
Posts: 9
Joined: Mon Mar 09, 2009 1:17 am

Re: Document won't print

Postby Hagar Delest » Thu Apr 02, 2009 8:51 pm

Do you confirm you had reset your user profile for your regular user???

To add '[Solved]' at the beginning of your first post title, use the edit button top right of the header.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Document won't print

Postby acknak » Thu Apr 02, 2009 9:11 pm

Do you confirm you had reset your user profile for your regular user???

I don't think so.

I understood novice to say that the instructions for resetting the profile were too difficult. I only suggested trying a new user as a (perhaps) easier alternative to performing a profile reset.

Working as the new user won't make a good long-term solution, but it does tell us that the problem should be solved if the profile can be reset for your normal user log in. That would be the better long-term solution.

Maybe you can ask someone who is more comfortable with file management to help you? It won't take an expert, just someone who is comfortable following the directions in the tutorial.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17420
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Document won't print

Postby Hagar Delest » Thu Apr 02, 2009 9:23 pm

acknak wrote:I don't think so.

I don't neither. It was just a subliminal message telling that OP had better try to reset his OOo user profile. I've slightly modified the process, perhaps it's more clear now.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Document won't print

Postby novice » Fri Apr 03, 2009 5:20 am

Sorry...I guess I wasn't clear in my last post, partly because I typed "I" instead of "It" ("...did work to create a new user"). What I did was create a new user for my computer (not for Open Office, because I never could figure out how to do that). Now when I create an OO document after starting up under my new user name, I am able to print. Evidently there was a problem with my settings on my first go-round. Thanks again!
OOo 3.0.X on MS Windows Vista
novice
 
Posts: 9
Joined: Mon Mar 09, 2009 1:17 am

Re: Document won't print

Postby Hagar Delest » Fri Apr 03, 2009 8:06 am

novice wrote:What I did was create a new user for my computer (not for Open Office, because I never could figure out how to do that). Now when I create an OO document after starting up under my new user name, I am able to print. Evidently there was a problem with my settings on my first go-round.

Yes, we know. That's why you should try to reset your user profile for OOo so that you get back your regular machine user with the related Windows configuration. I've slightly changed the process describing the reset, tell us what you don't manage to do.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Writer

Who is online

Users browsing this forum: No registered users and 29 guests