Keyboard space bar fails to work

Discuss the word processor

Keyboard space bar fails to work

Postby gatitosmommy » Mon Jan 14, 2008 8:52 am

was in process of doing ebook for job project... I had to stop for a couple of hours, & when I got back to it the keyboard's space bar refused to work. tried different keyboard- same problem. rebooted- didn't help. in the process, my toolbar bounced from bottom of screen to top of screen. the catch is, the space bar works fine on everything EXCEPT this one ebook document. I copied/pasted the material into a different one, but it still didn't work.

as it seems the problem is about the document rather than the keyboard, can someone please advise as to what could be wrong with it & how I can fix it asap? I have 2 large work projects & can't do them when the space bar won't work...

advice with this would be much appreciated....
gatitosmommy
 
Posts: 4
Joined: Mon Jan 14, 2008 8:47 am

Re: Keyboard space bar fails to work -- need help asap.

Postby TerryE » Mon Jan 14, 2008 9:03 am

If you need Help ASAP, thenthe first thing that you need to work within is our Survival Guide. First, I've changed the title of this post so that you have a better chance of a focussed response, but we really need more info to help you. What OS? What OOo version? What type of document have you got? What size is it?

Have you tried opening it on a different PC with OOo installed? What about space bar use in simple new documents? Trying these is important because this tell you if the problem is PC/OOo configuration related or document content related.
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK

Re: Keyboard space bar fails to work -- need help asap.

Postby gatitosmommy » Mon Jan 14, 2008 9:15 am

it says Open Office 2.0- writer, word processor...
I know very little about computers/terminology... when I open Writer, it's just the basic standard size document as it comes up when opened, didn't change/modify it in any way.

I don't have another PC to try it on...
but when I opened & started a different document entirely, it works fine-- it just won't work on the one I'm working on! it worked fine earlier today, but when I went back to it to complete the document, the space bar wouldn't work. c/p the material into a new document produced the same results (none).

since it works on everything except that one document, I don't think the problem could be with the keyboards.
the document is basic text, using the same font as always, with a few "clip-art" types of graphics. I did the first 10 pages of this with no problem.

it's a Linux system.
gatitosmommy
 
Posts: 4
Joined: Mon Jan 14, 2008 8:47 am

Re: Keyboard space bar fails to work -- need help asap.

Postby TerryE » Mon Jan 14, 2008 10:44 am

If you paste a couple of the pages that do not contain private / sensitive into a new doc and you still see the symptom, then why not attach it to your post and we'll have a look
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK

Re: Keyboard space bar fails to work -- need help asap.

Postby gatitosmommy » Mon Jan 14, 2008 7:18 pm

I'll do that if it can be of help, but I think I've narrowed it down- currently, the only place the space bar refuses to work is at the very end of the document.
I mean I can go further back into the document & try it & it works fine, but on the specific page I'm working on it won't do anything.
I tried deleting the current page & retyping it, but it doesn't work that way either
gatitosmommy
 
Posts: 4
Joined: Mon Jan 14, 2008 8:47 am

Re: Keyboard space bar fails to work -- need help asap.

Postby TerryE » Mon Jan 14, 2008 11:22 pm

Deleting a page an retyping is a waste of your time. Create a test copy, and delete all except the last page. Check that you can use the space bar. if not then post the doc here. If you want to sanitise the content, do a replace with More Options-> Regular Expressions enabled and
    [a-zA-Z] -> a
    [0-9] -> 9
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK

Re: Keyboard space bar fails to work -- need help asap.

Postby Hagar Delest » Mon Jan 14, 2008 11:59 pm

If you type characters after hitting the space bar, do they appear ?

I fear it's the white space issue :
See issue 20878. I discovered an interesting file (attachment 33679). I thought it was an OOo general setting but it's related to the paragraph style in fact. We can revert this behavior (at least for new paragraphs inserted before the first paragraph).

I googled a bit and I found 2 interesting pages :
http://books.evc-cit.info/odbook/ch03.html
http://blogs.sun.com/lars/category/Everything

The 'problem' comes from whitespaces with the xml attribute "text:c" for example <text:s text:c="484"/> in the issue attachment.

It seems that when a line is re-wrapped due to spaces added at the end of a paragraph, they're concatenated with this attribute. But if this value is too high, it's impossible to remove it and we don't see the spaces we type anymore, even if there is still much room on the line. I modified the value 484 in the content.xml of the issue attachment and I was able afterwards to type spaces at the end of the line (whereas it was impossible before) !

As ODF file (odt, ods, odp, ...) is a bunch of xml files zipped together, you can fix it easily: make a copy of your file, change the extension to 'zip' instead of 'odt', extract the file content.xml and open it with your web browser (to see the structure more clearly). Search for the attribute 'text:c=' from the end of the file (problem may be for last paragraph I guess). When you've spotted the string, open the file also with a text editor (Notepad/Gedit), search from the end the string and replace the 'xx' number you've seen after this string with a small number like 1 or 2. Save the file, zip it back into the archive and change the archive extension back from 'zip' to 'odt'. Try to open it and add spaces.
AOO 4.0.1 on Windows 7 and Xubuntu 13.10 (Saucy Salamander)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Writer

Who is online

Users browsing this forum: RusselB and 15 guests