Bullet issues with 3.0 and .doc files

Discuss the word processor

Bullet issues with 3.0 and .doc files

Postby scroobious » Wed Oct 22, 2008 5:35 pm

I've run into bullet issue with bullets with 3.0 on Ubuntu 8.04. With the official release, when I add bullets to a file in 3.0, I can only see the bullet for the first level; none of the other bullets appear. However, if I save that document and open it in Word, all the bullets are there. I have to save documents as .doc files, just for compatibility with what my students use, so that's set as the default.

In previous betas of 3.0, bullets wouldn't appear correctly in 2.4, and I believe in Word as well -- it's been a while, and I don't rightly recall.

I'm wondering if there's a setting I need to adjust, or if I've found a bug. Ideas?
OOo 3.1 on Ubuntu 9.10
User avatar
scroobious
 
Posts: 6
Joined: Wed Oct 22, 2008 5:26 pm

Re: Bullet issues with 3.0 and .doc files

Postby yosttheskanker » Fri Oct 24, 2008 6:33 am

I'm having the exact same issue.
yosttheskanker
 
Posts: 3
Joined: Thu May 01, 2008 3:28 am

Re: Bullet issues with 3.0 and .doc files

Postby scroobious » Fri Oct 24, 2008 5:45 pm

I have a number of screen shots for comparison.

    First is a bulleted document made in OO.org 3.0. This file was saved both as an .odt and a .doc. Note that all bullets past the first level are not visible

    Second is that OO.org 3.0 .odt file opened in OO.org 2.4. Note that the bullets are all flushed left. Despite the format problem, all the bullets on every level are visible here. So an .odt file made in 3.0 doesn't work in 3.0 or 2.4.

    Third is that OO.org 3.0 .doc file opened in OO.org 2.4. Note that the bullets are all formated correctly, yet like with 3.0, bullets past the first level are not visible.

    Fourth is that OO.org.3.0 .doc file opened in MS Word 2002. Note that the bullets are all formatted correctly and are visible. So a .doc file made in 3.0 works in Word, but not 3.0.

    Fifth is a .doc file made in MS Word 2002 and opened in OO.org 2.4. All the bullets are formatted correctly and visible.

    Sixth is that same MS Word 2002 .doc file opened in OO.org 3.0. All the bullets are formatted correctly and visible.

What this tells me overall is that OpenOffice handles .doc files better than .odt files, at least when it comes to bullets, and its own .odt file format doesn't convert well across versions of OpenOffice. This seems like a big oversight; I hope it can get fixed, and if it's a bug, tell me where to go and I'll file it.
Attachments
oo.org 3.0 bullets.jpg
Images of bullet lists in OpenOffice 3.0, OpenOffice 2.4, and MS Word
OOo 3.1 on Ubuntu 9.10
User avatar
scroobious
 
Posts: 6
Joined: Wed Oct 22, 2008 5:26 pm

Re: Bullet issues with 3.0 and .doc files

Postby Hagar Delest » Fri Oct 24, 2008 11:37 pm

Do you use a list style or the bullet button in the toolbar?
Here is what I get when I open a .doc file created with OOo 3 on my xubuntu (Hardy) box:
Bullets_OOo3.png
Bullets_OOo3.png (1.86 KiB) Viewed 5357 times

Bullets_OOo2.png
Bullets_OOo2.png (1.75 KiB) Viewed 5359 times
Attachments
Bullets.doc
(9 KiB) Downloaded 162 times
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28833
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Bullet issues with 3.0 and .doc files

Postby pbouf » Sun Oct 26, 2008 5:29 am

Same problem here since going from 2.4 to 3.0. Very annoying. I take notes with OO writer and am used to just hitting Tab and Shift-Tab to change the indent level.

Using 'List 1' style seems to do more what I want, but why does the Bullets button not just do what it should do?
OOo 3.0.X on Ubuntu 8.x
pbouf
 
Posts: 1
Joined: Sat Oct 25, 2008 10:28 pm

Re: Bullet issues with 3.0 and .doc files

Postby Hagar Delest » Sun Oct 26, 2008 11:05 am

pbouf wrote:why does the Bullets button not just do what it should do?

Vote for it: Issue 9437 - Change default bullet type.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28833
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Bullet issues with 3.0 and .doc files

Postby scroobious » Sun Oct 26, 2008 3:29 pm

Thought I responded to this, but I guess not. I used the bullet button, not the list. The pictures you show with the list are similar to how bullet lists made in 2.4 and opened in 3.0 beta worked for me in recent weeks.
OOo 3.1 on Ubuntu 9.10
User avatar
scroobious
 
Posts: 6
Joined: Wed Oct 22, 2008 5:26 pm

Re: Bullet issues with 3.0 and .doc files

Postby scroobious » Sat Nov 01, 2008 6:04 pm

Just a bit of an update here.

I had this problem with the .deb files. I removed all of those files and installed OpenOffice 3.0 on Ubuntu 8.10 via this repository:
Code: Select all   Expand viewCollapse view
deb http://ppa.launchpad.net/openoffice-pkgs/ubuntu intrepid main

I no longer have the same bullet issues. Things seem to work a treat in this version, so I'm guessing it was a tweak made by Ubuntu to work with its OS, or some such thing.
OOo 3.1 on Ubuntu 9.10
User avatar
scroobious
 
Posts: 6
Joined: Wed Oct 22, 2008 5:26 pm

Re: Bullet issues with 3.0 and .doc files

Postby Hagar Delest » Sat Nov 01, 2008 11:34 pm

Thanks for the follow up. Indeed, Ubuntu version is based on the go-oo.org version that has improved support of MS Office file formats.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28833
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Bullet issues with 3.0 and .doc files

Postby tralex » Wed Nov 19, 2008 12:28 pm

Steps to reproduce a manifestation of the problem:
- Win XP pro
- OO 3.0
- create new write document
- click on "Bullets on/off" button in toolbar
- add a few bullets with various indentation levels - change indentation either via (SHIFT+)TAB or OO's own "Bullets and Numbering" toolbar
- save as word 97/2000/XP .doc (to date very convenient for compatibility with other users/tools)
- close document and reopen in OO 3.0
- add more bullets with different indentation levels - result: bullet symbols do not change indentation as they should while text does.

Notes:
1. similar (if not identical) behavior is exhibited by creating the bullets via "List styles" (e.g. I have tried "List 4")
2. exported .pdfs exhibit the same incorrect formatting shown by OO
3. new files saved as .odt do not exhibit this problem

Can someone confirm if they get the same behaviour?
OOo 3.0.X on Ms Windows XP
tralex
 
Posts: 1
Joined: Wed Nov 19, 2008 11:44 am

Re: Bullet issues with 3.0 and .doc files

Postby xaviermaxenator » Fri Jan 09, 2009 5:05 pm

I get the same behavior. I save all my files as .doc files by default (for compatibility), and am running OOo 3.0 on Mac OS X Leopard. I've looked around, but haven't yet seen a fix for this. Any ideas?
OOo 3.0.X on Mac OSx Leopard
xaviermaxenator
 
Posts: 1
Joined: Fri Jan 09, 2009 5:00 pm


Return to Writer

Who is online

Users browsing this forum: Google [Bot] and 7 guests