Page 1 of 1

[Solved] Unknown solid line

PostPosted: Tue Oct 21, 2008 1:46 am
by pauliw25
I am using OO3 on a machine that runs Vista Home edition SP1.

In a document I have be working on in Writer,somehow, between two paragraphs I have managed to create a solid black line that exends the full width of the page. The problem is - I don't know how I manage to create it - nor do I know how to get rid of it. I've tried selecting View to show Hidden Characters but didn't see anything that would help.

Any suggestions?

Re: Unknown solid line

PostPosted: Tue Oct 21, 2008 2:22 am
by acknak
Before I explain how to get rid of it, you should understand how it happens.

In your Writer document, place the cursor on an empty paragraph. Type Hello, then Enter, then type three hyphens in a row, but NO ENTER yet. You should see this:
Hello
---

Now press Enter on the line of hyphens. Do you see what happened? Type Ctrl+Z/Ctrl+Y to see it again.

The hyphens are changed into a line underneath the "Hello" paragraph.

Writer does this as a quick way to add a horizontal line across the page. But Writer uses a small trick to make the line: it's actually part of the paragraph above the hyphens: the line is a border on the bottom edge of the paragraph. You can remove it when it happens by typing Ctrl+Z (undo); you can remove it later by putting the cursor on the paragraph and doing Format > Paragraph > Borders > Line arrangement: none (click the diagram with no borders), OK.

If you don't like this at all and you don't want it to happen again, go to Tools > AutoCorrect > Options > Replace dashes Apply borders: NO (unchecked).

Solved - Re: Unknown solid line

PostPosted: Tue Oct 21, 2008 9:57 pm
by pauliw25
Thanks acknak.

Your instructions worked beautifully.


:D

Re: Unknown solid line

PostPosted: Tue Oct 21, 2008 10:52 pm
by AJB-work
acknak wrote:Before I explain how to get rid of it, you should understand how it happens.

In your Writer document, place the cursor on an empty paragraph. Type Hello, then Enter, then type three hyphens in a row, but NO ENTER yet. You should see this:
Hello
---

Now press Enter on the line of hyphens. Do you see what happened? Type Ctrl+Z/Ctrl+Y to see it again.

The hyphens are changed into a line underneath the "Hello" paragraph.

Writer does this as a quick way to add a horizontal line across the page. But Writer uses a small trick to make the line: it's actually part of the paragraph above the hyphens: the line is a border on the bottom edge of the paragraph. You can remove it when it happens by typing Ctrl+Z (undo); you can remove it later by putting the cursor on the paragraph and doing Format > Paragraph > Borders > Line arrangement: none (click the diagram with no borders), OK.

If you don't like this at all and you don't want it to happen again, go to Tools > AutoCorrect > Options > Replace dashes: NO (unchecked).


I think the actual way to turn this on or off is to check (or uncheck for off) the Tools > AutoCorrect> Options > Apply Borders

Re: [Solved] Unknown solid line

PostPosted: Wed Oct 22, 2008 2:37 am
by acknak
Ack! Sorry! You're exactly right. I thought "replace dashes" didn't seem right but I missed the "apply borders" option when I went to look for it.

Thanks for the correction--I fixed it up above also, in case anyone should come by later and read the thread.

Re: [Solved] Unknown solid line

PostPosted: Thu Dec 03, 2009 10:15 pm
by jimbir
Thanks Acknak. :knock:
I'm new to this program and this was driving (actually a short walk) me crazy. I suspected how it happened but, I couldn't figure out how to get rid of it.

Re:

PostPosted: Wed Jun 15, 2011 9:12 am
by knalstaaf
Unfortunately none of this works for OOo 3.2.1 on MacOSX 10.5.6. It would just move the line upward...

Re: [Solved] Unknown solid line

PostPosted: Wed Jun 15, 2011 9:28 am
by RoryOF
Can you upload a short sample file to the Forum? The upload tab is below the Submit button on the Post A Reply window (not Quick Reply window)

Re: Re:

PostPosted: Wed Jun 15, 2011 9:57 am
by Bill
knalstaaf wrote:Unfortunately none of this works for OOo 3.2.1 on MacOSX 10.5.6. It would just move the line upward...

No, they don't "move", and yes, it does work. If you have two consecutive paragraphs with bottom borders set and also have the "merge with next paragraph" option enabled, then the first paragraph's border will not be shown until the border is removed from the second paragraph. You just haven't removed all of the borders from all of the paragraphs yet.

Re: [Solved] Unknown solid line

PostPosted: Thu May 10, 2012 7:57 am
by MargaretRobinson
I have this problem as well, and none of these solutions are working for me.I'm using Open Office for Mac OSX 10.7.3. I've tried selecting the paragraph and removing the line arrangement, but it always reverts to using the line. I've tried selecting all the paragraphs and doing this, but it has no effect.

Re: [Solved] Unknown solid line

PostPosted: Thu May 10, 2012 1:45 pm
by jrkrideau
MargaretRobinson wrote:I have this problem as well, and none of these solutions are working for me.I'm using Open Office for Mac OSX 10.7.3. I've tried selecting the paragraph and removing the line arrangement, but it always reverts to using the line. I've tried selecting all the paragraphs and doing this, but it has no effect.


Your best bet would be to upload an example so forum members can have a look.