How can I turn off the punctuation marks auto-correction?

Discuss the word processor

How can I turn off the punctuation marks auto-correction?

Postby xieqidong » Sat Oct 18, 2008 2:08 pm

Environment: OpenOffice 3.0 RC4 Simplified Chinese version, Windows intel x86

Detail: the sWriter always corrects my entered Chinese quotation marks, for instance, when there is some English characters in the Chinese double quotation marks, sWriter always changes the right quotation mark as English quotation mark. It’s boresome, how can I turn it off? or it’s just relevant with the source code? I tried several ways, but doesn't work.

by the way: Microsoft Office 2007 is OK with that.

thanks a lot, guys.
Last edited by xieqidong on Sat Oct 18, 2008 3:18 pm, edited 2 times in total.
xieqidong
 
Posts: 4
Joined: Sat Oct 18, 2008 2:01 pm

Re: How can I turn off the punctuation marks auto-correction?

Postby floris v » Sat Oct 18, 2008 2:22 pm

Check out Tools - Autocorrect - Custom quotes and play a bit with the settings there.

If your your problem has been solved, please edit the first post of this thread (Edit button) and add [Solved] to the start of the subject line.
MS Windows Vista - AOO 4.0.1 - LibreOffice 4.1.0.4.
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 3024
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: How can I turn off the punctuation marks auto-correction?

Postby xieqidong » Sat Oct 18, 2008 3:14 pm

floris v wrote:Check out Tools - Autocorrect - Custom quotes and play a bit with the settings there.



Thanks, but doesn't work.
OOo 3.0.X on MS Windows Vista
xieqidong
 
Posts: 4
Joined: Sat Oct 18, 2008 2:01 pm

Re: How can I turn off the punctuation marks auto-correction?

Postby floris v » Sat Oct 18, 2008 3:19 pm

Check out Autocorrect - Options as well, there's one item for replacing quotation marks by custom quotation marks.
MS Windows Vista - AOO 4.0.1 - LibreOffice 4.1.0.4.
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 3024
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: How can I turn off the punctuation marks auto-correction?

Postby xieqidong » Sat Oct 18, 2008 5:10 pm

floris v wrote:Check out Autocorrect - Options as well, there's one item for replacing quotation marks by custom quotation marks.


Thanks, still doesn't work, I tried everything.

Chinese double quotation marks only can contain Chinese characters, as long as a English character is next to the right quotation mark, it will automaticly change to English quotation mark.

I don't know what to do.
xieqidong
 
Posts: 4
Joined: Sat Oct 18, 2008 2:01 pm

Re: How can I turn off the punctuation marks auto-correction?

Postby acknak » Sat Oct 18, 2008 6:44 pm

If Tools > AutoCorrect > Options > Replace "standard" quotes with "custom" quotes is OFF, but you're still seeing automatic changes, then I wonder if it could be a language-specific setting? I'm pretty sure that at least some of the autocorrect settings are language-specific, although I don't which, or how you view settings for a particular language.

Is the language attribute of the text passages where the quotes are changing set to Chinese?

Also, you could try Format > AutoFormat > While Typing: NO (unchecked). That should prevent any automatic changes while you type. If you still see the problem then maybe it's not coming from OOo at all.
AOO 4 • Linux • Fedora 17
User avatar
acknak
Moderator
 
Posts: 17399
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: How can I turn off the punctuation marks auto-correction?

Postby Bhikkhu Pesala » Sat Oct 18, 2008 7:30 pm

xieqidong wrote:Chinese double quotation marks only can contain Chinese characters, as long as a English character is next to the right quotation mark, it will automaticly change to English quotation mark.

Autocorrect is language sensitive. You must type the closing double quotation mark in Chinese, then switch to English. Notice the current language in the status line.
Free Speech and Right Speech
OOo 3.0.X on Ms Windows XP
Bhikkhu Pesala
 
Posts: 1253
Joined: Mon Oct 08, 2007 1:27 am

Re: How can I turn off the punctuation marks auto-correction?

Postby xieqidong » Mon Oct 20, 2008 9:21 am

Thank you guys above.

When I input a English character in the Chinese double quotation marks and next to the right Chinese quotation mark, it still changes, and the current language in status line changes from Simplified Chinese to English right now.

I tried All you've said, but doesn't work. only can select all text, and set to Chinese FontType, that works.
OOo 3.0.X on MS Windows Vista
xieqidong
 
Posts: 4
Joined: Sat Oct 18, 2008 2:01 pm


Return to Writer

Who is online

Users browsing this forum: No registered users and 16 guests