[Solved] Autocorrect never works properly for me

Discuss the word processor

[Solved] Autocorrect never works properly for me

Postby ErikJon » Thu Apr 23, 2020 2:17 am

Hello my very dear friends. Thank you for taking the time to offer help to this lost soul.

I've been using OpenOffice for about ten years, I guess, and have never been able to get Autocorrect to work completely. What I mean specifically, is that I cannot seem to keep it from suggesting unsolicited corrections.

For example, after selecting "use replacement table" in the "options" tab of the Autocorrect Options dialog box, and after selecting "enable word completion" in the "word completion" tab of the same, and after deleting all of the default replacement table words, and after manually deleting all "exceptions" from the "exceptions" tab, I am still presented with "Monday" when typing "mon." even though that option has already been deleted from the replacement table.

I have tried re-starting the program, but that does not help.

I have reset my profile over the years, including two weeks ago, but this does not seem to be related to my problem.

Can you tell me how to get OpenOffice to stop suggesting corrections for words that do not exist in the replacement table?

I am using OpenOffice 4.1.7. on Windows Vista Ultimate 32-bit SP2
Last edited by RusselB on Sat Apr 25, 2020 12:46 am, edited 1 time in total.
Reason: Topic edited per last post, Solved tag and green check added.
I am using OpenOffice 4.1.7. on Vista Ultimate 32-bit SP2
ErikJon
 
Posts: 14
Joined: Sun Oct 16, 2011 6:12 am

Re: Autocorrect never works properly

Postby RusselB » Thu Apr 23, 2020 3:07 am

Many options are stored in your user profile, thus when you reset it, you also lose the customization settings, including any Options settings that are stored therein.
Aside from that, I'm going to refer this topic to a helper that uses Writer more than I do.
OpenOffice 4.1.7 and LibreOffice 6.3.3.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 6119
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: Autocorrect never works properly

Postby Bill » Thu Apr 23, 2020 3:31 am

ErikJon wrote:...after selecting "use replacement table" in the "options" tab of the Autocorrect Options dialog box, and after selecting "enable word completion" in the "word completion" tab of the same, and after deleting all of the default replacement table words, and after manually deleting all "exceptions" from the "exceptions" tab, I am still presented with "Monday" when typing "mon." even though that option has already been deleted from the replacement table.

"Word completion" does not use the replacement table. "Word completion" and "Use replacement table" are two different options. You need to uncheck the "Enable word completion" option to turn it off.
AOO 4.1.7, LO 6.3.6.2 and LO 6.4.3.2 on Kubuntu 20.04
Bill
Volunteer
 
Posts: 7875
Joined: Sat Nov 24, 2007 6:48 am

Re: Autocorrect never works properly

Postby Villeroy » Thu Apr 23, 2020 10:18 am

Word completion completes words you are going to type based on what you already typed. Very useful with long composite words in German.
AutoCorrect corrects words you finished typing with a trailing space based on a replacement list. This may be common misspellings or things like 1/2 --> ½
And then there is spell checking which compares every single word with a dictionary.
One of the most useful featues is "Auto Text" which inserts prepared content based on a shortcut. Type dt and hit F3. dt stands for "dummy text". This inserts formatted and unformatted text, fields, tables, graphics(? don't know),...
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28569
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Autocorrect never works properly

Postby ErikJon » Fri Apr 24, 2020 6:06 am

I see. So then word completion is different from autocorrect. I did not know that. I will try everything that you suggested and see if that helps. Thank you so much for your suggestions.
I am using OpenOffice 4.1.7. on Vista Ultimate 32-bit SP2
ErikJon
 
Posts: 14
Joined: Sun Oct 16, 2011 6:12 am

[SOLVED] Autocorrect never works properly for me

Postby ErikJon » Sat Apr 25, 2020 12:17 am

Dear Gentlemen,

I have tried what you suggested and come to the happy conclusion that, there was nothing wrong with OpenOffice, but only with my limited understanding regarding how it was supposed to work. I now understand the difference between "word completion" and "replacement table," and, yes, it is quickly becoming very useful to me.

How strange that I could go for so many years without being aware of this feature, and having to re-type so many long phrases, thousands of times, just out of ignorance.

Thank you for being so kind as to explain the answer, and the point about the profile.

by the way, sorry for the sloppiness of my thread title. It should have read something like, "Autocorrect never works properly for me," although it was not my intention to imply that the feature was defective. I will try to re-title the thread to preclude any other future misunderstandings.
I am using OpenOffice 4.1.7. on Vista Ultimate 32-bit SP2
ErikJon
 
Posts: 14
Joined: Sun Oct 16, 2011 6:12 am


Return to Writer

Who is online

Users browsing this forum: No registered users and 22 guests