[Solved] Spell check not working in 4.1.7

Discuss the word processor

[Solved] Spell check not working in 4.1.7

Postby jlfiegel » Wed Apr 08, 2020 9:35 pm

 Edit: Split from Spell check not working in 4.1.7 — MrProgrammer 2020-04-08 19:58 UTC 
Hi
I have 4.17. Spellcheck works on *some* documents and not on others. I've noticed that it works on older existing documents that I re-open and modify. Spellcheck is not working on new docs that I am creating in the last couple of weeks.
I've attached a new doc where it is not working. Can someone take a look at this and tell me what the issue is?

Best
John
Attachments
Notes OO Spellcheck.odt
(15.67 KiB) Downloaded 20 times
Last edited by Hagar Delest on Mon Apr 13, 2020 4:00 pm, edited 1 time in total.
Reason: tagged solved
OpenOffice 4.17 on Win 10
jlfiegel
 
Posts: 2
Joined: Wed Apr 08, 2020 9:30 pm

Re: Spell check not working in 4.1.7

Postby MrProgrammer » Wed Apr 08, 2020 10:08 pm

Hi, and welcome to the forum.

jlfiegel wrote:Can someone take a look at this and tell me what the issue is?
The Format → Character → Font dialog shows that no language is assigned to this text, therefore Writer cannot spell check it. Writer needs a language to determine which dictionary to use for the spelling check.
Screen Shot 2020-04-08 at 15.00.52.jpg
I set Tools → Language → For All Text → English (USA). Then spell check found several problems in your writing.

jlfiegel wrote:Spellcheck is not working on new docs that I am creating in the last couple of weeks.
You may need to set the For All Text language in the template that Writer is now using. Read about templates in Help → Index or in User Guides (PDF) or searching for topics about this in the Writer Forum.

If you continue to have difficulty, read [Solved] Spell Check Not Working (words red underlined).

If this solved your problem please go to your first post use the Edit button and add [Solved] to the start of the title. You can select the green checkmark icon at the same time.
Mr. Programmer
AOO 4.1.7 Build 9800 on MacOS 10.14.6.   The locale for any menus or Calc formulas in my posts is English (USA).
User avatar
MrProgrammer
Moderator
 
Posts: 3961
Joined: Fri Jun 04, 2010 7:57 pm
Location: Wisconsin, USA

Re: Spell check not working in 4.1.7

Postby RoryOF » Wed Apr 08, 2020 10:17 pm

The Status Bar (bottom Bar of OO window) shows language selected is "None". If you cannot see Status Bar, use /View Status Bar to turn it on.

To cure the problem for this file, use /Tools /Language : for all text, and select your desired language from the popup.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31416
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell check not working in 4.1.7

Postby jlfiegel » Mon Apr 13, 2020 3:45 pm

Thanks!
OpenOffice 4.17 on Win 10
jlfiegel
 
Posts: 2
Joined: Wed Apr 08, 2020 9:30 pm


Return to Writer

Who is online

Users browsing this forum: No registered users and 9 guests