[Solved] Copy & Paste now acting strange

Discuss the word processor

[Solved] Copy & Paste now acting strange

Postby toss@usa.com » Wed Apr 08, 2020 7:43 pm

I'm not sure this is an Apache Open Office problem or not. Up until version 4.16 or so, I could highlight words found on the internet, select them as 'copy' and drop them into an OO document with no problem.

For the last few months, I can no longer do this in 4.16 or 4.17. When I try to copy, I find no 'paste' capability listed in the drop-down in OO.

To make matters more confusing, if I drop the words or phrase copied into the 'search' space of Firefox's browser, then I can copy the same phrase and now drop it into OO with the 'paste' feature just as it used to be. Anyone have a fix for this. The extra steps are a pain in the patootie.
Last edited by Hagar Delest on Thu Apr 09, 2020 5:51 pm, edited 1 time in total.
Reason: tagged solved
openoffice 4.1.1
toss@usa.com
 
Posts: 27
Joined: Wed Dec 17, 2014 1:34 am

Re: Copy & Paste now acting strange

Postby John_Ha » Wed Apr 08, 2020 8:14 pm

Works fine for me with Firefox and AOO 4.1.7.

Strange problems are sometimes fixed by resetting the profile - see Resetting the user profile.

toss@usa.com wrote:I could highlight words found on the internet, select them as 'copy' and drop them into an OO document with no problem.

I assume you mean "highlight words found on the internet, press Ctrl+V to copy them (or r-click > Copy), and paste them into an OO document with Ctrl+V (or r-click > Paste) with no problem"
Attachments
your post.odt
(12.98 KiB) Downloaded 21 times
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7794
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

SOLVED Re: Copy & Paste now acting strange

Postby toss@usa.com » Wed Apr 08, 2020 10:10 pm

While I still do not have the drop down 'paste' option HAGAR suggested to try plain old Cntr V which works good enough for me. Thanks one and all.

Yes, thank you. What you described is how it used to work for me. But not now. The copy "paste" is absolutely empty in OO but I can drop the same paste with its word or phrase right into the search field of Firefox---- then re-copy right from the search block and THEN it would show up as a "paste" on OO.
Last edited by toss@usa.com on Thu Apr 09, 2020 3:34 am, edited 1 time in total.
openoffice 4.1.1
toss@usa.com
 
Posts: 27
Joined: Wed Dec 17, 2014 1:34 am

Re: Copy & Paste now acting strange

Postby Hagar Delest » Wed Apr 08, 2020 11:28 pm

You mean that there is no Paste icon?
Have you tried Ctrl+V?
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Copy & Paste now acting strange

Postby John_Ha » Thu Apr 09, 2020 12:00 am

What happened when you reset the profile?
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7794
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Copy & Paste now acting strange

Postby toss@usa.com » Thu Apr 09, 2020 3:14 am

Sorry, I do not know what you mean. As far as I know I had nothing to do with a profile. Looked in OO help and it does not mention profile.
openoffice 4.1.1
toss@usa.com
 
Posts: 27
Joined: Wed Dec 17, 2014 1:34 am

Re: Copy & Paste now acting strange

Postby robleyd » Thu Apr 09, 2020 3:21 am

Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3458
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Copy & Paste now acting strange

Postby John_Ha » Thu Apr 09, 2020 12:41 pm

toss@usa.com wrote:Sorry, I do not know what you mean

Did you not read my first post where I wrote
Strange problems are sometimes fixed by resetting the profile - see Resetting the user profile.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7794
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved] Copy & Paste now acting strange

Postby Hagar Delest » Thu Apr 09, 2020 5:57 pm

For the record, I received an PM from OP telling that the Ctrl+V shortcut does work.
But still a kind of workaround for those relying on the toolbar buttons.

I think that I've seen that in the past but I've removed that icon a while ago. However, sometimes I experience similar glitches when for example I cannot paste a clipboard content As formatted text (RTF) when it does paste with the standard Paste (Ctrl+V).

It's like AOO sometimes is not un sync anymore with the clipboard.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Copy & Paste now acting strange

Postby John_Ha » Thu Apr 09, 2020 8:52 pm

Hagar

See Issue 113171 - OO does not paste the text contents of the Windows clipboard - instead, it pastes the previous text copied in OO. See comment 2 - it could just be AOO takes a few seconds to do the paste.

I used to have it frequently but it stopped. I am pretty sure it is hardware dependent as my wife's laptop never had the problem.

Clipboard problems are sometimes due to clipboard utilities (like retain a history of clipboard items).
Last edited by John_Ha on Thu Apr 09, 2020 8:56 pm, edited 1 time in total.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7794
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved] Copy & Paste now acting strange

Postby Hagar Delest » Thu Apr 09, 2020 8:55 pm

No, it's different because when I paste with Ctrl+V (just Paste), it works well, the correct content is pasted, even if it failed with Paste as unformatted text.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Copy & Paste now acting strange

Postby w3irdo » Wed Aug 12, 2020 6:18 am

same error here.

i copy text from web browser, the paste and paste special selection from OO dropdown are disabled.

must reset profile or reinstall the app?
OpenOffice 4 on Windows 7
w3irdo
 
Posts: 7
Joined: Tue Apr 08, 2014 4:57 am

Re: [Solved] Copy & Paste now acting strange

Postby Villeroy » Wed Aug 12, 2020 6:47 am

w3irdo wrote:must reset profile or reinstall the app?

If you really want to use the unmaintained OpenOffice application, you should try to reset the profile.
If you want to install a better application that tries to make things better, then you should install https://libreoffice.org/
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28544
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Solved] Copy & Paste now acting strange

Postby w3irdo » Wed Aug 12, 2020 7:11 am

Villeroy wrote:
w3irdo wrote:must reset profile or reinstall the app?

If you really want to use the unmaintained OpenOffice application, you should try to reset the profile.
If you want to install a better application that tries to make things better, then you should install https://libreoffice.org/


too bad my vba all installed on OO. I tried libra and their display of my worksheet very different... alot changes to do
OpenOffice 4 on Windows 7
w3irdo
 
Posts: 7
Joined: Tue Apr 08, 2014 4:57 am

Re: [Solved] Copy & Paste now acting strange

Postby Hagar Delest » Wed Aug 12, 2020 8:08 am

You can try to reset the profile but not sure it will help. Don't delete it, just rename it so that you can retrieve it if there is no change.
Reinstalling won't change anything IMHO.
It still happens from time to time for me but haven't really tried to find a pattern (no time when facing that issue). IIRC, it happens with HTML (especially from mail) and sometime from PDF.
Maybe a clipboard application would do better (never tried myself but there are some suggestions in the forum).
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Copy & Paste now acting strange

Postby Villeroy » Wed Aug 12, 2020 8:13 am

w3irdo wrote:
Villeroy wrote:
w3irdo wrote:must reset profile or reinstall the app?

If you really want to use the unmaintained OpenOffice application, you should try to reset the profile.
If you want to install a better application that tries to make things better, then you should install https://libreoffice.org/


too bad my vba all installed on OO. I tried libra and their display of my worksheet very different... alot changes to do

OpenOffice hardly supports VBA. LibreOffice does that fairly well. If you mean StarBasic, just copy the basic folder from one profile to the other. And yes, office documents may look different even when using the same software on different systems because of installed fonts. The most important thing is that your spreadsheet works correctly. How things are displayed is a secondary issue.
You can run both applications side by side on the same system. OpenOffice is almost dead.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, no OpenOffice, LibreOffice 6.4
User avatar
Villeroy
Volunteer
 
Posts: 28544
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Solved] Copy & Paste now acting strange

Postby w3irdo » Wed Aug 12, 2020 8:35 am

Villeroy wrote:You can run both applications side by side on the same system. OpenOffice is almost dead.


does that mean openoffice already end of life? no more support?
OpenOffice 4 on Windows 7
w3irdo
 
Posts: 7
Joined: Tue Apr 08, 2014 4:57 am

Re: [Solved] Copy & Paste now acting strange

Postby Hagar Delest » Wed Aug 12, 2020 9:38 pm

No, but the development stalls.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28951
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Copy & Paste now acting strange

Postby Zizi64 » Thu Aug 13, 2020 6:43 am

does that mean openoffice already end of life? no more support?

Never was "official support" for the OpenOffice. (This is a User forum.)
There was only upgraded versions from the developers.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9542
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary


Return to Writer

Who is online

Users browsing this forum: No registered users and 11 guests