Spell check not working in 4.1.7

Discuss the word processor

Spell check not working in 4.1.7

Postby Chris879 » Wed Jan 29, 2020 5:42 am

I am using windows 10 and I have open office 4.1.7. now. I have used open office it for many years with a language pack for another language.
My English spell checker just does not work anymore. I have unloaded the software about 5 times. I have uninstalled with Revo uninstaller so nothing will remain. I have reset user profile multiple times on previous versions, nothing works anymore . I am wondering if there is a bug. The new downloaded version on my PC then may work one time on some document I have just typed , but it will not work on previous documents saved which are still waiting for correction.
As soon as I download the language pack, that also seems to make the English spell check worse .
The language pack in a foreign language does the spell check for the other language just fine.
To make matters more confusing , English correction works for some documents and not others.
I have spent 5 hours to confirm the fact that certain of my typed documents will not spellcheck, I cannot figure out why. I need to spellcheck not a native English speaker.
Is the open office version 4.1.7 incompatible with certain windows versions? Does it need Java. ? I am at a total loss . Chris
windows 10. open office 4.1.7
Chris879
 
Posts: 7
Joined: Mon May 16, 2016 5:57 am

Re: spell check not working in 4.1.7

Postby FJCC » Wed Jan 29, 2020 5:50 am

I am not aware of any spell check bug in version 4.1.7. If you could upload a file that fails to spell check on your system, we could see if it has the same problem for other people. If you can just make a short document with the problem, that would be best. Maybe make a copy of one of your files and delete most of the text.
To upload a file, click Post Reply and look for the Upload Attachment tab just below the box where you type a response.
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 7673
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: spell check not working in 4.1.7

Postby robleyd » Wed Jan 29, 2020 6:28 am

Have you looked at [Troubleshooting] Spell check in OpenOffice. particularly the part about language settings for paragraphs?
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3389
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Spell check not working in 4.1.7

Postby Bill » Wed Jan 29, 2020 7:20 pm

Chris879 wrote:As soon as I download the language pack, that also seems to make the English spell check worse .
The language pack in a foreign language does the spell check for the other language just fine.

Language packs contain the files that change the language of the user interface. Language packs don't contain dictionaries that can be used by SpellCheck so installing a language pack should have no effect on SpellCheck. Did you download and install the correct dictionaries? Did you check the language setting for the text in the documents that SpellCheck isn't checking?
AOO 4.1.7, LO 6.3.6.2 and LO 6.4.3.2 on Kubuntu 20.04
Bill
Volunteer
 
Posts: 7792
Joined: Sat Nov 24, 2007 6:48 am

Re: Spell check not working in 4.1.7

Postby RoryOF » Wed Jan 29, 2020 7:24 pm

Also, for paragraphs or text strings in the foreign language, are the relevant Paragraph Styles or Character Styles set to indicate the foreign language?
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31209
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell check not working in 4.1.7

Postby Chris879 » Thu Jan 30, 2020 2:28 am

Thanks for all your input
I have done all trouble -shooting described at open office .
I have restarted every time I download open office.
I download the language pack and of course I download also the extension dictionary.
But as I said, I have no problem spellchecking the other language, only the default language English.

I have certain personal documents that do not spellcheck.
I have taken portions of that text of the document which does not spellcheck and transferred it to a new open office file. Than I try to spell check that. It does not spell check either , No mater how tiny an excerpt I transfer , it does not spell check. This happens still even though most of my newly typed documents in open office now spell check in English.

Unfortunately I cannot upload my personal document. I am beginning to think there is no solution.

It could be that the document is corrupted? I would not know .
What I can say , originally it had a link to an article to in the Washington Post. Since then I have removed the link from the text , but maybe it altered something in the text document which now cannot be undone . Definitely this corruption transfers itself when I transfer parts of the text. Just odd.
I will watch this and post if this gets to be a regular thing.
windows 10. open office 4.1.7
Chris879
 
Posts: 7
Joined: Mon May 16, 2016 5:57 am

Re: Spell check not working in 4.1.7

Postby Bill » Thu Jan 30, 2020 3:36 am

You have not yet said anything about the language setting for the text that is not being spell checked. If you click an English word in one of the problem documents, what language is displayed in the Status Bar?
AOO 4.1.7, LO 6.3.6.2 and LO 6.4.3.2 on Kubuntu 20.04
Bill
Volunteer
 
Posts: 7792
Joined: Sat Nov 24, 2007 6:48 am

Re: Spell check not working in 4.1.7

Postby Chris879 » Thu Jan 30, 2020 8:40 pm

Most of my documents are in English. Occasionally, I write a document in the other language. Before I start the spellcheck, I always reset what language I want to spell check with. The documents which I have trouble spell checking are in English, they have no other language in the text itself. The spell checker is set for English. And yes, I have checked the bottom of the open office writer to see if the correct language shows on the bottom.
windows 10. open office 4.1.7
Chris879
 
Posts: 7
Joined: Mon May 16, 2016 5:57 am

Re: Spell check not working in 4.1.7

Postby RoryOF » Thu Jan 30, 2020 8:52 pm

Try downloading the attached file. It is set to English(UK) and all instances of Bennet and Darcy have been misspelled.
Attachments
Pride and Prejudice chap 1-4 with mistakes.odt
(21.67 KiB) Downloaded 33 times
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31209
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell check not working in 4.1.7

Postby Chris879 » Thu Jan 30, 2020 9:22 pm

Yes, I can spell check that.
So this confirms my suspicion that I have some documents on my PC from the past three weeks which are corrupted. And for some strange reason I cannot spell check them.
I will have type them new. Thanks for your help.
windows 10. open office 4.1.7
Chris879
 
Posts: 7
Joined: Mon May 16, 2016 5:57 am

Re: Spell check not working in 4.1.7

Postby RoryOF » Thu Jan 30, 2020 9:24 pm

If they are corrupted, they will show as #### for the entire file or other obvious corrupt lines (not necessarily the entire file).

Can you upload a sample file?
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31209
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell check not working in 4.1.7

Postby Bill » Thu Jan 30, 2020 9:39 pm

Chris879 wrote:Most of my documents are in English. Occasionally, I write a document in the other language. Before I start the spellcheck, I always reset what language I want to spell check with.

Just to clarify, how exactly do you "reset what language I want to spell check with"? I'm not aware of an option that does this, nor am I aware of any reason such an option should be necessary. If the language attribute is set for the text, then SpellCheck automatically knows which dictionary to use. No resetting is required.
AOO 4.1.7, LO 6.3.6.2 and LO 6.4.3.2 on Kubuntu 20.04
Bill
Volunteer
 
Posts: 7792
Joined: Sat Nov 24, 2007 6:48 am

Re: Spell check not working in 4.1.7

Postby Chris879 » Fri Jan 31, 2020 10:14 pm

When I type a document in the foreign language ( in this case my native language) , I just open "open office writer" and type the text . While I type, I do not worry about red underlines. I have turned that off . I spell check later .
Then when I want to spell check my text with my native language , I go to „Tools“ in the writer . Then I click „Language“. then I choose for „ all text“. I click and choose/mark the foreign language on the right the one I want. By clicking it is simply selected . If the language you want does not show immediately on the right, I choose „more " What comes up then, is the window with the “Language settings” of open office .
My default is marked of course as “English” . I then scroll down in that window through the languages to my native language I typed in . I choose that native language and make it my default option. Of course my native language has already a” check mark” next to it in the scroll down list, as I have previously downloaded its language pack and the dictionary .So now at the bottom of the writer as default it does not say „English“ ,it states my native language Now when I hit spellcheck, it corrects for my native language. Since I change the default language , every time I spell check a document, I have to watch which language I am in.
windows 10. open office 4.1.7
Chris879
 
Posts: 7
Joined: Mon May 16, 2016 5:57 am


Return to Writer

Who is online

Users browsing this forum: No registered users and 10 guests