[Solved] com::sun::star::uno::RuntimeException

Discuss the word processor

[Solved] com::sun::star::uno::RuntimeException

Postby gatomas » Sat Jun 13, 2009 12:24 am

Hi,

I just installed 3.1, as root, on a Linux box with no prior installation of ANY Open Office. Here are my steps:

1. downloaded OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar.gz
2. Opened an terminal
3. From the command line I copied OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar.gz to /tmp
4. tar xvzf OOo_3.1.0_LinuxIntel_install_wJRE_en-US.tar.gz
5. cd to OOO310_m11_native_packed-2_en-US.9399/RPMS
6. rpm -Uvih *rpm
7. change users (su -) to sarahpalin (assuming it is existing)
8. cd into the Default installation directory: /opt/openoffice.org3/program
9. typed on the command line ./swriter

A few seconds later, I get this error message on my terminal, "terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'"

change user back to root
1. As root, I cd into the Default installation directory: /opt/openoffice.org3/program
2. typed on the command line ./swriter
3. Open Office Writer launches, no problem


First of all, It's frustrating to decipher this error except that its a runtime exception. [answer: Ok, I google'd it found out that it might be something OO not being able to writer to user's directory the necessary config files, is that true?]

Second, I already read http://user.services.openoffice.org/en/forum/viewtopic.php?f=74&t=12426 and does not help because I did a clean install on a machine that never had a user profile.

Would someone please advise me on what is wrong? Authors? Anyone?

Thank you in advance!
Last edited by Hagar Delest on Mon Dec 07, 2009 4:50 pm, edited 1 time in total.
Reason: tagged [Solved].
OOo 2.3.X on Linux-Other
gatomas
 
Posts: 21
Joined: Thu May 07, 2009 11:16 pm

Re: com::sun::star::uno::RuntimeException = FRUSTRATION!

Postby hol.sten » Sat Jun 13, 2009 8:46 am

gatomas wrote:7. change users (su -) to sarahpalin (assuming it is existing)

Did you try to not use su? So logout as root, login as the user, start OOo?

BTW: Which Linux distribution are you using?
OOo 3.2.0 on Ubuntu 10.04 • OOo 3.2.1 on Windows 7 64-bit and MS Windows XP
hol.sten
Volunteer
 
Posts: 495
Joined: Mon Oct 08, 2007 1:31 am
Location: Hamburg, Germany

Re: com::sun::star::uno::RuntimeException = FRUSTRATION!

Postby gatomas » Sat Jun 13, 2009 9:38 pm

Thanks for the reply. I am running Red Hat Linux.

I tried your suggestion by logging off as root and logging back on as a user. However, it didn't work.

I did notice that if I cleared the cache on the following directories:

/opt/openoffice.org3/share/uno_packages
/usr/local/<user>/.openoffice.org/3/user/uno_packages

it seems to work but I don't fully understand it. :?
OOo 2.3.X on Linux-Other
gatomas
 
Posts: 21
Joined: Thu May 07, 2009 11:16 pm


Return to Writer

Who is online

Users browsing this forum: robleyd and 18 guests