Spacing between footnotes

Discuss the word processor

Spacing between footnotes

Postby MartinEve » Sat Mar 14, 2009 7:21 pm

Hi all,

I am just switching over to OOo having been an MS Word user for the duration.

The trouble that I am experiencing is with footnotes in documents. I have adjusted the paragraph style to have a line spacing of 0 and to have no spacing above or below the paragraph. However, my footnotes always turn out like this:

gapbetweenfootnotes.png

This was imported from an MS Word document, but the same problem happens if I simply create a new document and add footnotes.

How can I get my footnotes to butt up directly against each other?

Many thanks,

Martin
Last edited by MartinEve on Mon Mar 16, 2009 10:19 am, edited 1 time in total.
OOo 3.0.X on Ubuntu 8.x
MartinEve
 
Posts: 10
Joined: Sat Mar 14, 2009 7:10 pm

Re: Spacing between footnotes

Postby MartinEve » Sat Mar 14, 2009 8:24 pm

Just a follow-up; seems I was wrong - the problem does not occur when creating a new document, only when importing from Word 2007...
OOo 3.0.X on Ubuntu 8.x
MartinEve
 
Posts: 10
Joined: Sat Mar 14, 2009 7:10 pm

Re: Spacing between footnotes

Postby MacPhisto » Sun Mar 15, 2009 1:55 pm

Are you used to using styles? I think you can solve this by changing the style used for footnotes. Through the context menu—right click on the paragraph—select “Edit Paragraph Style… > Indents & Spacing” and change the spacing above and/or below paragraph.
If your question has been answered, please add “[Solved]” to the beginning of the title of your first post (use the edit button.)
OOo 3.0.X on Ubuntu 9.x
User avatar
MacPhisto
 
Posts: 75
Joined: Tue Dec 09, 2008 11:05 am
Location: The Netherlands

Re: Spacing between footnotes

Postby MartinEve » Sun Mar 15, 2009 2:03 pm

Hi,

First off: thanks for the reply.

Sadly I've already tried editing the styles. I have set the "Spacing" to 0.00cm both before and after on the paragraph "Footnote" and "footnote text", but neither seems to fix this problem. I've tried doing this through the context menu (as you suggested) and through the Styles and Formatting toolbar. It's only happening on Word 2007 docx files though, my new files are ok. However, as I would like to read all my old documents without having to re-do them to get clean footnotes, any further help would be greatly appreciated!

Martin
OOo 3.0.X on Ubuntu 8.x
MartinEve
 
Posts: 10
Joined: Sat Mar 14, 2009 7:10 pm

Re: Spacing between footnotes

Postby Helge » Sun Mar 15, 2009 3:19 pm

I have the same problem with footnotes as you. I have also imported documents from Office 2007. I have further problems with my footnotes in that they do no longer align in the left margin. I have created new documents, cut all the footnotes, pasted them in new documents, reformatted them and then pasted them back. The problems remain. The problem must be the import from Office 2007. I have had other problems with imported files. If you perhaps have the original files left and could get to Office 2007 you could save the docx files to .doc (Or perhaps use MS word to save in .odt-format, MS have an add-on that can do this.) It seems that there are less problem with imported .doc files and this may perhaps solve the problem. I would be interested if you manage to convert the footnotes somehow. If I come up with something good I will let you know!
OOo 3.3/LibO 3.3.3 on Kubuntu 11.04/Windows 7
Helge
 
Posts: 96
Joined: Sat Feb 14, 2009 9:37 pm
Location: Sweden

Re: Spacing between footnotes

Postby MartinEve » Sun Mar 15, 2009 3:22 pm

Hi Helge,

Well, at least it's good to know that somebody else is having the same problem. I have also opted for the cut and paste approach, manually reinserting the footnotes in my new .odf document. However, it's far from ideal!

With visible text boundaries it looks like the "Spacing" option under Styles and Formatting adds the space *inside* the guidance boxes. What is needed is to remove the space between the boxes (boxes/objects/text/paragraphs - I'm not sure of the OOo terminology). Any further ideas?

Martin
OOo 3.0.X on Ubuntu 8.x
MartinEve
 
Posts: 10
Joined: Sat Mar 14, 2009 7:10 pm

Re: Spacing between footnotes

Postby RoryOF » Sun Mar 15, 2009 3:25 pm

Select Paragraph style, Footnotes. Then right click and select Modify, adjust indents and spacing above and below paragraph as you wish it (probably to 0.0). Note that it is the Footnote syle you need to modify, under Paragraph styles, not the default paragraph style.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29440
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spacing between footnotes

Postby MartinEve » Sun Mar 15, 2009 3:28 pm

Hi,

I posted this before:

MartinEve wrote:Sadly I've already tried editing the styles. I have set the "Spacing" to 0.00cm both before and after on the paragraph "Footnote" and "footnote text", but neither seems to fix this problem.


Either I'm missing something, or I already tried what you are suggesting to no avail. Apologies if I've misunderstood...

Martin
OOo 3.0.X on Ubuntu 8.x
MartinEve
 
Posts: 10
Joined: Sat Mar 14, 2009 7:10 pm

Re: Spacing between footnotes

Postby RoryOF » Sun Mar 15, 2009 7:42 pm

I'm sorry - I had remembered your original posting, where the details of which style you had modified were vague, and missed your later posting where you specified "footnote style". I suspect that the problem does still lie in Paragraph/footnote style, but have nothing more specific to suggest.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29440
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spacing between footnotes

Postby acknak » Sun Mar 15, 2009 9:38 pm

Could someone please attach a small sample document that has this problem? You can use the "Upload Attachment" link (below the message entry area after you click "POST REPLY"). [Forum] How to attach a document here

Perhaps it can be fixed, but who knows what an imported document may contain. Using just OOo Writer, I cannot reproduce the spacing as shown in the screenshot. Changing "space above/below" in the Footnote style does not change the spacing between the frames, and there is no footnote frame style that I can find. I'm afraid that it may be an internal style that can't be modified through the user interface.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Spacing between footnotes

Postby MartinEve » Sun Mar 15, 2009 10:13 pm

Sure.

Please see the attached.

Thanks for the attention,

Martin
Attachments
Footnote Spacing.odt
Footnote spacing problem.
(16.81 KiB) Downloaded 481 times
OOo 3.0.X on Ubuntu 8.x
MartinEve
 
Posts: 10
Joined: Sat Mar 14, 2009 7:10 pm

Re: Spacing between footnotes

Postby acknak » Mon Mar 16, 2009 3:40 am

Sorry, I'm drawing a complete blank here: I can't find where the space is coming from or where to get rid of it.

I checked to see if the the problem has been reported, but nothing seems to match exactly.

Hopefully, someone else will have an idea, but if nothing comes up, then I'd suggest that you file a bug report and attach this document there as well. If nothing else, the developers may be able to give you some workaround.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Spacing between footnotes

Postby MartinEve » Mon Mar 16, 2009 8:29 am

Hi acknak,

Really appreciate your response. At least now I know that, as a newbie, I'm not just being stupid!

Best,

Martin
OOo 3.0.X on Ubuntu 8.x
MartinEve
 
Posts: 10
Joined: Sat Mar 14, 2009 7:10 pm

Re: Spacing between footnotes

Postby RoryOF » Mon Mar 16, 2009 10:18 am

I also cannot see any cause or cure.

To go back to an earlier point; you said that you got the same spacing with footnotes in a new document. That was not my experience: in a new document my footnotes were properly spaced (i.e., no gap). In your document new footnotes, whether with style Footnote (standard OO3.0.1 style) or Footnote Text (imported style from Office 2007?) maintained the incorrect spacing.

No setting I applied seemed to cause the inter-footnote spacing to change. Office 2007 is unknown to me - I ask is there an inter-footnote setting there, which you are not consciously using, that may be being incorrectly applied on import to OO? If the spacing can be caused to change then we at least have a clue as to what causes it. If the file is exported from Office 2007 in .rtf format, and imported in that format into OO, does the problem still persist?
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29440
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spacing between footnotes

Postby MartinEve » Mon Mar 16, 2009 10:25 am

Apologies, that was my mistake - in new documents it works fine, but in anything converted from Word 2007, it does not.

As far as I know there isn't an inter-footnote spacing setting in Word. It certainly isn't spaced like that in the original document!

Martin
OOo 3.0.X on Ubuntu 8.x
MartinEve
 
Posts: 10
Joined: Sat Mar 14, 2009 7:10 pm

Re: Spacing between footnotes

Postby RoryOF » Mon Mar 16, 2009 10:35 am

A posting has just been lost, so I repost.

If I export the "bad" document from OO 3.0.1 in .rtf format, and open this in OO, the footnotes are correctly spaced. I have not examined this new file for other formatting changes. I suggest you try exporting from Office 2007 in .rtf format, and see does the import of that into OO give a satisfactory result.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29440
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spacing between footnotes

Postby MacPhisto » Mon Mar 16, 2009 1:26 pm

I noticed that I could copy the whole contents of the document—including the footnotes—at once, then when I pasted them in a new document, the spacing was done correctly; it may be a helpful workaround, though not perfect. Mind you, there are also empty paragraphs at the end of the footnotes in your sample document, but removing these is trivial.
If your question has been answered, please add “[Solved]” to the beginning of the title of your first post (use the edit button.)
OOo 3.0.X on Ubuntu 9.x
User avatar
MacPhisto
 
Posts: 75
Joined: Tue Dec 09, 2008 11:05 am
Location: The Netherlands

Re: Spacing between footnotes

Postby MartinEve » Mon Mar 16, 2009 1:39 pm

Hiya,

Thanks for both your responses.

The empty paragraphs after each footnote are the direct result of the import process; in my tests I had removed them, but left them there so that the exact import was present.

Therefore, the copy and paste routine fixes the gaps between footnotes, but I'll still have to manually go through and remove these paragraphs.

On the RTF front, it does indeed appear to cure the footnote spacing, but the formatting ills that it introduces throughout seem to outweigh this.

I think I will file a bug report and, in the meantime, use the copy & paste workaround, removing my paragraphs.

Thanks for the suggestions,

Martin
OOo 3.0.X on Ubuntu 8.x
MartinEve
 
Posts: 10
Joined: Sat Mar 14, 2009 7:10 pm

Re: Spacing between footnotes

Postby RoryOF » Tue Mar 17, 2009 12:03 am

A last thought. Can you save to an earlier format from Office 2007? Say to Office 2003 or 2000? If one of those formats worked then the problem would be solved and we could all sleep easy in our beds!
Apache OpenOffice 4.1.6 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29440
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spacing between footnotes

Postby MartinEve » Wed Mar 18, 2009 11:21 am

Hiya,

Thanks for the reply: I'll give it a shot later and let you know.

Best,

Martin
OOo 3.0.X on Ubuntu 8.x
MartinEve
 
Posts: 10
Joined: Sat Mar 14, 2009 7:10 pm

Re: Spacing between footnotes

Postby AndrewZ » Sun Mar 22, 2009 4:35 pm

MartinEve wrote: It's only happening on Word 2007 docx files though, my new files are ok.


Does this help? It shows how to improve OOo 3.0's import capabilities.

Article: "A better [Word 2007] .docx importer"
<signature>
* Did you solve your problem? Do others a favor: Post the solution
* Visit OpenOffice.org Ninja (blog) and OpenOffice.org Ninja Wiki for news, previews, troubleshooting, etc.
</signature>
OOo 3.0.X on Fedora 9 + XP
User avatar
AndrewZ
Volunteer
 
Posts: 633
Joined: Mon Oct 08, 2007 1:25 am
Location: Colorado, USA

Re: Spacing between footnotes

Postby Fundi » Mon Mar 23, 2009 12:56 am

If you change the style and it has no parent effect it could be that the footnote is actually formatted on character level which will take precedence over the paragraph style. You can get rid of all formatting and only have the paragraph formatting when you select the entire footnote and then press Ctrl-m (in OOo v 3) or Ctrl-Shift-Space (in Ooo v 2.4). This option is also available from the menu under Formatting and is called Default formatting.

Hope this helps.

Fundi
Fundi
 
Posts: 22
Joined: Mon Jan 28, 2008 1:44 am

Re: Spacing between footnotes

Postby Fundi » Mon Mar 23, 2009 12:57 am

If you change the style and it has no parent effect it could be that the footnote is actually formatted on character level which will take precedence over the paragraph style. You can get rid of all formatting and only have the paragraph formatting when you select the entire footnote and then press Ctrl-m (in OOo v 3) or Ctrl-Shift-Space (in Ooo v 2.4). This option is also available from the menu under Formatting and is called Default formatting.

Hope this helps.

Fundi
Fundi
 
Posts: 22
Joined: Mon Jan 28, 2008 1:44 am

Re: Spacing between footnotes

Postby Nlok » Tue May 05, 2009 12:09 pm

Hi,

Had the same problem. Very frustrating.

But i seemed to have solved it by accident. I did all the changing of the footnoting spacing as is written above, but it still had a space between each footnote. I then created a new odt document, pasted from the old coverted into that one and then clicked down into the footnotes. When i did that, i noticed that i could now click between the footnotes to delete the space.

Not sure why it worked, not sure if it's repeatable, but give it a shot if you're frustrated, mighty be lucky like me...

Nick (Nlok)
OOo 3.0.X on MS Windows Vista
Nlok
 
Posts: 4
Joined: Tue May 05, 2009 12:04 pm

Re: Spacing between footnotes

Postby FrancescoQ » Sun Jun 08, 2014 12:08 pm

Hi, sorry to bring up this old thread, but i've not found elsewhere a possible answer.. maybe this is not resolvable?
I've a .docx file from MS Word 2013, and i'm working with OO4.1.0 in Linux Mint 17 (Qiana), the problem is exactly the same described above... is there any news with this?

Copying and pasting entire document in a new one seems working, but i loose all the page settings (margins, and other things.. ) so if there's a more correct way to resolve this problem would be nice!

Thank you!
Francesco.
OpenOffice4.1.0 on Linux Mint 17 Qiana
FrancescoQ
 
Posts: 1
Joined: Sun Jun 08, 2014 11:57 am


Return to Writer

Who is online

Users browsing this forum: No registered users and 43 guests