Open odt from LO in AO

Discuss the word processor

Open odt from LO in AO

Postby tays01s » Mon Mar 20, 2017 4:00 pm

Because of LO's memory leak and poor quality figures when inserting images/ pictures I wanted to pull my odt into AO. However, quite a lot of text changes font, actual cross-refs and page numbers are shown as 'place holders' and some drawings are completely messed up.

Is there a systematic way to make the file cross-compatible?
LO 4.2.2.1 on OSX 10.8.5
tays01s
 
Posts: 418
Joined: Thu Oct 28, 2010 7:57 am

Re: Open odt from LO in AO

Postby RoryOF » Mon Mar 20, 2017 4:06 pm

"Pull your odt into AO"? Did you start AOO and /File /Open? Is this the same computer, using the same fonts and paths?
Apache OpenOffice 4.1.4 on Xubuntu 16.04.03 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 25518
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Open odt from LO in AO

Postby Zizi64 » Mon Mar 20, 2017 4:41 pm

Can you upload an example .odt file (with the problematic embedded objects) here?
Tibor Kovacs, Hungary; LO4.4.7, LO5.3.7 on Win7x64Prof.
PortableApps, WinPenPack: LO3.3.0-LO5.4.3 and AOO4.1.4
Please, edit the topic's initial post, and add the word "[Solved]" at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 6082
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Open odt from LO in AO

Postby tays01s » Mon Mar 20, 2017 5:01 pm

File: Originally developed in LO version 4.x. I'm using same computer/fonts (paths? Not sure what this refers to)

I'll copy a portion of the file if it's not easy to figure out without it (quite a bit is confidential).
LO 4.2.2.1 on OSX 10.8.5
tays01s
 
Posts: 418
Joined: Thu Oct 28, 2010 7:57 am

Re: Open odt from LO in AO

Postby Zizi64 » Mon Mar 20, 2017 8:24 pm

(paths? Not sure what this refers to)

Related to the he linked (but not embedded) objects.
Tibor Kovacs, Hungary; LO4.4.7, LO5.3.7 on Win7x64Prof.
PortableApps, WinPenPack: LO3.3.0-LO5.4.3 and AOO4.1.4
Please, edit the topic's initial post, and add the word "[Solved]" at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 6082
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Open odt from LO in AO

Postby Villeroy » Mon Mar 20, 2017 9:54 pm

If you want any help on this, we have to actually see some odt document that behaves differently under AOO and LO
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 16.04, OpenOffice 4.x & LibreOffice 5.x
User avatar
Villeroy
Volunteer
 
Posts: 24659
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Open odt from LO in AO

Postby tays01s » Tue Mar 21, 2017 4:53 pm

Here's part of the file showing:
1. Ariel font changed to something odd.
2. A drawing pushed out of synch.
3. Cross references are odd instead of being full context.
Attachments
Eg LO to AO.odt
(51.77 KiB) Downloaded 36 times
LO 4.2.2.1 on OSX 10.8.5
tays01s
 
Posts: 418
Joined: Thu Oct 28, 2010 7:57 am

Re: Open odt from LO in AO

Postby Zizi64 » Tue Mar 21, 2017 5:38 pm

Ariel font changed to something odd.

See the used/missing fonts in your document.
I tested it with the extension "TestFonts":
http://extensions.openoffice.org/en/project/testfonts

Your document looks like as you can see in the attachment - when I opened it with my LO 4.4.7

Missing fonts.png
Tibor Kovacs, Hungary; LO4.4.7, LO5.3.7 on Win7x64Prof.
PortableApps, WinPenPack: LO3.3.0-LO5.4.3 and AOO4.1.4
Please, edit the topic's initial post, and add the word "[Solved]" at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 6082
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Open odt from LO in AO

Postby tays01s » Tue Mar 21, 2017 6:59 pm

How do I fix it?
LO 4.2.2.1 on OSX 10.8.5
tays01s
 
Posts: 418
Joined: Thu Oct 28, 2010 7:57 am

Re: Open odt from LO in AO

Postby Zizi64 » Tue Mar 21, 2017 7:27 pm

How do I fix it?

Test your installed/missing fonts on your computer by the TestFont extension, and then
Change the missing fonts that are you using in your document to existing (installed) ones. (Modify the propeties of the Styles and never use direct formattings.)
Tibor Kovacs, Hungary; LO4.4.7, LO5.3.7 on Win7x64Prof.
PortableApps, WinPenPack: LO3.3.0-LO5.4.3 and AOO4.1.4
Please, edit the topic's initial post, and add the word "[Solved]" at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 6082
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: Open odt from LO in AO

Postby John_Ha » Wed Mar 22, 2017 10:23 pm

The font showing in the Writer font drop down selection box is the font the document is asking for - it is NOT necessarily the font being used to create the display. This is because if the font being asked for is not installed on the PC, Windows (or other operating system) will silently substitute a different font which is available.

The TestFonts add-on is invaluable for finding missing fonts which the document is asking for, but which are not installed on the PC. You can see which fonts are installed on the PC by Start > Control Panel > Fonts or by clicking C:\Windows\Fonts.
AOO 4.1.4, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the up to date Writer guide for information. Click the Help button on a pop-up window for extensive help on that function.
John_Ha
Volunteer
 
Posts: 4664
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK


Return to Writer

Who is online

Users browsing this forum: No registered users and 26 guests