[Solved] Can't add records to new table.

Creating tables and queries

[Solved] Can't add records to new table.

Postby fmsmith » Fri Jan 15, 2010 10:07 pm

I made a new table and try to go back and add records, and the add record button is not 'on'.

I made a new table with 7 fields. I made an index.

I save the table. I go back and open the table and it won't let me add records.

Obviously it is a new, empty table.

Is there a switch that allows new records? Whats up?

Thanks much for any replies.

Frank


ps - I am using HSQL database engine - what came with OO
Last edited by TheGurkha on Fri Jan 15, 2010 11:19 pm, edited 2 times in total.
Reason: tagged [Solved]
Frank Smith
Open Office 3.1.1
Windows Vista
fmsmith
 
Posts: 3
Joined: Fri Jan 15, 2010 9:56 pm

Re: Cant add records to new table.

Postby Villeroy » Fri Jan 15, 2010 10:21 pm

Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 25952
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Cant add records to new table.

Postby fmsmith » Fri Jan 15, 2010 10:29 pm

Thanks for the reply.

I read that and I understand about the read-only on the form itself.

My problem is that it won't let me add a record to the table, either on the table directly, or with the form.

The add record buttons are grayed out.

Sorry if I didn't see the answer there, but I didn't.

Frank
Frank Smith
Open Office 3.1.1
Windows Vista
fmsmith
 
Posts: 3
Joined: Fri Jan 15, 2010 9:56 pm

Re: Cant add records to new table.

Postby Villeroy » Fri Jan 15, 2010 10:42 pm

myself wrote:2. The existence of a primary key.

I added 2 more screen shots regarding the primary key.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 25952
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [solved] Cant add records to new table.

Postby fmsmith » Fri Jan 15, 2010 10:49 pm

That was it.

Thank you, thank you, thank you.

I was defining indexes, but not a primary key. Now I understand.
Frank Smith
Open Office 3.1.1
Windows Vista
fmsmith
 
Posts: 3
Joined: Fri Jan 15, 2010 9:56 pm

Re: Cant add records to new table.

Postby Villeroy » Fri Jan 15, 2010 10:56 pm

Additional indices can be very useful. The primary key is the one which is actually used to "put a finger" on a distinct record for editing.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 18.04, OpenOffice 4.x & LibreOffice 6.x
User avatar
Villeroy
Volunteer
 
Posts: 25952
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: [Solved] Can't add records to new table.

Postby darthvader45 » Sun Aug 25, 2013 6:09 pm

I actually created a new table and even set a primary key. Not only that, but the Access Database file that I connected to was not read-only. Yet I still cannot add records. Why is this?
OpenOffice 4.0.0 installed on Windows Vista Home Basic x86
darthvader45
 
Posts: 1
Joined: Sun Aug 25, 2013 5:59 pm

Can't add records to tables

Postby mathias_ubik » Fri Feb 26, 2016 10:17 pm

I have created a database by connection to an existant MS-Access 2013 database.
The data of the tables is visble, however can not be modified.
So I created a new table in OO (with primary key :D )
Can not add records neither.
This new table is visible in MS-Access, where I can add & modify records.
OO objects:
I can create select queries but no forms.
My OO base seems in "half" read-only mode.

Any help would be appreciated.
OpenOffice 4.1.2 on Windows 7
mathias_ubik
 
Posts: 3
Joined: Fri Feb 26, 2016 10:08 pm


Return to Tables & Queries

Who is online

Users browsing this forum: No registered users and 6 guests