Page 1 of 1

Won't respond

PostPosted: Fri Sep 13, 2019 2:40 am
by knightbloomingsirius
Hi there,
I have been having trouble for the past month or so with Open Office. I had installed it sometime last year and a couple of weeks ago opened it and it suddenly would not work. I simply got "not responding" and my mouse said "thinking" and then I would be forced to end the task. I cannot even open a file to read on it. I uninstalled it and reinstalled the most recent version a day or two ago and it's still not working - it has the exact same response as before. The minute I open it, it just starts freezing, mouse goes to thinking, and I am forced to end the task, even after waiting for several minutes.

I have a Lenovo YOGA laptop that's pretty new; I bought it last year and it's a recent model (don't remember exactly which, but it's bronze).

Please help.

Re: Won't respond

PostPosted: Fri Sep 13, 2019 3:15 am
by FJCC
You probably need to reset your user profile. Open any folder and in the address bar near the top enter
%appdata%\openoffice\4
That will take you to a folder containing a folder called user. Rename that to user_old. Restart OpenOffice and you should get the registration screen. Is OpenOffice stable now?

Re: Won't respond

PostPosted: Fri Sep 13, 2019 3:27 am
by knightbloomingsirius
Unfortunately, no. I did exactly as you said; it still will not work. It did let me create a new user profile, but then it resorted to the exact same behaviour as before.

Re: Won't respond

PostPosted: Fri Sep 13, 2019 4:40 am
by RusselB
Since OpenOffice didn't stablize, try restarting your system in Safe Mode and try OpenOffice again.
If OpenOffice responds properly, then there is something that is loaded in a standard boot configuration that is affecting how OpenOffice is running.
If this is the case, my first suggestion is to read the Tutorial regarding Windows Defender under Windows 10. I'd give the link, but don't have the ability to look it up while on this page at this point in time.

Re: Won't respond

PostPosted: Fri Sep 13, 2019 1:16 pm
by RoryOF
Sometimes, a hanging OpenOffice can be caused by a left over OO process, left over after a program or computer crash. Using TaskManager (Ctrl shift Esc) will show running processes. Kill any soffice processes shown on TM's tabs, and try OO again. Note the initial "s" in soffice.

A computer restart may clear such left over processes, but I prefer the certainty of doing it the way I outlined, as it informs one of what the cause was, whereas if the restart worked, one knows the problem is cured, but not why.

Re: Won't respond

PostPosted: Sat Sep 14, 2019 6:20 pm
by neiljacobson
I've been having the same problem for several days. i've rebooted. I've deleted my user profile. I've checked for soffice processes. I've scanned with Malwarebytes.
What should I do?

Re: Won't respond

PostPosted: Sat Sep 14, 2019 6:29 pm
by RoryOF
In TaskManager, there is a setting to "Check for processes from all users" (words to that effect). If you didn't select this you may have missed some soffice processes.

If that fails, try a reinstall.

Re: Won't respond

PostPosted: Sat Sep 14, 2019 6:48 pm
by neiljacobson
I just checked and confirmed that I am the only user

Re: Won't respond

PostPosted: Sat Sep 14, 2019 11:51 pm
by RusselB
If your system shows you are the only user after enabling the option mentioned by Rory, then you have a problem with your system, since enabling that would also show System as a user, meaning tasks being run by the Windows operating system

Re: Won't respond

PostPosted: Sun Sep 15, 2019 12:10 am
by neiljacobson
There are many processes being run by the System, but I am the only user, see https://www.dropbox.com/s/yh6wgn6nrw9dila/Screenshot%202019-09-14%2014.57.49.png?dl=0

Re: Won't respond

PostPosted: Sun Sep 15, 2019 2:51 am
by RusselB
Your picture shows the tasks sorted by CPU usage. Resort by Task Name to make finding the soffice tasks easier.

Re: Won't respond

PostPosted: Sun Sep 15, 2019 3:36 am
by neiljacobson

Re: Won't respond

PostPosted: Sun Sep 15, 2019 3:54 am
by RusselB
Have you tried my earlier suggestion of trying OpenOffice after starting your system in safe mode?

Re: Won't respond

PostPosted: Sun Sep 15, 2019 4:16 am
by neiljacobson
does mousekeys work in safe mode? With my disability, I cannot use a mouse