[Solved] Spelling and grammar check

Discuss setup / installation issues - Add a spell checker, Language pack?

[Solved] Spelling and grammar check

Postby KeithLawson » Fri Jun 07, 2019 10:58 am

Reopened a text file and every single word is underlined in red. Nothing wrong with my spelling or grammar. Damned annoying to have all that red ink across my screen as well as losing the ability to properly run a check.
Open Office 4.1.5 Previous problem was crashing (which it still does).
Last edited by Hagar Delest on Fri Jun 07, 2019 9:28 pm, edited 1 time in total.
Reason: tagged solved
Open Office 4.1.5 on Windows 10
KeithLawson
 
Posts: 12
Joined: Fri Aug 24, 2018 5:37 pm

Re: Spelling and grammar check

Postby RoryOF » Fri Jun 07, 2019 11:02 am

The loss of spellcheck may be related to a crash of OpenOffice, which can cause the OO User Profile to be improperly (or not at all) written.

Start by renaming your existing OpenOffice user profile.

As you are using Windows close OpenOffice and the Quickstarter. Open File Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer (sometimes called Windows Explorer) Address Bar and press Enter. Rename the "user" folder - "user.old" is a good choice. Start OpenOffice.

This cures most spellcheck problems.
Apache OpenOffice 4.1.7 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31451
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spelling and grammar check

Postby KeithLawson » Fri Jun 07, 2019 11:19 am

Thanks. I'll give it a try (but I am not very technical). I'll confirm if successful
Open Office 4.1.5 on Windows 10
KeithLawson
 
Posts: 12
Joined: Fri Aug 24, 2018 5:37 pm

Re: Spelling and grammar check

Postby KeithLawson » Fri Jun 07, 2019 11:50 am

I'm failing. I can't find where my OO user profile is. And pasting the link into the message bar just comes up with Google responses.
So I uninstalled 4.1.5 and installed 4.1.6 but still have the problem.
Open Office 4.1.5 on Windows 10
KeithLawson
 
Posts: 12
Joined: Fri Aug 24, 2018 5:37 pm

Re: Spelling and grammar check

Postby robleyd » Fri Jun 07, 2019 12:00 pm

It may be that you are either entering the string in a web browser, or are using the search bar in Windows Explorer rather than the address bar.

This post of mine in another topic has some images which may help you; although they are from Windows 7 rather than Windows 10 you should get the idea.
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3467
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Spelling and grammar check

Postby KeithLawson » Fri Jun 07, 2019 12:07 pm

WAIT. I think I've cracked it. I was pasting the link in the wrong place, because I misunderstood Windows Explorer. Did it in File Explorer and followed Rory's instructions and opened my doc without red underlining.
I just find that the more MS update Windows the less I understand how the system work!
THANKS. So speedy.
Open Office 4.1.5 on Windows 10
KeithLawson
 
Posts: 12
Joined: Fri Aug 24, 2018 5:37 pm

Re: Spelling and grammar check

Postby robleyd » Fri Jun 07, 2019 12:12 pm

I wish bloody Windows would be consistent between versions in naming their gods damned file manager!! In Windows 3 it was actually called File Manager. Now it seems to vary between Windows Explorer and File Explorer and probably something else I haven't seen yet. <Sigh>
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3467
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 6 guests