OpenOffice is not responding (again)

Discuss setup / installation issues - Add a spell checker, Language pack?

OpenOffice is not responding (again)

Postby Veggie » Mon Mar 25, 2019 3:39 am

First of all sorry for my noobish entrance in this forum.
Prior to this cry for help here i did research online and tried various suggestions to similar problems all to no avail.

I have been using OpenOffice 4.1.6 for little over a half year now and at first it was working perfectly and i had no issues or complaint.
I am using Calc and Writer only. for some administration and text editing.

Since a few weeks ago and without having installed or changed anything about my setup or adding other software (excluding maybe some forced Windows Updates) my OpenOffice seemingly out of the blue starts becoming unresponsive after opening any of my spreadsheet or text documents.
There are 2 variants of this unresponsive hang, either:

-Calc or Writer tries to open a file, but becomes unresponsive showing a grey screen.
-Calc or Writer opens a file, and becomes unresponsive right after opening it, showing the contents.

This can happen with ANY file, being a big spreadsheet, a simple 1 page text or even by rightclicking and creating a new spreadsheet or text document and opening that.

When it happens, a .lock file of the opened document remains in the folder and the ONLY solution i have found working so far is:

-DELETE all .lock files
-DELETE the OpenOffice folders in %appdata%
-UNINSTALL OpenOffice
-REBOOT
-INSTALL OpenOffice

It seems to hang on irregular intervals, while some times it will work for days, and other times it fails on me daily.
Just yesterday i booted my PC and did some editing in Adobe Photoshop (i mention this not knowing if it's related to the issue, i've read somewhere that the clipboard might be causing this but the problem also occurs after booting and opening OpenOffice right away), then i wanted to edit a text document and i got a grey screen.

So i followed my above steps and got all working again, edited my textfile, saved it and besides some internet browsing turned off my PC at a later time.
Then today, i booted up my PC, when to my folder that stores my spreadsheet files, doubleclicked on one which loaded, but Calc became unresponsive right away.(and i came here and signed up posting this post)

I also have this issue appear when opening OpenOffice and then selecting Writer or Calc from the menu.

Having to delete, uninstall reboot and reinstall on so many occasions is becoming a major pain and none of the suggestions i found online worked.
(as a side not, while trying to kill OpenOffice in Taskmanager many times i have never encountered a process called "soffice")

If someone can help me figure this out it would be greatly appreciated!

OpenOffice 4.1.6 / Windows 10Pro 64bit / 16GB Ram
Openoffice 4.1.6 on Windows 10 64bit
Veggie
 
Posts: 9
Joined: Mon Mar 25, 2019 3:11 am

Re: OpenOffice is not responding (again)

Postby Zizi64 » Mon Mar 25, 2019 7:47 am

Try some portable versions of the OpenOffice and the LibreOffice to determine if the problem is located in the office software or in the PC hardware/op. sys/drivers/settings.

Many versions of the AOO and LO (permanently installed and portable ones) worked, and work now in my Windows 7 prof 64 bit without any problem. (I am using the 32 bit versions of the LibreOffice.)
The permanently installed LibreOffice 4.4.7, and the portable versions work now on my Win10 prof 64 bit op sys. without any problem.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9409
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: OpenOffice is not responding (again)

Postby RoryOF » Mon Mar 25, 2019 9:34 am

Very probably there are left over OpenOfice components. Start TaskManager (Ctrl Shift Esc) and killl all soffice components shoem on TM's tabs. . Note the initial "s" in soffice! Now exit TM, and try starting OpenOffice again.

Such "left over" processes can stop OpenOffice starting correctly. They can be left because of a program or system crash, or sometimes because of over-hasty power off of the computer before internal housekeeping has been written to disk. When shutting down your computer, wait until hard disk has spun down before cutting the power or closing laptop lid.

If this problem is occurring only with one or two specific files, it would be helpful to have hands-on of such files so that their structure might be inspected.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31209
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: OpenOffice is not responding (again)

Postby Veggie » Mon Mar 25, 2019 10:44 am

Zizi64 wrote:Try some portable versions of the OpenOffice and the LibreOffice to determine if the problem is located in the office software or in the PC hardware/op. sys/drivers/settings.

Many versions of the AOO and LO (permanently installed and portable ones) worked, and work now in my Windows 7 prof 64 bit without any problem. (I am using the 32 bit versions of the LibreOffice.)
The permanently installed LibreOffice 4.4.7, and the portable versions work now on my Win10 prof 64 bit op sys. without any problem.


Actually a while ago i tried LibreOffice and encountered the same issue.
I didn't realize there are portable versions, i will look into those thanks.

I'm pretty sure it's not AOO or LO though and most likely something Windows related.

I often copy the exact same files to a more than 15 year old, designed-for-xp, at the time budget model, Compaq laptop that i brought back from the dead using Lubuntu and i never have any issues opening my files on this anchient and now Linux driven machine.
Openoffice 4.1.6 on Windows 10 64bit
Veggie
 
Posts: 9
Joined: Mon Mar 25, 2019 3:11 am

Re: OpenOffice is not responding (again)

Postby Veggie » Mon Mar 25, 2019 10:58 am

RoryOF wrote:Very probably there are left over OpenOfice components. Start TaskManager (Ctrl Shift Esc) and killl all soffice components shoem on TM's tabs. . Note the initial "s" in soffice! Now exit TM, and try starting OpenOffice again.

Such "left over" processes can stop OpenOffice starting correctly. They can be left because of a program or system crash, or sometimes because of over-hasty power off of the computer before internal housekeeping has been written to disk. When shutting down your computer, wait until hard disk has spun down before cutting the power or closing laptop lid.

If this problem is occurring only with one or two specific files, it would be helpful to have hands-on of such files so that their structure might be inspected.


I'm 100% sure i close my programs correctly, save, then close, always shutdown my PC, did not experience crashes or power outages causing instant poweroffs or anything (using UPS too).

Even AOO is not crashing if it works.
If i "fix" the issue and make sure not to close any document, then i can keep opening and editing documents all day long.
As soon as i close ALL documents, (by save and close) the problem can and often will occur right after i try to open AOO again.
I have even checked TM if there were any processes running AFTER closing and BEFORE reopening AOO.

I have checked taskmanager processes all too often, but never found anything "soffice" unless i'm going blind
I just checked, and AGAIN after doing my administration just fine, now a few hours later (PC has only be streaming radio) AOO is unresponsive and so useless untill i reinstall (or find another solution)

Taskmanager has ONLY the process "OpenOffice 4.1.6(32bit)" for me to kill, and also on the services tab i cannot find anything named "soffice" or alike.

The problem is upon opening AOO, be it through AOO , opening ANY existing file and/or opening a NEW empty file.

In reply to your solution: Closing by killing ALL i can find related to AOO in TM and restarting the program does not work. Any combinations of such steps do not work.

The ONLY way to get stuff working again is by steps posted in my first post.

Thanks though
Openoffice 4.1.6 on Windows 10 64bit
Veggie
 
Posts: 9
Joined: Mon Mar 25, 2019 3:11 am

Re: OpenOffice is not responding (again)

Postby RoryOF » Mon Mar 25, 2019 11:34 am

Not using Windows to any extent - and then only a very old copy of Windows XP - I am not familiar with the current Windows version. It has been reported that Windows Defender causes many problems with OpenOffice until correctly adjusted; I cannot help with suggestions as to what adjustment you should make to its settings, but perhaps some Windows user will oblige.

You mention using lubuntu with success on an old machine: I use Xubuntu 18.04.2 on all my computers - this, my usual machine, is now ten years old and gives no trouble. If one can find suitable substitutes for one's usual programs then a move to linux could keep an older machine working well.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.4 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31209
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: OpenOffice is not responding (again)

Postby John_Ha » Mon Mar 25, 2019 12:00 pm

starts becoming unresponsive after opening any of my spreadsheet or text documents

Download these two files to your desktop then do the following:

1. Start AOO
2. File > Open ..., and navigate to each file
3. Do a small edit in each file.
4. File > Save ..., and save each file.

Did that all work OK?

Now do a separate test

1. Close AOO
2. Double-click on test.odt.

Does it open?

3. Double-click on test.ods.

Does it open?
Attachments
test.odt
(11.79 KiB) Downloaded 32 times
test.ods
(14.56 KiB) Downloaded 28 times
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7760
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: OpenOffice is not responding (again)

Postby Veggie » Mon Mar 25, 2019 12:22 pm

John_Ha wrote:
starts becoming unresponsive after opening any of my spreadsheet or text documents

Download these two files to your desktop then do the following:

1. Start AOO
2. File > Open ..., and navigate to each file
3. Do a small edit in each file.
4. File > Save ..., and save each file.

Did that all work OK?


Both files open but immediately AOO becomes unresponsive.
I can see the contents, i can just not scroll, edit, save etc etc and Windows notifies the program being unresponsive and asks me to force close

Now do a separate test

1. Close AOO
2. Double-click on test.odt.

Does it open?

3. Double-click on test.ods.

Does it open?

[/quote]

Same results as above.

But after full delete, reboot and reinstall (as expected) both files can be opened, edited, saved etc etc untill the next time AOO decides to die on me
Meanwhile i did try out the portable version too, sadly it does not help the problem.

Something somewhere goes wrong and just permanently breaks my AOO, it seems to happen more often/quicker now too having to do the whole reinstall cycle just about every time i want start a new session using AOO.
Openoffice 4.1.6 on Windows 10 64bit
Veggie
 
Posts: 9
Joined: Mon Mar 25, 2019 3:11 am

Re: OpenOffice is not responding (again)

Postby John_Ha » Mon Mar 25, 2019 12:53 pm

It may not look like it but we are moving forwards. :super:

1. It does not look like it is Windows Defender but check in any case - make sure C:\Program Files (x86)\OpenOffice 4\program\soffice.bin has write privileges in Windows Defender. Google for information on Windows Defender.

2.
Both files open but immediately AOO becomes unresponsive.
I can see the contents, i can just not scroll, edit, save etc etc and Windows notifies the program being unresponsive and asks me to force close

That is extremely strange and I have never seen it before. It suggests that AOO is in a loop doing lots of work but getting nowhere. It cannot be because of the files as they are so simple and they work fine on my PC so it must be AOO on your PC. Double-click C:\Windows\System32\taskmgr.exe to start TaskManager (put it as a shortcut on your desktop too - it is VERY useful). Click the Processes tab. Is AOO using a lot of CPU? Is Disk set to 100%? Also, when AOO is unresponsive, are other programs (your browser, Notepad etc) OK? or are they unresponsive too?

3. Try booting the PC in Safe Mode (Google for how). Is it now OK? If it is OK then it is one of the programs which starts when your PC starts causing the problem.

If that does not fix it then do a complete uninstall where you delete the profile, and do a complete reinstall.

1. Stop AOO
2. Settings > Programs (or whatever in W10). Find AOO. Uninstall it.
3. Go to C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user and rename ...\user to ...\user.OLD. You may need to set Show Hidden Files to ON to see the folder. This deletes the User Profile by renaming it.
4. Go to http://www.openoffice.org/download/index.html and download AOO.
5. Install AOO. You will be asked for your name and initials. If you are not asked it is because you did not do Step 3!!!
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7760
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: OpenOffice is not responding (again)

Postby Veggie » Mon Mar 25, 2019 1:33 pm

John_Ha wrote:It may not look like it but we are moving forwards. :super:

1. It does not look like it is Windows Defender but check in any case - make sure C:\Program Files (x86)\OpenOffice 4\program\soffice.bin has write privileges in Windows Defender. Google for information on Windows Defender.

I'm not quite sure what you mean here, googling "write privileges windows 10 defender" ends me in searchresults about "controlled folder access/ransomware protection"
Clicking through Windows Defender i can not find anything to see or set privileges.
However by default i have Windows Defender off because its a pain and i'm using Malwarebytes for antivirus and online security

2.
Both files open but immediately AOO becomes unresponsive.
I can see the contents, i can just not scroll, edit, save etc etc and Windows notifies the program being unresponsive and asks me to force close

That is extremely strange and I have never seen it before. It suggests that AOO is in a loop doing lots of work but getting nowhere. It cannot be because of the files as they are so simple and they work fine on my PC so it must be AOO on your PC. Double-click C:\Windows\System32\taskmgr.exe to start TaskManager (put it as a shortcut on your desktop too - it is VERY useful). Click the Processes tab. Is AOO using a lot of CPU? Is Disk set to 100%? Also, when AOO is unresponsive, are other programs (your browser, Notepad etc) OK? or are they unresponsive too?


Yes this issue is strange, and no. other than AOO my PC stays fully functional and performing as should having no single issue whatsoever running anything else. Windows asks to force close AOO, which it does perfectly (no traces in Taskmanager) and if i want to use AOO again i must delete, uninstall, reboot, install and it will work at least once and untill i close ALL the files i opened that session.

I'm not the type that signs up and asks for help quickly, but i tried many online suggestions plus common knowledge and still am stumped.
I came here hoping anyone would point out a silly but known cause.

3. Try booting the PC in Safe Mode (Google for how). Is it now OK? If it is OK then it is one of the programs which starts when your PC starts causing the problem.


Will try after posting this and get back here

If that does not fix it then do a complete uninstall where you delete the profile, and do a complete reinstall.

1. Stop AOO
2. Settings > Programs (or whatever in W10). Find AOO. Uninstall it.
3. Go to C:\Users\xxxxxx\AppData\Roaming\OpenOffice\4\user and rename ...\user to ...\user.OLD. You may need to set Show Hidden Files to ON to see the folder. This deletes the User Profile by renaming it.
4. Go to http://www.openoffice.org/download/index.html and download AOO.
5. Install AOO. You will be asked for your name and initials. If you are not asked it is because you did not do Step 3!!!


^ THIS works but ONLY if i include a reboot before installing again, just deleting, uninstalling and reinstalling does not work (i remain with a freshly installed but unresponsive-after-opening AOO)

Thanks so far for the efforts though :super:
Openoffice 4.1.6 on Windows 10 64bit
Veggie
 
Posts: 9
Joined: Mon Mar 25, 2019 3:11 am

Re: OpenOffice is not responding (again)

Postby Veggie » Mon Mar 25, 2019 1:44 pm

Ok weird...
I booted in Safe Mode and AOO worked
I booted back normal mode, and AOO still worked
Openoffice 4.1.6 on Windows 10 64bit
Veggie
 
Posts: 9
Joined: Mon Mar 25, 2019 3:11 am

Re: OpenOffice is not responding (again)

Postby John_Ha » Mon Mar 25, 2019 2:06 pm

Veggie wrote:Ok weird...

Yesterday it worked
Today it doesn't.
Windows is like that.


Veggie wrote:I booted in Safe Mode and AOO worked

So it is one of the programs which starts when the PC starts which is causing the problem.

Veggie wrote:I booted back normal mode, and AOO still worked

That suggests that you stopped a program from starting. Did you prevent a program starting? Was it Windows Defender?
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7760
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: OpenOffice is not responding (again)

Postby Veggie » Mon Mar 25, 2019 3:17 pm

John_Ha wrote:
Veggie wrote:Ok weird...

Yesterday it worked
Today it doesn't.
Windows is like that.



Don't get me started, my love/hate (mostly hate) relation with M$ goes a long way back...

Veggie wrote:I booted in Safe Mode and AOO worked

So it is one of the programs which starts when the PC starts which is causing the problem.

Veggie wrote:I booted back normal mode, and AOO still worked

That suggests that you stopped a program from starting. Did you prevent a program starting? Was it Windows Defender?


Still not sure, i didn't stop, start or change anything.(only rebooting and starting AOO in safe and later normal mode)
As for now it is still working, after last reboot again i have only been browsing a bit

Defender was, and is, still disabled so i doubt that's the culprit

It's the type of problem that when you encounter it you think to yourself "OK this must be a common and well known bug with some obvious easy solution", but i keep going in circles.

I will try to log my behavior some until it "breaks" again and maybe that will give a clue

Thanks for your patience, i will update if something changes
Openoffice 4.1.6 on Windows 10 64bit
Veggie
 
Posts: 9
Joined: Mon Mar 25, 2019 3:11 am

Re: OpenOffice is not responding (again)

Postby John_Ha » Mon Mar 25, 2019 3:37 pm

Veggie wrote:Defender was, and is, still disabled so i doubt that's the culprit

Defender is like one of those "you can't blow them out candles that light again" as the service just starts it again if it cannot see it running. See How to Enable or Disable Windows Security in Windows 1
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7760
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: OpenOffice is not responding (again)

Postby Veggie » Mon Mar 25, 2019 4:00 pm

John_Ha wrote:
Veggie wrote:Defender was, and is, still disabled so i doubt that's the culprit

Defender is like one of those "you can't blow them out candles that light again" as the service just starts it again if it cannot see it running. See How to Enable or Disable Windows Security in Windows 1


Yes i know that.
Windows doesn't like the user in control, if just deactivated it will decide screw you and turns it on after a while (same as automatic updates BTW)

The first thing i always do after installing Windows is run some tweaks to take out some bloat and take back some control.
Sadly there are a few things i still need Windows for so i guess soon i will setup a dualboot with a nice Linux distro
Openoffice 4.1.6 on Windows 10 64bit
Veggie
 
Posts: 9
Joined: Mon Mar 25, 2019 3:11 am

Re: OpenOffice is not responding (again)

Postby Veggie » Tue Mar 26, 2019 1:34 am

Before i turned off my PC last night i checked and AOO was working
Today first thing after booting i tried AOO (with one of the test files downloaded above) and it hanged unresponsive.

I guess i'll just give up on Windows for this.

Everyone thanks for trying to help!
Openoffice 4.1.6 on Windows 10 64bit
Veggie
 
Posts: 9
Joined: Mon Mar 25, 2019 3:11 am

Re: OpenOffice is not responding (again)

Postby Zizi64 » Tue Mar 26, 2019 8:38 am

Try the LibreOffice. I am using it on Win7 (prof), Win10 (prof) without any problem.
Tibor Kovacs, Hungary; LO6.1.6, 6.2.8 /Win7-10 x64Prof.
PortableApps/winPenPack: LO3.3.0-6.4.5;AOO4.1.7
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 9409
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: OpenOffice is not responding (again)

Postby John_Ha » Tue Mar 26, 2019 1:03 pm

Veggie wrote:Before i turned off my PC last night i checked and AOO was working
Today first thing after booting i tried AOO (with one of the test files downloaded above) and it hanged unresponsive.

See [Tutorial]Problems with Windows Defender under Windows 10.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7760
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 6 guests