Spellcheck works except with Writer docs created in folder

Discuss setup / installation issues - Add a spell checker, Language pack?

Spellcheck works except with Writer docs created in folder

Postby rubydragon44 » Thu Mar 21, 2019 11:01 pm

Spellcheck will work, but only if I load up the Writer application from the start menu. If I create a new Writer document in a folder and open it, spellcheck won't work.
I always use the Default template
I've already tried deleting my user profile and letting another one be created
I have autospellcheck selected
Hunspell SpellChecker, Libhyphen Hyphenator, and OpenOffice.org New Thesaurus are checked in File->Options->Language Settings->Writing Aids
I have the newest 32 bit Java
I applied the macro found here viewtopic.php?f=74&t=85529
I made sure to download and enable the English dictionary in Tools->Extension Manager
By going to the start menu, selecting settings, Time & Language, then Region & Language, my system language is English (United States) and my keyboard language is US QWERTY

Following these posts
viewtopic.php?t=16512
viewtopic.php?f=30&t=91386
It seems that when I create a new document by opening Writer from the start menu or by going to File->New->Text Document, the language is Default - English (USA) with an ABC checkmark to signify that I have a dictionary for that language.
But when I create a new text document within a folder, its language is German and that language doesn't have a checkmark beside it.

Yet despite switching the OpenOffice language to Default USA English, creating a new doc within a folder will always result in a German language. I can switch a German document to a USA one and the setting won't change back on me, but spellcheck still won't work for that document even upon closing it and opening it back up again.
But if create a document using any other method, it will be English automatically and will never have any issues with spellcheck.

If I right-click the German (or German-changed-to-English) document and go to Edit Paragraph Style->Font, there will be no language selected in the dropdown box. Selecting English - USA (which has the ABC checkmark) will cause the document to suddenly start spellchecking correctly.
I can change the default font language in Format->Styles & Formatting, right-clicking Default and selecting Modify, then changing the language to English (USA) in the dropdown menu of the Font category, but this setting will reset back to nothing being selected upon creating a new Writer doc in a folder which results the aformentioned German document.
So something is causing my OpenOffice Writer docs to always default in German with no font language regardless of the settings I change despite everything about my system being USA English, but only with a certain method of document creation.

The reason I bring this up when there are clearly instances where spellcheck does work for me is that it's handy to be able to create a document where it belongs rather than always having to navigate to the folder I want to save it in.
OpenOffice 4.1.5 ib Windows 10
rubydragon44
 
Posts: 1
Joined: Thu Mar 21, 2019 9:59 pm

Re: Spellcheck works except with Writer docs created in fold

Postby Bill » Fri Mar 22, 2019 12:10 am

Open a new document. Change the settings you want to use in the document. Select File > Templates > Save. On the Templates dialog, select "My Templates" in Categories. Type in the New template name. Click OK to close the Templates dialog. Select File > Templates > Organize to open the Templates Management dialog. If no templates are listed under My Templates, double-click My Templates. Select your template. Click Commands > Set as Default Template. Click Close. The default template should now be applied to any document you create in the folder.

This is the same problem discussed earlier today:
Default language not permanent
AOO 4.1.7, LO 6.3.6.2 and LO 6.4.3.2 on Kubuntu 20.04
Bill
Volunteer
 
Posts: 7806
Joined: Sat Nov 24, 2007 6:48 am

Re: Spellcheck works except with Writer docs created in fold

Postby floris v » Fri Mar 22, 2019 4:35 am

That looks a lot like a known error, when no language is assigned at all in files made with Windows Explorer. Right now the development of OpenOffice is as good as dead. Don't expect a fix for this bug for quite a while. Instead, start new documents in Writer instead of Winows Explorer and you'll be fine.
AOO 4.1.6 op Linux Mint
If your problem has been solved or your question has been answered, please edit the first post in this thread and add [Solved] to the title bar.
Nederlandstalig forum
User avatar
floris v
Moderator
 
Posts: 4203
Joined: Wed Nov 28, 2007 1:21 pm
Location: Netherlands

Re: Spellcheck works except with Writer docs created in fold

Postby Bill » Fri Mar 22, 2019 4:55 am

It's not an error. It's a consequence of the way Windows creates files and the lack of a true default template file in OpenOffice. Windows just creates a copy of a file that contains one particular language setting. MS Word is able to work around this problem out-of-the-box because Word has a global template which changes the language setting for the user. OpenOffice users must create and use their own default template if they want a different document language setting.
AOO 4.1.7, LO 6.3.6.2 and LO 6.4.3.2 on Kubuntu 20.04
Bill
Volunteer
 
Posts: 7806
Joined: Sat Nov 24, 2007 6:48 am

Re: Spellcheck works except with Writer docs created in fold

Postby John_Ha » Fri Mar 22, 2019 1:25 pm

See the tutorial about creating a new default template.

As a new poster you will find much useful information in the Writer FAQ, the Writer Tutorials, the up to date Writer guide and the Writer Manual. May I suggest you bookmark the pages.

Press F1 to access the Help screen and search for your problem

The chapter headings in the manual are:

1 - Introducing Writer
2 - Setting up Writer
3 - Working with Text
4 - Formatting Pages
5 - Printing, Exporting, Faxing and E-Mailing
6 - Introduction to Styles
7 - Working with Styles
8 - Working with Graphics
9 - Working with Tables
10 - Working with Templates
11 - Using Mail Merge
12 - Tables of Contents, Indexes and Bibliographies
13 - Working with Master Documents
14 - Working with Fields
15 - Using Forms in Writer
16 - Customizing Writer – Keyboard shortcuts.

When a pop-up window opens, click the Help button for extensive help on that function - it is often more comprehensive than the manual.
LO 6.4.4.2, Windows 10 Home 64 bit

See the Writer Guide, the Writer FAQ, the Writer Tutorials and Writer for students.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 7787
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Spellcheck works except with Writer docs created in fold

Postby Hagar Delest » Fri Mar 22, 2019 10:19 pm

Indeed, corner case 2 in bottom post Spell checking is not working, why? (the tutorial).

Please add [Solved] at the beginning of the title in your first post (top of the topic) with the *EDIT button if your issue has been fixed.
AOO 4.1.7 on Xubuntu 20.04 and 4.1.5 on Windows 10 (with winPenPack port).

Off line until 30-AUG-2020
User avatar
Hagar Delest
Moderator
 
Posts: 28920
Joined: Sun Oct 07, 2007 9:07 pm
Location: France


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 5 guests