[Solved] Spell check highlights correctly spelled words

Discuss setup / installation issues - Add a spell checker, Language pack?

[Solved] Spell check highlights correctly spelled words

Postby Desire » Wed Mar 06, 2019 1:27 pm

The spell checker was originally operating correctly, but since today when I opened a saved Open Office document... when I click on the spell checker button (ABC blue check arrow button), the spell checkers highlights in red obviously correctly spelled words like "the", "of", "a", "when", etc...etc...
I have checked that correct language is select (UK English) and have even tried changing to US English and South African English, but to no avail.

Then how can I add an English Thesaurus?

Can you please help?
Last edited by Hagar Delest on Wed Mar 06, 2019 2:54 pm, edited 1 time in total.
Reason: tagged solved
OpenOffice 3.1 on Windows 7
Desire
 
Posts: 2
Joined: Wed Mar 06, 2019 1:04 pm

Re: Spell check highlights obviously correctly spelled words

Postby robleyd » Wed Mar 06, 2019 1:39 pm

For the spell checking problem, please see [Solved] Spell Check Not Working (words red underlined) which is the first topic in this forum.
Cheers
David
Apache OpenOffice 420m2(Build:9821) - Slackware 14.2 - 64 bit
LibreOffice 6.4.6.2 (SlackBuild for 6.4.6 by Eric Hameleers) - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 3565
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: Spell check highlights obviously correctly spelled words

Postby RoryOF » Wed Mar 06, 2019 1:47 pm

Once you have the spell check working correctly, right click on a word, select "Synonyms" from the popuyp menu; at the end of its suggestions you will see a link to Thesaurus. Or /Tools /Language /Thesaurus (ctrl F7) will offer a suggestuion for the word currently under the cursor.

Also, see the Help file and look up "thesaurus" ; you may need to change some settings to allow the thesaurus and this finds the information.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31732
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Spell check highlights obviously correctly spelled words

Postby Desire » Wed Mar 06, 2019 2:02 pm

robleyd wrote:For the spell checking problem, please see [Solved] Spell Check Not Working (words red underlined) which is the first topic in this forum.

Thank you. Problem now easily fixed by renaming "user" file to "user.old" and then re-opening OpenOffice again and using Wizard set-up.

I had assumed because the Spell checker was operating that it was not relevant to the first topic in the thread.

Many thanx
OpenOffice 3.1 on Windows 7
Desire
 
Posts: 2
Joined: Wed Mar 06, 2019 1:04 pm

Re: Spell check highlights obviously correctly spelled words

Postby RoryOF » Wed Mar 06, 2019 2:18 pm

You have probably lost your spellchecker (and may do again) because of an OpenOffice or system crash, or because of over-hasty close down of the computer before all internal housekeeping was written to disk

To avoid this, always use the forml Shutdown procedure for your computer, then wait a few seconds for all disk activity to cease after the "OK to shiutdown message" or the dark screen before disconnecting from the power or closing the laptop lid.
Apache OpenOffice 4.1.8 on Xubuntu 20.04.1 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 31732
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 10 guests