Page 1 of 1

[Solved] Creating Macros Crashes OpenOffice

PostPosted: Thu Oct 11, 2018 6:55 pm
by Robitron
Okay, I don't know what happened but I was working in a file and had some macros created.

Windows updated and restarted, now everytime I open OO.o, everything loads fine until I try to get into the macros (whether in a new file or an existing one), OO.o crashes; recovers the file I was working on and crashes again. Wash, rinse, repeat.

I uninstalled OO.o and removed the folders from my appdata folder but then reinstalled to no avail. I can not use macros at all with OO.o now. Any idea what may be causing this and how to fix it?

Re: Creating Macros Crashes Open Office

PostPosted: Thu Oct 11, 2018 9:52 pm
by FJCC
This seems to be a problem with the Windows update. I had this problem after the update I got earlier this year (August?). I got updates yesterday, KB4462930 and KB4462919, and the problem seems to be gone. Please look at your update history and tell us which update were made last.

Re: Creating Macros Crashes Open Office

PostPosted: Thu Oct 11, 2018 10:40 pm
by Robitron
KB4100347, KB4462930 and KB4462919

Re: Creating Macros Crashes Open Office

PostPosted: Thu Oct 11, 2018 11:43 pm
by Robitron
Okay, I'm not sure what happened but I tried to do an OO.o update (which failed as it always does for me) so I went into settings, changed my internet proxy server from system to none. Then I tried the update again (which failed again) so I changed the proxy server back to system and now the macros seem to be working okay...

Not sure what the apple had to do with the orange but apparently, they were both needed for the fruit salad.

*I just checked the proxy server settings again and it set itself back to none. So I don't know what's going on but it seems to be working for the time being.