Page 1 of 1

Eliminate 'Recent Documents' completely?

PostPosted: Fri Aug 03, 2018 12:46 am
by ululator
Is there a way to remove the recently used file list so that it doesn't show up at all? Maybe an option to change the number of recent documents to zero, like you can in MS Office?

I turned off the 'Recent Documents' option in the File Menu, but that doesn't eliminate them. They still show up in the Standard Toolbar's Open command (in Writer & Calc)

Yes, I know the Toolbar's Open command includes the option of clearing the list... but what I want is to eliminate the 'Recent Documents' list permanently, so it doesn't show up in the first place. Any ideas?

Re: Eliminate 'Recent Documents' completely?

PostPosted: Fri Aug 03, 2018 12:54 am
by John_Ha
1. Record a macro clearing the list
2. Tools > Customise > Events. Assign the macro to Close application (or Document closed? or Document saved?)

Every time the chosen event happens the macro will be run.

Or, as I think you have tried, remove Recent documents from the File ..., menu by Customise > Menus.

If you save a file in folder ...\Fred, then when you go File > Open ..., AOO opens its browse window in the last used folder, namely ...\Fred. You may find that deleting your name from Tools > Options > OpenOffice > User data ...,will stop that happening. Alternatively, write a macro which first saves your file normally, then deletes the entire contents and saves the empty file with a dummy name in a standard folder you don't care about, and then clears the list. AOO will open its browser window at the standard folder.

See the manual for more information.

Be aware that hiding something as a form of security is notoriously weak and destined to failure - you need a password protected way of doing it.

Showing that a problem has been solved helps others searching so, if your problem is now solved, please view your first post in this thread and click the Edit button (top right in the post) and add [Solved] in front of the subject.

Re: Eliminate 'Recent Documents' completely?

PostPosted: Fri Aug 03, 2018 3:05 am
by robleyd
You could try installing the History Manager extension which seems to allow setting the number to zero.