Filter selector

Discuss setup / installation issues - Add a spell checker, Language pack?

Filter selector

Postby billhos1 » Tue Jul 24, 2018 7:37 pm

I have had open office for some time now. When I wanted to save a text document I would just click on save as and then I could go back into Open office and open it up no problem. But, I just reloaded Windows 10 o my computer and when I try to open the doc it brings up a "filter selector" and give me a lot of things to choose from to open it with. I have tried everything on it but nothing works. What do I do to get my documents back? If there is no other fix should I go back and get an earlier version of Open Office?
open office 4.1.5 windows 10
billhos1
 
Posts: 1
Joined: Tue Jul 24, 2018 7:11 pm

Re: filter selector

Postby RusselB » Tue Jul 24, 2018 7:53 pm

This problem has been reported many times, and the first recommendation is to use your system as little as possible
This has nothing to do with the installation of OpenOffice, but, rather, the content of your actual files.
Were you saving your files in open document format (.odt for Writer, .ods for Calc, etc.)?
Please read this tutorial
OpenOffice 4.1.6 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 5107
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: filter selector

Postby RoryOF » Tue Jul 24, 2018 8:30 pm

Is this problem on one document in particular, or on all OpenOffice documents?
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28988
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: filter selector

Postby John_Ha » Tue Jul 24, 2018 8:40 pm

If you open a genuine .odt file and you get the Ascii filter box it means the file is damaged beyond repair and there is no user content in it.

Your only hope is to see [Tutorial] How to find and un-delete Writer temporary files for

a) detailed instructions on how to recover your file as it was when you last opened or saved it, or as it was when it was last saved with AutoRecovery;

b) how to find previous versions of the file in the folder it is located in, but which have since been deleted;

c) how to un-delete the temporary files Writer wrote while you were editing the file, and then deleted. This will recover your file as it was when you last opened or you last saved it and is probably your best hope.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6632
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Filter selector

Postby crankywalrus » Fri Aug 03, 2018 11:42 pm

I have a slight variation on this problem.

At this point I'm mostly resigned to this file being gone but, what I want to know is *why*

1 and only 1 file has this problem. I recently (about a month back) transferred all my files from my old (and dying) computer to my new one. The file opened fine on the old computer AND on the new one, up until a week back. (My new computer has space to replace one of the chips with 4 gigs of RAM with a different chip so I did that to speed the new computer up. I thought I'd closed everything out beforehand but I'm assuming that that was what caused this one file to get corrupted.)

But what has me really baffled is this: Since I read forum after forum on here with people having the same problem, and it seemed clear the only/best bet was to just find a previous version that wasn't messed up, I used Recuva to recover the deleted prior-version of this file from off of the flash drive I'd used to transfer the files. Recuva had no problem finding it and said it hadn't been overwritten or anything.
The more up to date (gibberish) version of the file says it was Created Aug 31 2014, Modified July 29 2018 and Last Accessed July 15 2018.
Recuva got me a file that was Created Aug 31 2014, Modified July 2 2018, and Last Accessed July 15 2018... so it was last modified a month ago and was last accessed well before the corruption affected this file.
.... But when I try to open THIS file it is also having the ASCII filter box problem. When I used Recuva I saved it to a different place.

Why is the old version of the file (that I KNOW was safe before) now corrupted??
Running OpenOffice version 4.1.5 on Windows 10
crankywalrus
 
Posts: 1
Joined: Fri Aug 03, 2018 11:22 pm

Re: Filter selector

Postby RusselB » Sat Aug 04, 2018 2:27 am

Is it the file that you originally transferred from the old computer to the new one (and on the flash drive) that is returning corrupted or is it the file Recuva "recovered" that is coming back as corrupted?
They should be two different files, especially as the Recuva recovered file was stored in a different location (as stated by you)
If you still have the original file on the flash drive, see if it works directly from the flash drive... your system should assign a temporary drive letter to the flash drive when you plug it in, making it directly accessible from the system.

As to why the file on the flash drive might be corrupted, the most common reason is an over hasty removal of the drive from the system. Windows (or at least in Windows 7) has a sequence of file closures that it goes through when you dismount the flash drive using the icon that shows in my system window as Safely Remove Hardware and Eject Media. If you didn't allow that process to complete before removing the flash drive, then the last file written might get corrupted, and as it's on a flashdrive there's (usually) nothing for Recuva to recover, so it reports back the only file that it can find, namely the corrupted one on the flashdrive,
OpenOffice 4.1.6 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
User avatar
RusselB
Moderator
 
Posts: 5107
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: Filter selector

Postby John_Ha » Sat Aug 04, 2018 10:27 am

crankywalrus wrote:At this point I'm mostly resigned to this file being gone but, what I want to know is *why*

No-one knows why it occasionally happens but development are looking at possible reasons.

In the meantime the advice is:

1. AOO continues to write to disk long after the dotted blue bar crosses the screen. This can be several seconds on a PC and 30 or more seconds on a slow network disk. Do not shut down your PC during this time.

2. Do not close the laptop lid quickly after closing AOO.

3. IF you save to a USB memory stick be sure to eject it safely.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6632
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Filter selector

Postby RoryOF » Sat Aug 04, 2018 11:03 am

The file on the original computer may have been damaged in its last Save, and this damaged file copied forward to the new computer. If this was so, the best hope of recovery of the file is investigation on the old computer - there will be no possibility of recovery on the new.

Usually such damage to files is caused by abnormal program termination - sometimes a crash, sometimes overhasty power off before the internal housekeeping of OO is complete. It has been reported that it may be caused by direct working to USB sticks; whether this is due to some internal peculiarity of the USB stick file structure, the imminent failure of the USB stick (they can fail after a number of accesses, usually in the thousands) or to improper observance of the USB removal protocol has never been ascertained.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28988
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 3 guests