Page 1 of 1

[Solved] 4.1.4 Calc didn't work with .de version in Thailand

PostPosted: Fri Nov 24, 2017 5:05 am
by Joe59
Windows 7 with open office 4.1.4

My spreadsheats working well in 4.1.3 show this Err:509 now with the same old formulas. The explanations says: missing operator, but muliplication is still the asterix (*). So what's wrong? =B3*35 means multiply B3 by 35. Has something changed there?

Re: 4.1.4 Érr:509 with simple formula =B3*35

PostPosted: Fri Nov 24, 2017 6:09 am
by Joe59
Update: ALL formulas with all functions like =(b4:b6) or whatever show the same error code. Any calculation is not possible anymore. Moreover, formulas can't be copied anymore. Something is fundamentally wrong.

Re: 4.1.4 Calc does not calculate any more

PostPosted: Fri Nov 24, 2017 7:02 am
by RusselB
This problem has already been mentioned earlier.
I have no problems with the formula =B3*35 conditional that the entry in B3 is a valid number
In your second post, there is no function specified, thus Calc doesn't know what it's supposed to do with the range B4:B6

Since you also state that you can't copy any formulas, to my knowledge a new aspect of this problem or a different problem completely, at this point i'm going to recommend that you reset your Open Office user profile, as described in [Tutorial]The OpenOffice User Profile

Re: 4.1.4 Calc does not calculate any more

PostPosted: Fri Nov 24, 2017 7:10 am
by RoryOF
In a thread reporting a similar problem this post reported a solution:
https://forum.openoffice.org/en/forum/viewtopic.php?f=9&t=91111#p431372

Please try the attached file

Re: 4.1.4 Calc does not calculate any more

PostPosted: Fri Nov 24, 2017 10:21 am
by Joe59
Thanks for the suggestions! However, the thing mentioned in the other thread does not work here. I had already tried to make a new file and tried it again after reading this thread. To no avail. Also the sample file gives me the Err:509 as a result. The values are numbers, the formulas are correct. I have been using OpenOffice Calc for quite some years now. What could be the problem?

Re: 4.1.4 Calc does not calculate any more

PostPosted: Fri Nov 24, 2017 10:47 am
by Joe59
@RusselB =(b4:b6) is the formula for the sum of b4 to b6 and as I remember, should there be no number in one of these fields, the error message is different. The formula is created by the program itself when you press the sum-symbol left of the input field.

Re: 4.1.4 Calc does not calculate any more

PostPosted: Fri Nov 24, 2017 10:52 am
by RoryOF
If the sample file doesn't work, the problem is local to your computer. I suggest you rename your OO user profile.

As you are using Windows close OpenOffice and the Quickstarter. Open File
Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer (sometimes called Windows Explorer)
Address Bar and press Enter. Rename the "user" folder - "user.old" is a good choice. Start OpenOffice.

Re: 4.1.4 Calc does not calculate any more

PostPosted: Fri Nov 24, 2017 11:01 am
by Joe59
Hi Rory, thanks for the tip. However, it did not work. Same problem persists. I have a new "user" folder, as I can see plus the copies of the old ones. New file: Does not work, old file: Does not work, Sample file: nope.

Was "Apache_OpenOffice_4.1.4_Win_x86_install_de" the right file to download for Windows 7?

Re: 4.1.4 Calc does not calculate any more

PostPosted: Fri Nov 24, 2017 11:18 am
by RoryOF
That is the correct file if your user locale is Germany. If it is one of the English speaking countries, the file should be Apache_OpenOffice_4.1.4_Win_x86_install_en-US.exe or some other variety of English in place of the en-US.

Re: 4.1.4 Calc does not calculate any more

PostPosted: Fri Nov 24, 2017 11:34 am
by Joe59
Oh, here might be the problem. I am German, living in Thailand. So can I just install this English file over the German version now or do I have to undo the latest update or even uninstall completely?

Re: 4.1.4 Calc does not calculate any more

PostPosted: Fri Nov 24, 2017 11:43 am
by RoryOF
In theory one can install over another version, but I would suggest using Revo Uninstaller at its most aggressive to remove OpenOffice; also delete the OO User profile so not trace of contamination from it affects the new install. Or, change to OO 4.1.3 in German.

I'm offline for about 8 hours now,

Re: 4.1.4 Calc does not calculate any more

PostPosted: Fri Nov 24, 2017 12:48 pm
by Joe59
Thanks, RoryOF! That did the trick. Overinstallation did not work. The US-version was not recognized as different from the .de version. So I installed Revo, deleted User, and reinstalled the US-version. And voila: Calc works like new ;)

I originally thought the different versions were about user language of the program only.
By the way: Anyway to change the user language of the US version into German? I didn't find any option.
Better to say, I find the option (user interface) but only Englisch (US) is available there. Are there language packages for user languages, too?

Re: [solved]4.1.4 Calc didn't work with .de version in Thail

PostPosted: Fri Nov 24, 2017 4:59 pm
by FJCC
Yes, you can download language packs from the usual page at openoffice.org. Just select to get a language pack instead of a full installation. For Windows, you will get a small exe file which you can double click to begin the installation.

Re: [solved]4.1.4 Calc didn't work with .de version in Thail

PostPosted: Fri Nov 24, 2017 6:24 pm
by Joe59
Thanks for the answer, FJCC. However, after loading down and installing a language pack, I still did not succeed to have a choice of German as an user interface language. It´s not a problem. I can work fine with the English version.