[Solved] 4.1.4 Calc didn't work with .de version in Thailand

Discuss setup / installation issues - Add a spell checker, Language pack?

[Solved] 4.1.4 Calc didn't work with .de version in Thailand

Postby Joe59 » Fri Nov 24, 2017 5:05 am

Windows 7 with open office 4.1.4

My spreadsheats working well in 4.1.3 show this Err:509 now with the same old formulas. The explanations says: missing operator, but muliplication is still the asterix (*). So what's wrong? =B3*35 means multiply B3 by 35. Has something changed there?
Last edited by Joe59 on Fri Nov 24, 2017 12:49 pm, edited 3 times in total.
Windows 7 plus Open Office 4.1.4
Joe59
 
Posts: 14
Joined: Fri Jun 16, 2017 5:52 pm

Re: 4.1.4 Érr:509 with simple formula =B3*35

Postby Joe59 » Fri Nov 24, 2017 6:09 am

Update: ALL formulas with all functions like =(b4:b6) or whatever show the same error code. Any calculation is not possible anymore. Moreover, formulas can't be copied anymore. Something is fundamentally wrong.
Windows 7 plus Open Office 4.1.4
Joe59
 
Posts: 14
Joined: Fri Jun 16, 2017 5:52 pm

Re: 4.1.4 Calc does not calculate any more

Postby RusselB » Fri Nov 24, 2017 7:02 am

This problem has already been mentioned earlier.
I have no problems with the formula =B3*35 conditional that the entry in B3 is a valid number
In your second post, there is no function specified, thus Calc doesn't know what it's supposed to do with the range B4:B6

Since you also state that you can't copy any formulas, to my knowledge a new aspect of this problem or a different problem completely, at this point i'm going to recommend that you reset your Open Office user profile, as described in [Tutorial]The OpenOffice User Profile
OpenOffice 4.1.6 and LibreOffice 6.0.6.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
RusselB
Volunteer
 
Posts: 4825
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: 4.1.4 Calc does not calculate any more

Postby RoryOF » Fri Nov 24, 2017 7:10 am

In a thread reporting a similar problem this post reported a solution:
https://forum.openoffice.org/en/forum/viewtopic.php?f=9&t=91111#p431372

Please try the attached file
Attachments
Sample.ods
(7.72 KiB) Downloaded 40 times
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28145
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: 4.1.4 Calc does not calculate any more

Postby Joe59 » Fri Nov 24, 2017 10:21 am

Thanks for the suggestions! However, the thing mentioned in the other thread does not work here. I had already tried to make a new file and tried it again after reading this thread. To no avail. Also the sample file gives me the Err:509 as a result. The values are numbers, the formulas are correct. I have been using OpenOffice Calc for quite some years now. What could be the problem?
Windows 7 plus Open Office 4.1.4
Joe59
 
Posts: 14
Joined: Fri Jun 16, 2017 5:52 pm

Re: 4.1.4 Calc does not calculate any more

Postby Joe59 » Fri Nov 24, 2017 10:47 am

@RusselB =(b4:b6) is the formula for the sum of b4 to b6 and as I remember, should there be no number in one of these fields, the error message is different. The formula is created by the program itself when you press the sum-symbol left of the input field.
Windows 7 plus Open Office 4.1.4
Joe59
 
Posts: 14
Joined: Fri Jun 16, 2017 5:52 pm

Re: 4.1.4 Calc does not calculate any more

Postby RoryOF » Fri Nov 24, 2017 10:52 am

If the sample file doesn't work, the problem is local to your computer. I suggest you rename your OO user profile.

As you are using Windows close OpenOffice and the Quickstarter. Open File
Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer (sometimes called Windows Explorer)
Address Bar and press Enter. Rename the "user" folder - "user.old" is a good choice. Start OpenOffice.
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28145
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: 4.1.4 Calc does not calculate any more

Postby Joe59 » Fri Nov 24, 2017 11:01 am

Hi Rory, thanks for the tip. However, it did not work. Same problem persists. I have a new "user" folder, as I can see plus the copies of the old ones. New file: Does not work, old file: Does not work, Sample file: nope.

Was "Apache_OpenOffice_4.1.4_Win_x86_install_de" the right file to download for Windows 7?
Windows 7 plus Open Office 4.1.4
Joe59
 
Posts: 14
Joined: Fri Jun 16, 2017 5:52 pm

Re: 4.1.4 Calc does not calculate any more

Postby RoryOF » Fri Nov 24, 2017 11:18 am

That is the correct file if your user locale is Germany. If it is one of the English speaking countries, the file should be Apache_OpenOffice_4.1.4_Win_x86_install_en-US.exe or some other variety of English in place of the en-US.
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28145
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: 4.1.4 Calc does not calculate any more

Postby Joe59 » Fri Nov 24, 2017 11:34 am

Oh, here might be the problem. I am German, living in Thailand. So can I just install this English file over the German version now or do I have to undo the latest update or even uninstall completely?
Windows 7 plus Open Office 4.1.4
Joe59
 
Posts: 14
Joined: Fri Jun 16, 2017 5:52 pm

Re: 4.1.4 Calc does not calculate any more

Postby RoryOF » Fri Nov 24, 2017 11:43 am

In theory one can install over another version, but I would suggest using Revo Uninstaller at its most aggressive to remove OpenOffice; also delete the OO User profile so not trace of contamination from it affects the new install. Or, change to OO 4.1.3 in German.

I'm offline for about 8 hours now,
Apache OpenOffice 4.1.6 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28145
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: 4.1.4 Calc does not calculate any more

Postby Joe59 » Fri Nov 24, 2017 12:48 pm

Thanks, RoryOF! That did the trick. Overinstallation did not work. The US-version was not recognized as different from the .de version. So I installed Revo, deleted User, and reinstalled the US-version. And voila: Calc works like new ;)

I originally thought the different versions were about user language of the program only.
By the way: Anyway to change the user language of the US version into German? I didn't find any option.
Better to say, I find the option (user interface) but only Englisch (US) is available there. Are there language packages for user languages, too?
Windows 7 plus Open Office 4.1.4
Joe59
 
Posts: 14
Joined: Fri Jun 16, 2017 5:52 pm

Re: [solved]4.1.4 Calc didn't work with .de version in Thail

Postby FJCC » Fri Nov 24, 2017 4:59 pm

Yes, you can download language packs from the usual page at openoffice.org. Just select to get a language pack instead of a full installation. For Windows, you will get a small exe file which you can double click to begin the installation.
Windows 10 and Linux Mint, since 2017
If your question is answered, please go to your first post, select the Edit button, and add [Solved] to the beginning of the title.
FJCC
Moderator
 
Posts: 7011
Joined: Sat Nov 08, 2008 8:08 pm
Location: Colorado, USA

Re: [solved]4.1.4 Calc didn't work with .de version in Thail

Postby Joe59 » Fri Nov 24, 2017 6:24 pm

Thanks for the answer, FJCC. However, after loading down and installing a language pack, I still did not succeed to have a choice of German as an user interface language. It´s not a problem. I can work fine with the English version.
Windows 7 plus Open Office 4.1.4
Joe59
 
Posts: 14
Joined: Fri Jun 16, 2017 5:52 pm


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 2 guests