[Solved] Junkware

Discuss setup / installation issues - Add a spell checker, Language pack?

[Solved] Junkware

Postby Helmut » Fri Oct 27, 2017 10:58 am

Solved

Hi,
My G-data (my Antivirus software) has reported as follows::

Junkware (PUP): Win32.Adware.Narn.D (Engine B)
Datei: Updater.exe
Verzeichnis: C:\Users\xxx\AppData\Roaming\OpenOffice Updater


What doe this mean ?
Helmut

I use Windows 7 and Open Office 4.1.4
Last edited by Helmut on Sun Oct 29, 2017 10:29 pm, edited 2 times in total.
Open Office 4.1.4
Windows 7
Helmut
 
Posts: 5
Joined: Fri Oct 27, 2017 10:41 am

Re: Junkware

Postby RoryOF » Fri Oct 27, 2017 11:04 am

This is most probably a "false positive", which often happens with new versions of a program. I suggest you try another antivirus; Trend do a remote scan of your computer - follow their Housecall link. In the past I have found this helpful.
Apache OpenOffice 4.1.4 on Xubuntu 16.04.03 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 25391
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Junkware

Postby Villeroy » Fri Oct 27, 2017 12:24 pm

Can anybody confirm that the directory C:\Users\xxx\AppData\Roaming\OpenOffice Updater exists? I don't have AOO on Windows right now.

Helmut, where did you download the program? Did you download from the original home page https://openoffice.org/ This page redirects to sourceforge.net where the package is actually hosted.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 16.04, OpenOffice 4.x & LibreOffice 5.x
User avatar
Villeroy
Volunteer
 
Posts: 24592
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Junkware

Postby John_Ha » Fri Oct 27, 2017 12:40 pm

Villeroy wrote:Can anybody confirm that the directory C:\Users\xxx\AppData\Roaming\OpenOffice Updater exists?

It does not appear on W7 with AOO 4.1.4 (and nor 4.1.3). C:\Users\xxx\AppData\Roaming\OpenOffice has a folder \4. C:\Users\xxx\AppData\Roaming\OpenOffice\4 has a folder \user. C:\Users\xxx\AppData\Roaming\OpenOffice\4\user has the profile folders shown below. Neither C:\Users\xxx\AppData\Local\ nor C:\Users\xxx\AppData\LocalLow\ have any AOO folders.

Also when I search the PC with updater it does not find any folder called updater.
Attachments
Clipboard02.png
The AOO 4.1.4 profile folders
AOO 4.1.4, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the up to date Writer guide for information. Click the Help button on a pop-up window for extensive help on that function.
John_Ha
Volunteer
 
Posts: 4544
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Junkware

Postby John_Ha » Fri Oct 27, 2017 12:51 pm

A thought. Does the folder get created during the installation, and then get deleted? There is no folder called updater in the OpenOffice 4.1.3 (en-GB) Installation Files or OpenOffice 4.1.4 (en-GB) Installation Files folders.

As for the original question - it will be a false positive if the software has been downloaded from the openoffice.org website and it can safely be ignored.
AOO 4.1.4, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the up to date Writer guide for information. Click the Help button on a pop-up window for extensive help on that function.
John_Ha
Volunteer
 
Posts: 4544
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: Junkware

Postby RusselB » Fri Oct 27, 2017 2:27 pm

Just checked my system with 4.1.4 installed (I know, I need to update my signature), and didn't find the directory.
Then I performed a monitored installation, per John_Ha's suggestion that it might be a directory made during installation, but did not notice this happening during the installation process.
I suspect, like has already been mentioned, that this is a false positive, due to the newer version of Open Office and/or the anti-virus being out of date.
OpenOffice 4.1.4 and LibreOffice 5.2.7.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
RusselB
Volunteer
 
Posts: 4118
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON

Re: Junkware

Postby RoryOF » Fri Oct 27, 2017 2:50 pm

I have drawn attention of the OO Dev list to this report, just in case.
Apache OpenOffice 4.1.4 on Xubuntu 16.04.03 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 25391
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Junkware

Postby Bill » Fri Oct 27, 2017 3:04 pm

This may be an independent updater from openoffice-updater.de, not part of Apache OpenOffice. Try a Google search for "roaming\openoffice updater" for more information.
AOO 4.1.4 on 64-bit Windows 10 and Manjaro Linux
Bill
Volunteer
 
Posts: 6343
Joined: Sat Nov 24, 2007 6:48 am

Re: Junkware

Postby Helmut » Fri Oct 27, 2017 4:49 pm

John_Ha wrote:
Villeroy wrote:Can anybody confirm that the directory C:\Users\xxx\AppData\Roaming\OpenOffice Updater exists?

It does not appear on W7 with AOO 4.1.4 (and nor 4.1.3). C:\Users\xxx\AppData\Roaming\OpenOffice has a folder \4. C:\Users\xxx\AppData\Roaming\OpenOffice\4 has a folder \user. C:\Users\xxx\AppData\Roaming\OpenOffice\4\user has the profile folders shown below. Neither C:\Users\xxx\AppData\Local\ nor C:\Users\xxx\AppData\LocalLow\ have any AOO folders.

Also when I search the PC with updater it does not find any folder called updater.
Last edited by Helmut on Fri Oct 27, 2017 5:44 pm, edited 1 time in total.
Open Office 4.1.4
Windows 7
Helmut
 
Posts: 5
Joined: Fri Oct 27, 2017 10:41 am

Re: Junkware

Postby Helmut » Fri Oct 27, 2017 4:53 pm

Villeroy wrote:Can anybody confirm that the directory C:\Users\xxx\AppData\Roaming\OpenOffice Updater exists? I don't have AOO on Windows right now.

Helmut, where did you download the program? Did you download from the original home page https://openoffice.org/ This page redirects to sourceforge.net where the package is actually hosted.


I'm not sure where I downloaded it from, but I normally download programs from the original home page
Open Office 4.1.4
Windows 7
Helmut
 
Posts: 5
Joined: Fri Oct 27, 2017 10:41 am

Re: Junkware

Postby Villeroy » Fri Oct 27, 2017 5:05 pm

Aunt Google tells me that the directory belongs to http://www.openoffice-updater.de/ which installs a separate program. It might be junkware indeed.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 16.04, OpenOffice 4.x & LibreOffice 5.x
User avatar
Villeroy
Volunteer
 
Posts: 24592
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Junkware

Postby RoryOF » Fri Oct 27, 2017 6:07 pm

One of the developers has replied to me as follows
quote] This directory is *not* created by our official build but by a
> repackaged installation from openoffice.de.
>
> We already had some users reporting virus warnings (Kaspersky) when
> installing this "false" package.[/quote]

As Villeroy has also pointed out, this package does not originate from
http://www.openoffice.org/download
which is the only site through which we recommend downloading.
Apache OpenOffice 4.1.4 on Xubuntu 16.04.03 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 25391
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Junkware

Postby Helmut » Sun Oct 29, 2017 10:14 am

RoryOF wrote:As Villeroy has also pointed out, this package does not originate from
http://www.openoffice.org/download
which is the only site through which we recommend downloading.


Thanks to all. I have uninstalled my Open Office and installed it from the link above. Let's see what happens.
Helmut
Open Office 4.1.4
Windows 7
Helmut
 
Posts: 5
Joined: Fri Oct 27, 2017 10:41 am

Re: Junkware

Postby Villeroy » Sun Oct 29, 2017 12:49 pm

However, you should also uninstall the "OpenOffice Updater". Technically this package has nothing to do with OpenOffice.
Please, edit this topic's initial post and add "[Solved]" to the subject line if your problem has been solved.
Ubuntu 16.04, OpenOffice 4.x & LibreOffice 5.x
User avatar
Villeroy
Volunteer
 
Posts: 24592
Joined: Mon Oct 08, 2007 1:35 am
Location: Germany

Re: Junkware

Postby Helmut » Sun Oct 29, 2017 1:56 pm

Villeroy wrote:However, you should also uninstall the "OpenOffice Updater". Technically this package has nothing to do with OpenOffice.

Done, thanks
Helmut
Open Office 4.1.4
Windows 7
Helmut
 
Posts: 5
Joined: Fri Oct 27, 2017 10:41 am

Re: Junkware

Postby RusselB » Sun Oct 29, 2017 6:43 pm

A small point, not directly related, but you should update your forum signature, as it currently reads Open Office 4.4, yet the latest version is OpenOffice 4.1.4
Having an accurate forum signature will make things easier as you won't get solutions for problems that work in the version you indicate in your signature, but might not work in the version you are actually using.
OpenOffice 4.1.4 and LibreOffice 5.2.7.2 on Windows 7 Pro & Ultimate
If you believe your problem has been resolved, please go to your first post in this topic, click the Edit button and add [Solved] to the beginning of the Subject line.
RusselB
Volunteer
 
Posts: 4118
Joined: Fri Jan 03, 2014 7:31 am
Location: Sarnia, ON


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: Google [Bot] and 9 guests