[Solved] Spell Check Not Working (words red underlined)

Discuss setup / installation issues - Add a spell checker, Language pack?

[Solved] Spell Check Not Working (words red underlined)

Postby Hagar Delest » Wed Jun 07, 2017 9:09 pm

It is the most frequent question in this forum!

There are already tutorials for that. The easiest fix is to reset the configuration. Follow the steps described here: resetting your OpenOffice user profile.
Note: reinstalling won't change anything if the profile is not deleted, which is not done automatically when removing the application.

A script has been developed which fixes it automatically without resetting the whole profile: Spell checker "red wriggly lines" - beta test fix for AOO.

If no change, then follow this topic: [Troubleshooting] Spell check in OpenOffice.

Further information in this topic: [Solved] No dictionary present in OpenOffice.

If this sticky post with its links has helped you, don't hesitate to leave a post in this thread.
User avatar
Hagar Delest
Moderator
 
Posts: 28458
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoyM » Tue Jul 11, 2017 8:41 pm

I had the same problem with red lunderlining, but trying the 'python' fix has removed the red lines but the spelling check does not work at all. There are no language packs available. I have downloaded the English UK but it refuses to show in the languages and still the spell check does not work.
Open Office 4.1.3 on Windows 10.
RoyM
 
Posts: 1
Joined: Tue Jul 11, 2017 6:50 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby John_Ha » Thu Jul 13, 2017 1:30 pm

RoyM wrote:I have downloaded the English UK but it refuses to show in the languages and still the spell check does not work.

You need to open the .oxt file with OpenOffice in order for it to install. My UK English dictionary is installed at C:\Users\John\AppData\Roaming\OpenOffice\4\user\uno_packages\cache\uno_packages\svdw693c.tmp_\ which contains the folder dict-en-20170701.oxt and the file dict-en-20170701.oxtproperties.

You can debug the problem at [Troubleshooting] Spell check in OpenOffice but the easiest solution is probably to re-install AOO.

1 Uninstall AOO. When it says "Do you want to keep your user data?" answer no - it is what is causing the problem.

2 Download AOO from http://www.openoffice.org/download/index.html. Install it.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6592
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved] Spell Check Not Working (words red underlined)

Postby bcripps » Tue Aug 15, 2017 9:17 pm

What is with Spell Check... Over the years I've had nothing but trouble with it. Can't those smart engineers over at LibreOffice get it right? This should NOT be this hard!
Bry
Open Office 4.1.2 operating on Win 7
bcripps
 
Posts: 3
Joined: Sun Aug 13, 2017 8:22 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoryOF » Tue Aug 15, 2017 9:32 pm

The methods to fix are set out in earlier postings in this thread; a recurrence of the problem is most often caused by User error - powering down the computer before the housekeeping information has finally been written to disk. It is worth waiting a few seconds after the formal "OK to power off" message before cutting the power, to permit the write buffers to flush to disk.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28742
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Check Not Working (words red underlined)

Postby John_Ha » Thu Aug 17, 2017 12:56 pm

bcripps wrote:What is with Spell Check... Over the years I've had nothing but trouble with it.

I have used OOo and AOO for 20 or more years, typing thousands of documents and millions of words, and I have never had a problem with spell check. But ...

... I always close AOO properly.
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6592
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved] Spell Check Not Working (words red underlined)

Postby Kwilc » Thu Sep 14, 2017 6:19 pm

I deleted the user file as recommended. I re-entered my details when I restarted office and the Spell check now works correctly. Thank You
Open Office 4.1.3 on Windows 10
Kwilc
 
Posts: 1
Joined: Thu Sep 14, 2017 6:14 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby tirgana » Mon Sep 18, 2017 4:54 am

I'm usually quick on the uptake, but the directions you gave to fix the spell checker are completely confusing. Please put the direction is simple terms that are understandable.
openoffice 401
tirgana
 
Posts: 3
Joined: Mon Sep 18, 2017 4:46 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoryOF » Mon Sep 18, 2017 11:50 am

Try this:

To fix the spellcheck, try renaming your OpenOffice user profile.

As you are using Windows close OpenOffice and the Quickstarter.

Open File Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer (sometimes called Windows Explorer)
Address Bar and press Enter.

Rename the "user" folder - "user.old" is a good choice.

Start OpenOffice.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28742
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Check Not Working (words red underlined)

Postby tirgana » Mon Sep 18, 2017 4:43 pm

File explorer? You are talking to a baby geek.
openoffice 401
tirgana
 
Posts: 3
Joined: Mon Sep 18, 2017 4:46 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoryOF » Mon Sep 18, 2017 4:45 pm

Google it - I cannot teach you by remote control how to drive a car or a computer.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28742
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Check Not Working (words red underlined)

Postby tirgana » Mon Sep 18, 2017 4:50 pm

Never mind. Got it. Thanks.
openoffice 401
tirgana
 
Posts: 3
Joined: Mon Sep 18, 2017 4:46 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby Marco555 » Thu Feb 08, 2018 12:01 am

To fix the spellcheck, try renaming your OpenOffice user profile.

As you are using Windows close OpenOffice and the Quickstarter.

Open File Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer (sometimes called Windows Explorer)
Address Bar and press Enter.

Rename the "user" folder - "user.old" is a good choice.

Start OpenOffice.

This worked for me!
OpenOffice 4 on Windows 8.1
Marco555
 
Posts: 1
Joined: Wed Feb 07, 2018 11:54 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby intanet » Thu Mar 08, 2018 8:38 am

While in the middle of writing a document, the spell check red line went away and I have no idea why or how. May have hit a key on my keyboard or something. Don't know. So, I tried this and it worked for me.
1) I went into Tools/Spelling and Grammar/Options and unticked "Check Spelling as you type" since it was already ticked but not working. Close off the windows.
2) I saved the document so I wouldn't lose my edits.
3) Closed the document
4) I opened up Task Manager (ctr alt delete) to make sure that every instance of Open Office was closed including soffice.bin and soffice.exe. I don't use the Quick Starter but, if you use it, that has to be closed too.
5) I opened up Open Office and went back into: Tools/Spelling and Grammar/Options and ticked "Check Spelling as you type" and closed off the windows and spell check red line was back again.
Open Office 3.1.1 on Windows XP Pro
intanet
 
Posts: 15
Joined: Sun Oct 18, 2009 6:57 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby John_Ha » Fri Apr 06, 2018 1:34 pm

intanet wrote:While in the middle of writing a document, the spell check red line went away and I have no idea why or how.

Almost certainly because you clicked the " abc with red wriggly line " icon which toggles between "show spelling errors with red line" and "don't show spelling errors with red line".
AOO 4.1.6, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 6592
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved] Spell Check Not Working (words red underlined)

Postby Fricisee » Sun Apr 29, 2018 2:00 am

Easier way to do this.

Open OpenOffice Document > Tools> Language> For All Languages > English (UK)

Its not selected by default for some reason.
OpenOffice 4.1 on Windows 10
Fricisee
 
Posts: 1
Joined: Sun Apr 29, 2018 1:54 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby rhowl » Thu Jun 21, 2018 5:55 am

I reset my profile just as described and it solved my spell check error! Thanks so much, I spent about an hour trying to fix it through other forum suggestions. Thank goodness for this post!
OpenOffice 4.1.5 on Windows 7
rhowl
 
Posts: 13
Joined: Tue Jan 23, 2018 7:52 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby Fred Bloggs » Fri Jul 06, 2018 1:31 pm

I really have solved it, I am using a stable distro (like a brick), except for office, usual linux problem, or a distro with excellent office, but hates hardware. So install brick like distro and virtual machine running hardware hating distro, to run office programs (instead of windows and MS Office on the VM) everything stable, good bye Bill. Taxes the machine and bit of a hassle, but worth it. Sorry but couldn't find one where Oo was stable except Windows, so using a different office, but smile for me, I have wanted to get rid of microsoft since windows 98. :D
Open Office 4.1.5 on Kubuntu 18.04
Fred Bloggs
 
Posts: 2
Joined: Fri Jul 06, 2018 3:47 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby 9drtr » Tue Jan 15, 2019 10:19 pm

Thank you. I owe you a kidney.
OpenOffice 4.1.6 on Windows 10
9drtr
 
Posts: 1
Joined: Tue Jan 15, 2019 10:01 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby muffiemae » Wed Mar 27, 2019 9:48 pm

I will try some of these ideas. i generally like Open Office, but almost every month or so, the spell check is not working. I have to go into my "user" files, open office, etc., and delete my user file. Then I have to re-register. After that, I have to re-do my options. Really a pain in the butt. And of course none of my recent documents show up, and I have to re-open all of them. I'd sure like Apache Open Office to fix this awful glitch!
OpenOffice 4.1.5 on Windows 7 Pro.
muffiemae
 
Posts: 6
Joined: Wed Mar 27, 2019 7:25 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoryOF » Wed Mar 27, 2019 11:02 pm

Often the reason for occasional failure of spellcheck is improper (over-hasty) close down of the computer. Use the formal computer close down proocedure and wait for a few seconds after the "Safe to power off" message for all disk activity to finish (the disks to spin down) before turning off the power or closing the laptop lid. This will only take a few seconds, but even cumulatively these few seconds will be less than the time taken to repair just one instance of spellcheck failure.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28742
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Check Not Working (words red underlined)

Postby muffiemae » Fri Mar 29, 2019 6:45 pm

Thank you, but I NEVER close down my computer until it is "safe to power off."(I have a desktop computer, not a laptop.) But I still consistently get this problem with Open Office. As much as I HATE Microsoft, I'm considering using Word instead of Open Office. A new learning experience in itself, but....
OpenOffice 4.1.5 on Windows 7 Pro.
muffiemae
 
Posts: 6
Joined: Wed Mar 27, 2019 7:25 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby muffiemae » Thu Apr 18, 2019 9:12 pm

bcripps wrote:What is with Spell Check... Over the years I've had nothing but trouble with it. Can't those smart engineers over at LibreOffice get it right? This should NOT be this hard!
Bry


I'm very annoyed! At least once a month I have to delete my profile because the spell check is not working...because the dictionaries have disappeared. And then that involves changing the ordinal numbers (I do NOT want them!) in not one but TWO places, deleting word completion in TWO places, etc. Then the "recent file" list is gone, of course.
OpenOffice 4.1.5 on Windows 7 Pro.
muffiemae
 
Posts: 6
Joined: Wed Mar 27, 2019 7:25 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoryOF » Thu Apr 18, 2019 9:21 pm

I have offered what advice I can. In ten years heavy use of OpenOffice, the only time I have lost my spellcheck was after sudden closedown because of power failure (now protected against by a UPS).

You could copy your entire OO user profile after getting spellcheck to work; next time the problem re-occurs, just copy the saved User profile over the now faulty one. You will lose any new extensions installed and any words added to the dictionary.

It is your choice what to do - we do not drive your computer.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28742
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Check Not Working (words red underlined)

Postby muffiemae » Fri Apr 19, 2019 2:54 am

That's a good idea to copy my user profile. My OO is on a desktop computer, I've used a UPS for years, and I've had no sudden shutdowns. I have Win 7 Pro. When I click "Shut down," the computer powers itself off and only then do I turn off my UPS. I'm glad you've not had the same problem, but obviously others have--who have not done premature shut downs.
OpenOffice 4.1.5 on Windows 7 Pro.
muffiemae
 
Posts: 6
Joined: Wed Mar 27, 2019 7:25 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby robleyd » Fri Apr 19, 2019 4:00 am

Do you close OpenOffice before you shut down the computer? If you let Windows terminate OpenOffice you may have problems.
Cheers
David
Apache OpenOffice 4.2.0 Build 9820 alpha version - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 2630
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoryOF » Fri Apr 19, 2019 10:26 am

Problems have been reported if a computer is allowed hibernate wih an OpenOffice file open.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28742
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Check Not Working (words red underlined)

Postby muffiemae » Fri Apr 19, 2019 12:19 pm

robleyd wrote:Do you close OpenOffice before you shut down the computer? If you let Windows terminate OpenOffice you may have problems.


Thank you. I have no open files in OO when I shut down. Is that what you mean? I assume it is not running if I have no open files, correct?

If I mistakenly have anything running/open when I click shut down, a message tells what files are open and are preventing shut down. Then I have to cancel and go back and close the files before I can shut down.
OpenOffice 4.1.5 on Windows 7 Pro.
muffiemae
 
Posts: 6
Joined: Wed Mar 27, 2019 7:25 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoryOF » Fri Apr 19, 2019 1:15 pm

A possibility is that the internal buffers of the hard disk need power for slightly longer to flush to disk - this obviously depends on exact configuration of your computer and its components.

I suggest for diagnostic purposes you adopt a systematic method of shutdown - close OpenOffice, wait about ten or fifteen seconds, then initiate the computer shutdown sequence.

A problem with fault diagnosis is that developers are almost always long-time computer users and their instincts guard against them doing what they feel to be incorrect actions, so it is difficult, perhaps almost impossible, for them to break away from their normal course of action.
Apache OpenOffice 4.1.6 on Xubuntu 18.04.2 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 28742
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Check Not Working (words red underlined)

Postby muffiemae » Fri Apr 19, 2019 2:40 pm

Thank you for the idea! Will do.
OpenOffice 4.1.5 on Windows 7 Pro.
muffiemae
 
Posts: 6
Joined: Wed Mar 27, 2019 7:25 pm


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 6 guests