[Solved] Spell Check Not Working (words red underlined)

Discuss setup / installation issues - Add a spell checker, Language pack?

[Solved] Spell Check Not Working (words red underlined)

Postby Hagar Delest » Wed Jun 07, 2017 9:09 pm

It is the most frequent question in this forum!

There are already tutorials for that. The easiest fix is to reset the configuration. Follow the steps described here: resetting your OpenOffice user profile.
Note: reinstalling won't change anything if the profile is not deleted, which is not done automatically when removing the application.

A script has been developed which fixes it automatically without resetting the whole profile: Spell checker "red wriggly lines" - beta test fix for AOO.

If no change, then follow this topic: [Troubleshooting] Spell check in OpenOffice.

Further information in this topic: [Solved] No dictionary present in OpenOffice.

If this sticky post with its links has helped you, don't hesitate to leave a post in this thread.
User avatar
Hagar Delest
Moderator
 
Posts: 28155
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoyM » Tue Jul 11, 2017 8:41 pm

I had the same problem with red lunderlining, but trying the 'python' fix has removed the red lines but the spelling check does not work at all. There are no language packs available. I have downloaded the English UK but it refuses to show in the languages and still the spell check does not work.
Open Office 4.1.3 on Windows 10.
RoyM
 
Posts: 1
Joined: Tue Jul 11, 2017 6:50 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby John_Ha » Thu Jul 13, 2017 1:30 pm

RoyM wrote:I have downloaded the English UK but it refuses to show in the languages and still the spell check does not work.

You need to open the .oxt file with OpenOffice in order for it to install. My UK English dictionary is installed at C:\Users\John\AppData\Roaming\OpenOffice\4\user\uno_packages\cache\uno_packages\svdw693c.tmp_\ which contains the folder dict-en-20170701.oxt and the file dict-en-20170701.oxtproperties.

You can debug the problem at [Troubleshooting] Spell check in OpenOffice but the easiest solution is probably to re-install AOO.

1 Uninstall AOO. When it says "Do you want to keep your user data?" answer no - it is what is causing the problem.

2 Download AOO from http://www.openoffice.org/download/index.html. Install it.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5689
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved] Spell Check Not Working (words red underlined)

Postby bcripps » Tue Aug 15, 2017 9:17 pm

What is with Spell Check... Over the years I've had nothing but trouble with it. Can't those smart engineers over at LibreOffice get it right? This should NOT be this hard!
Bry
Open Office 4.1.2 operating on Win 7
bcripps
 
Posts: 3
Joined: Sun Aug 13, 2017 8:22 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoryOF » Tue Aug 15, 2017 9:32 pm

The methods to fix are set out in earlier postings in this thread; a recurrence of the problem is most often caused by User error - powering down the computer before the housekeeping information has finally been written to disk. It is worth waiting a few seconds after the formal "OK to power off" message before cutting the power, to permit the write buffers to flush to disk.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 26943
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Check Not Working (words red underlined)

Postby John_Ha » Thu Aug 17, 2017 12:56 pm

bcripps wrote:What is with Spell Check... Over the years I've had nothing but trouble with it.

I have used OOo and AOO for 20 or more years, typing thousands of documents and millions of words, and I have never had a problem with spell check. But ...

... I always close AOO properly.
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5689
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved] Spell Check Not Working (words red underlined)

Postby Kwilc » Thu Sep 14, 2017 6:19 pm

I deleted the user file as recommended. I re-entered my details when I restarted office and the Spell check now works correctly. Thank You
Open Office 4.1.3 on Windows 10
Kwilc
 
Posts: 1
Joined: Thu Sep 14, 2017 6:14 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby tirgana » Mon Sep 18, 2017 4:54 am

I'm usually quick on the uptake, but the directions you gave to fix the spell checker are completely confusing. Please put the direction is simple terms that are understandable.
openoffice 401
tirgana
 
Posts: 3
Joined: Mon Sep 18, 2017 4:46 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoryOF » Mon Sep 18, 2017 11:50 am

Try this:

To fix the spellcheck, try renaming your OpenOffice user profile.

As you are using Windows close OpenOffice and the Quickstarter.

Open File Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer (sometimes called Windows Explorer)
Address Bar and press Enter.

Rename the "user" folder - "user.old" is a good choice.

Start OpenOffice.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 26943
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Check Not Working (words red underlined)

Postby tirgana » Mon Sep 18, 2017 4:43 pm

File explorer? You are talking to a baby geek.
openoffice 401
tirgana
 
Posts: 3
Joined: Mon Sep 18, 2017 4:46 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby RoryOF » Mon Sep 18, 2017 4:45 pm

Google it - I cannot teach you by remote control how to drive a car or a computer.
Apache OpenOffice 4.1.5 on Xubuntu 18.04 (mostly 64 bit version) and infrequently on Win2K/XP
14 October 2016 was Pooh's 90th birthday
User avatar
RoryOF
Moderator
 
Posts: 26943
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: [Solved] Spell Check Not Working (words red underlined)

Postby tirgana » Mon Sep 18, 2017 4:50 pm

Never mind. Got it. Thanks.
openoffice 401
tirgana
 
Posts: 3
Joined: Mon Sep 18, 2017 4:46 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby Marco555 » Thu Feb 08, 2018 12:01 am

To fix the spellcheck, try renaming your OpenOffice user profile.

As you are using Windows close OpenOffice and the Quickstarter.

Open File Explorer. Copy and paste %appdata%\OpenOffice\4 in the File Explorer (sometimes called Windows Explorer)
Address Bar and press Enter.

Rename the "user" folder - "user.old" is a good choice.

Start OpenOffice.

This worked for me!
OpenOffice 4 on Windows 8.1
Marco555
 
Posts: 1
Joined: Wed Feb 07, 2018 11:54 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby intanet » Thu Mar 08, 2018 8:38 am

While in the middle of writing a document, the spell check red line went away and I have no idea why or how. May have hit a key on my keyboard or something. Don't know. So, I tried this and it worked for me.
1) I went into Tools/Spelling and Grammar/Options and unticked "Check Spelling as you type" since it was already ticked but not working. Close off the windows.
2) I saved the document so I wouldn't lose my edits.
3) Closed the document
4) I opened up Task Manager (ctr alt delete) to make sure that every instance of Open Office was closed including soffice.bin and soffice.exe. I don't use the Quick Starter but, if you use it, that has to be closed too.
5) I opened up Open Office and went back into: Tools/Spelling and Grammar/Options and ticked "Check Spelling as you type" and closed off the windows and spell check red line was back again.
Open Office 3.1.1 on Windows XP Pro
intanet
 
Posts: 15
Joined: Sun Oct 18, 2009 6:57 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby John_Ha » Fri Apr 06, 2018 1:34 pm

intanet wrote:While in the middle of writing a document, the spell check red line went away and I have no idea why or how.

Almost certainly because you clicked the " abc with red wriggly line " icon which toggles between "show spelling errors with red line" and "don't show spelling errors with red line".
AOO 4.1.5, Windows 7 Home 64 bit

See the Writer Manual, the Writer FAQ, the Writer Tutorials and the Writer guide.

Remember: Always save your Writer files as .odt files. - see here for the many reasons why.
John_Ha
Volunteer
 
Posts: 5689
Joined: Fri Sep 18, 2009 5:51 pm
Location: UK

Re: [Solved] Spell Check Not Working (words red underlined)

Postby Fricisee » Sun Apr 29, 2018 2:00 am

Easier way to do this.

Open OpenOffice Document > Tools> Language> For All Languages > English (UK)

Its not selected by default for some reason.
OpenOffice 4.1 on Windows 10
Fricisee
 
Posts: 1
Joined: Sun Apr 29, 2018 1:54 am

Re: [Solved] Spell Check Not Working (words red underlined)

Postby rhowl » Thu Jun 21, 2018 5:55 am

I reset my profile just as described and it solved my spell check error! Thanks so much, I spent about an hour trying to fix it through other forum suggestions. Thank goodness for this post!
OpenOffice 4.1.5 on Windows 7
rhowl
 
Posts: 12
Joined: Tue Jan 23, 2018 7:52 pm

Re: [Solved] Spell Check Not Working (words red underlined)

Postby Fred Bloggs » Fri Jul 06, 2018 1:31 pm

I really have solved it, I am using a stable distro (like a brick), except for office, usual linux problem, or a distro with excellent office, but hates hardware. So install brick like distro and virtual machine running hardware hating distro, to run office programs (instead of windows and MS Office on the VM) everything stable, good bye Bill. Taxes the machine and bit of a hassle, but worth it. Sorry but couldn't find one where Oo was stable except Windows, so using a different office, but smile for me, I have wanted to get rid of microsoft since windows 98. :D
Open Office 4.1.5 on Kubuntu 18.04
Fred Bloggs
 
Posts: 2
Joined: Fri Jul 06, 2018 3:47 am


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 8 guests