Page 1 of 1

[Solved] Saving as unknown file?

PostPosted: Mon Dec 10, 2007 7:17 pm
by francophile
After many months of problem free use I now have a problem in that whatever format I select for saving OO saves the documents as unknown files which will not then open automatically in OO. :?:

Thanks now solved, so easy really

Re: Saving

PostPosted: Mon Dec 10, 2007 7:24 pm
by floris v
Have you checked the Automatic file name extension check box?

Re: Saving

PostPosted: Mon Dec 10, 2007 8:54 pm
by TerryE
go into Calc or Writer and select from the file menu, "recent documents". Can you open the ones who that you still have? What extensions are you using: ODT PDS or DOC and XLS. You can set up your options to load and save in MSOffice compatible format, but there is also an install option which asks you whether you want to associate these extensions with OOo. You may have said No to this Q.

Usually you should stick to the OOo native types (ODS etc) unless you want to interchange files with an MSOffice user. Anyway you should associate the extension that you want to use with OOo with it. You can do this manually in XP by right clicking on the file and doing an "open with" then browsing to pick the relevant exe from (typically) "C:\Program Files\OpenOffice.org 2.3\program\" and checkingthe "always open this file type with this application" option.

Re: Saving

PostPosted: Tue Dec 11, 2007 12:18 am
by Hagar Delest
floris v wrote:Have you checked the Automatic file name extension check box?

It should fix the issue.

Thanks to add '[Solved]' in your first post title (edit button) if your issue has been fixed.

NB: moved your thread to the Setup & Troubleshouting forum.

Re: Saving

PostPosted: Tue Dec 11, 2007 11:12 am
by francophile
Existing docs open fine. No matter what format I select result is the same. I don't think I've altered any settings. Shall I reinstall d'ya think?

Re: Saving

PostPosted: Tue Dec 11, 2007 12:16 pm
by francophile
floris v wrote:Have you checked the Automatic file name extension check box?
I can't find it. :oops:

Re: Saving

PostPosted: Tue Dec 11, 2007 12:30 pm
by TerryE
Open an existing file that you can't open by clicking on it. Click File -> Properties and copy the full name then paste it into a reply here, so I can see the name and extension.

Also tell me whether you managed to do the "open with" dialogue as I described.

Re: Saving

PostPosted: Tue Dec 11, 2007 3:35 pm
by francophile
xmas message

That's it no file extension shown. Documents created previously have an odt extension like this( round robin.odt.) I can open all documents but the ones I create now do not show as the usual OOo logo and have no file extension so they will not open auomatically as previously. Not a terrible problem for me but I want to email some stuff to Word users and I can't tell if the document is readable to them or not.

Thanks for you help.

Re: Saving

PostPosted: Tue Dec 11, 2007 4:05 pm
by RonIA
So, did you find the "Automatic File Extension" box? It is on the File - Save As Dialog box (under where you put in the file name and file type, etc.)

For those files without a file extension you have previously saved, you should be able to go into your file manager (MS Windows Explorer for MS Windows) and right click on the file and select Rename, then you can add the appropriate extension (ODT). However, please note, in your last post you said you want people who have MS Word to be able to open the files.

Microsoft in its arrogance will not read / write ODT files, so make sure you save the file in a format MS Word can read/write (.doc or .rtf are two that should work).

Thanks to add '[Solved]' in your first post title (edit button) if your issue has been fixed.

Re: Saving

PostPosted: Tue Dec 11, 2007 10:42 pm
by Hagar Delest
Here it is when you open a Save As dialog :
Automatic file name.png
Automatic file name.png (10.63 KiB) Viewed 7200 times