Page 1 of 1

Locked for editing

PostPosted: Mon Nov 19, 2012 6:25 pm
by bryanparsons
Using Windows 8 I have been writing a file and saving it for several days; but foolishly not backed it up. Now when I try to access the file I get 'odt' is locked for editing by: Unknown User.' It asks me to 'Open document read-only or open a copy of the document for editing.'
When I try either I get what seems to be the correct quantity of type; but each line is composed of two parallel lines with slightly sloping vertical lines which are close together. I am not aware of having done anything which should have made this happen.
Is there any way to open the file?

Thanks

Bryan

Re: locked for editing

PostPosted: Mon Nov 19, 2012 7:38 pm
by thomasjk

Re: Locked for editing

PostPosted: Tue Nov 20, 2012 5:47 pm
by bryanparsons
Tried:
Open Folder Options by clicking the Start button , clicking Control Panel, clicking Appearance and Personalization, and then clicking Folder Options.
Click the View tab.
Under Advanced settings, click Show hidden files and folders, and then click OK.

This gets another folder in the files: '~lock.Edward's........' as well the original folder 'Edward's......' .The first of these opens without the 'odt' is locked for editing by: Unknown User.' It asks me to 'Open document read-only or open a copy of the document for editing.' ; but to one page with one and a bit of the parallel lines with groups of two sloping vertical lines. The second one still opens as before in original post.
Any further suggestions appreciated.

Bryan

Re: Locked for editing

PostPosted: Tue Nov 20, 2012 8:30 pm
by RoryOF
Look at the Edward's files. The ~lock.Edwards etc file should be no bigger than a few hundred bytes. The Edwards etc file should be a minimum of 7KB - a noticeable difference in size between the two, With OpenOffice closed, delete the smaller file and all should be well.

Re: Locked for editing

PostPosted: Wed Nov 21, 2012 1:01 pm
by bryanparsons
Yes I can now directly open the file; but all I get is the whole document as;
##############################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################################
Is there anything I can do to still open it?
If not is it likely to happen again?
Was it caused by 'Openoffice'; by 'Windows 8'; a combination of the two or something else?

Many Thanks

Bryan

Re: Locked for editing

PostPosted: Wed Nov 21, 2012 1:25 pm
by Hagar Delest
Sadly, quite nothing to do, see: 22 pages term paper replaced with pound signs.
Any power shortage for example? It's a common root cause of such problem.

Check the temporary folder of the system (see in OOo Tools>Options>OOo>Paths). If there are folders like sgmlf.tmp with a file having the same name inside, make a copy of that file, rename it in .odt and cross your fingers. Else, I hope you had a backup (or a copy in a mailbox)...

Re: Locked for editing

PostPosted: Wed Nov 21, 2012 1:40 pm
by RoryOF
This sometimes happens if there is a power failure or program or system crash, as Hagar says. It can also happen if the computer is closed down too quickly, witout giving the Write buffers, both in the operating system's file system or internally in the hard drives, time to flush and finsh their writes.

Working direct to a USB stick has been reported as causing similar problems; whether these reports are due to inherent problems with USB sticks (which do have a limited life in terms of number of write accesses) or improper observance of the correct USB removal protocols is uncertain, so on the Forum we do not recommend direct working to a USB stick.

Re: Locked for editing

PostPosted: Wed Nov 21, 2012 5:40 pm
by bryanparsons
No joy; but many thanks for your efforts. I will hopefully now be more vigilant at backing up and with closing down.

Bryan

Re: Locked for editing

PostPosted: Sat Mar 21, 2015 10:30 pm
by Lycantis
bryanparsons wrote:No joy; but many thanks for your efforts. I will hopefully now be more vigilant at backing up and with closing down.

Bryan



Bryan, I know this is a long time for a reply and I apologize, but I found your thread helpful and found a solution to the problem of pound signs.

Just continue by opening a copy to edit, save copy under a different name so you have the text. Then you go to Control Panel -> Folder Options -> View -> Show hidden folders, files and drives; proceed to delete that lock file, in my case it began with .~Lock. followed by the document name. If your original document was corrupted and is made of the "hashtags" all you have to do is CTR+A the copy, CTR+C to copy and CTR+P to paste it into the old document.

(Complicated way! Suggest using simpler method below! I just like to cover all options in case nothing else works.)

Alternately you DELETE the older version altogether and rename the new one, this will not affect the new document as it's a completely separate file. If you do not delete the .~lock. file, all subsequent files with the same name as the original will lock and become pound signs. I did a little testing.

Hope this helps everyone who has this problem in the future!

Re: Locked for editing

PostPosted: Mon Mar 30, 2015 9:45 am
by handgold
I also experienced the same thing . I am using Windows XP operating system , from the many pc , only 1 pc that entire file openoffice locked by unknown user. I 've checked the hidden files , but no folders are locked

Please help me guys

Re: Locked for editing

PostPosted: Fri Apr 08, 2016 4:19 pm
by egarrett
I had the same error pop up on one of my documents every day. So, every day I had to work on a new version of the file and save it. Not a big deal, but can be annoying.
Today I tried something else and it worked.

If I go to my file manager, and try to open the problematic file from the file manager, I get the "read only" error message.

If I open the OO, and go to File->Recent Documents -> my file that I need, then it opens up ok with no problems.

Maybe I am just lucky, but try this guys, and see if you have the same result.

Re: Locked for editing

PostPosted: Sun Oct 08, 2017 9:17 pm
by alanjones10
For some reason I create a file using Open-Office open writer, then save it. When I open it I cannot edit it at all. It is just a normal looking file. I do not see a duplicate.
Frankly this is very frustrating. I saw several answers to this but what they said to click I did not have on the screen. So I am posting a pic of what I see.
Hmmm. I guess I can not post it here.
Well...
On the top line I see: Writer, Home, Insert, Page Layout, References, ...
On the second line: Open from Cloud documents, Save to Cloud, File Roaming, Share File, Export to PDF, Export to Picture, ...
On the third line:(there are icons but when my cursor is over them this appears) Open, Save, Export to PDF, Print, Print Preview, ...

SO PLEASE USING THE ABOVE TELL ME HOW TO UNLOCK THE FILE SO I CAN CONTINUE EDITING.

Re: Locked for editing

PostPosted: Sun Oct 08, 2017 10:51 pm
by RoryOF
Close OpenOffice. Enable viewing of Hidden files (this is an operating system command, nit an OpenOffice command - look it up if in any doubt) and delete any filename in the target Save directory with a name similar to
Code: Select all   Expand viewCollapse view
.~lock.MyFile.odt#


Note that such file(s) will be small - perhaps a few hundred bytes, whereas the owning file will be at least 6 KB in size. Do not delete the wrong file.

Re: Locked for editing

PostPosted: Mon Oct 09, 2017 2:38 pm
by Bill
alanjones10 wrote:On the top line I see: Writer, Home, Insert, Page Layout, References, ...
On the second line: Open from Cloud documents, Save to Cloud, File Roaming, Share File, Export to PDF, Export to Picture, ...
On the third line:(there are icons but when my cursor is over them this appears) Open, Save, Export to PDF, Print, Print Preview, ...

Where did you get "Open Office 3.1"? The official version 3.1 was OpenOffice.org 3.1 and the current official version is Apache OpenOffice 4.1.3. I've never seen what you have described on the top line and second line in an official version and the third line should start with a "New" icon. To upload a screen shot, click "Upload attachment" which appears below the editing box when you post a reply.