OpenOffice crashes on startup

Discuss setup / installation issues - Add a spell checker, Language pack?

OpenOffice crashes on startup

Postby gohead8 » Tue Aug 14, 2012 5:24 pm

Open office 3.4 crashes on startup. It always wants to do a document recovery. Any ideas?? :(
Open Office 3.4 on windows 7
gohead8
 
Posts: 2
Joined: Tue Aug 14, 2012 5:21 pm

Re: Open office crashes on startup

Postby Greengiant224 » Tue Aug 14, 2012 11:25 pm

Have you done a search for AOO/LO crashes?

Have you re-set your user profile?

Linux 2.6.38, KDE 4.9.2, LibreOffice 3.5.* (Java 1.6.0_35) utilising HSQL 1.8.10 & 2.3.*, MySQL, PostgreSQL, SQLite
+ Blood, Sweat and Tears (Application, Determination and Perseverance)
User avatar
Greengiant224
 
Posts: 185
Joined: Wed Jun 09, 2010 3:50 pm
Location: All Over The World

Re: OpenOffice crashes on startup

Postby Hagar Delest » Wed Aug 15, 2012 11:03 am

See: how to reset your OpenOffice user profile.

Please add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OpenOffice crashes on startup

Postby gohead8 » Wed Aug 15, 2012 5:13 pm

Thanks for the response. Yes, I have uninstalled, re-installed, changed my user profile, but it still crashes. The program is unusable. This is a new computer running Windows 7. My old computer running XP worked well with version 3.1. Any more ideas??
Open Office 3.4 on windows 7
gohead8
 
Posts: 2
Joined: Tue Aug 14, 2012 5:21 pm

Re: OpenOffice crashes on startup

Postby Hagar Delest » Wed Aug 15, 2012 5:15 pm

What security application do you use? Comodo is known to get too aggressive on AOO.
Else, just go through the recovery process, I've faced this under XP and after 5 or 6 times, it stopped doing this.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OpenOffice crashes on startup

Postby Geoff_T » Wed Aug 15, 2012 8:58 pm

Hi

I have the same problem and it never happened on any prior version... just the version 3.4

I am using a fairly recent 64bit HP OmniPC with 8GB RAM and running Windows 7

The program always starts with data recovery and that data, usually a word processor is so unstable it will crash if I print or attempt to scroll a 12 or so page document.

I can close the program and, even as I type this, a window will pop up saying it crashed and will recover, but that window is non-responding and needs task manager to close.

It's very frustrating... I have downloaded, re-installed until the cows come home but it still behaves this way...

Any suggestions would be appreciated
Open Office 3.4 running on 64bit HP PC with Windows 7
Geoff_T
 
Posts: 3
Joined: Wed Aug 15, 2012 8:44 pm

Re: OpenOffice crashes on startup

Postby Hagar Delest » Wed Aug 15, 2012 10:21 pm

Try to go through the recovery process even if it takes 5 to 6 times. I faced that also and once you go through, it seems to work fine.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OpenOffice crashes on startup

Postby Geoff_T » Wed Aug 15, 2012 11:01 pm

I wish it was that simple.... every file seems to want recovery, even files I previously recovered. I have never had an issue with any prior Open Office version and would love a link (that did not come from a third party with advertising junk) so I could dump this 3.4 and download a super reliable earlier version...
Open Office 3.4 running on 64bit HP PC with Windows 7
Geoff_T
 
Posts: 3
Joined: Wed Aug 15, 2012 8:44 pm

Re: OpenOffice crashes on startup

Postby Hagar Delest » Wed Aug 15, 2012 11:20 pm

AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OpenOffice crashes on startup

Postby Geoff_T » Thu Aug 16, 2012 12:41 am

Hi, Well that seemed a good idea. I uninstalled 3.4 and installed the 3.2 in your link.

I am certain this program hates me because, if I open the basic screen icon or open a existing file, it says it will take me through the registration process, puts my name up, asks if I want to register (no field for already registered), tells me to click on finish and then the window closes and nothing happens. As I am a business user the inability to either open files or open and suffer crashes seems unduly worrying.

There's nothing on this computer should worry it... it's just since downloading 3.4 nothing works right.

Help!!!!
Open Office 3.4 running on 64bit HP PC with Windows 7
Geoff_T
 
Posts: 3
Joined: Wed Aug 15, 2012 8:44 pm

Re: OpenOffice crashes on startup

Postby Bill » Thu Aug 16, 2012 3:37 am

Did you reset your user profile before uninstalling AOO 3.4 and installing OOo 3.2? Downgrading to an earlier version without resetting the user profile is almost guaranteed to cause problems.
Bill
 
Posts: 3322
Joined: Sat Nov 24, 2007 6:48 am

Re: OpenOffice crashes on startup

Postby Pongo » Tue Aug 21, 2012 9:27 pm

I have a similar problem, but not quite the same one. I can open Swriter, but if I try to do pretty much anything beyond that (I started out trying to combine a couple of files) it freezes up. I've tried uninstalling and reinstalling, and I've tried renaming the profile. No good.

I'm running version 3.4 on Windows 7, and until today it had been running like a top. The only change in my system is that I started using Chrome.
OOo 2.4.X on MS Windows Vista
Pongo
 
Posts: 2
Joined: Mon Sep 29, 2008 10:40 pm

Re: OpenOffice crashes on startup

Postby Hagar Delest » Sun Sep 02, 2012 4:14 pm

Once you go through some 5 or 6 crashes, does it still happen?
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OpenOffice crashes on startup

Postby l.pastorello » Thu Sep 13, 2012 2:54 pm

Hi,
I had the same problem (this is the 3rd installation i have this problem), this issue happens when openoffice tries to connect to Internet.
It's no matter about reinstall, clean profile or registers, the problem is about date: Openoffice looks at system date, then tries to connect on startup for searching updates and crashes.

this error occurred many times, also in older OpenOffice versions, I solved the problem in this way:

- go to Tools > Options > Openoffice.org > Online updates (something about update, i have OpenOffice in Italian, not sure about translation in EN)
- disable online updates

Another strange issue is about "Tools > Options > Openoffice.org > Internet > Proxy"
When you're under this bug (online updates), it automatically crashes when you click on this tab. (i disabled also proxy, not sure if this helps)
When i disabled automatic updates i noticed this fields in proxy tab filled with strange chars:
Image

Although, after disabling internet updates, you can also
- check for internet updates manually
- reactivate updates safely

...until the day you will get the same bug, then you have to disable updates again :)
OpenOffice 3.4.1 on Windows 7
l.pastorello
 
Posts: 3
Joined: Thu Sep 13, 2012 2:20 pm

Re: OpenOffice crashes on startup

Postby kingfisher » Fri Sep 14, 2012 12:36 am

I don't know the Italian term but in 'Proxy' I have the selection 'System' which must be the default. With that setting the other boxes are blank.

The update tool has always been a source of trouble. I don't understand why it is retained. However, your setting is stored in your profile folder and should not be altered (I expect) when and if you update.
OpenOffice 3.3 on PCLinuxOS. There are 3 kinds of people: those who can count and those who can't.
User avatar
kingfisher
Volunteer
 
Posts: 1861
Joined: Tue Nov 20, 2007 10:53 am

Re: OpenOffice crashes on startup

Postby l.pastorello » Fri Sep 14, 2012 11:16 am

"Nessuno" means "none" in italian, and if i select "System" strange chars remain the same.
...and openoffice just crashed 5min ago, when i tried to see in "Tools > Options > Openoffice.org > Internet > Proxy" which option was selected.

I tried to reproduce the error and i found a way:
- i deleted user profile folder (just to reset)
- every time i tried to go to "Tools > Options > Openoffice.org > Internet > Proxy" or "Tools > Options > Openoffice.org > Internet > Search" Openoffice crashed

so i found a workaround:
- select any another tab in the option
- press ok in that tab
- exit the program

When i reopened Openoffice i had no problems with proxy tab, but this time strange characters changed again, i think that is a problem about initialization of last opened tab in "Tool > Options".
No matter about my user profile, i had no personal settings on this installation, so actually i don't rely on it :)
Last edited by RoryOF on Fri Sep 14, 2012 12:05 pm, edited 1 time in total.
Reason: corrected sundry typos for greater clarity [RoryOF, Moderator]
OpenOffice 3.4.1 on Windows 7
l.pastorello
 
Posts: 3
Joined: Thu Sep 13, 2012 2:20 pm

Re: OpenOffice crashes on startup

Postby Hagar Delest » Fri Sep 14, 2012 12:33 pm

l.pastorello wrote:I tried to reproduce the error and i found a way:
- i deleted user profile folder (just to reset)
- every time i tried to go to "Tools > Options > Openoffice.org > Internet > Proxy" or "Tools > Options > Openoffice.org > Internet > Search" Openoffice crashed

No problem with that on XP with 3.4.1.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OpenOffice crashes on startup

Postby kingfisher » Sat Sep 15, 2012 12:49 am

Could this be the Skype issue or related to the web browser?
OpenOffice 3.3 on PCLinuxOS. There are 3 kinds of people: those who can count and those who can't.
User avatar
kingfisher
Volunteer
 
Posts: 1861
Joined: Tue Nov 20, 2007 10:53 am

Re: OpenOffice crashes on startup

Postby l.pastorello » Thu Sep 20, 2012 3:53 pm

I don't know if this is a problem realted to skype or windows7. AVG Free and Skype are always running in background when i use OOo, but browsers aren't always running (i use IE, Firefox, Safari, Chrome and Opera because i need them all for my job).
The most important thing is to check if everyone that have this problem can resolve this issue disabling updates.

I'm an open office user since 2004-2005 and this isn't the first time i have this problem related to sudden continuos crash on startup, i used OOo also on linux but this problem happened only under windows xp, windows me and finally this year on windows7.
So i decided to open a forum account and post it.
OpenOffice 3.4.1 on Windows 7
l.pastorello
 
Posts: 3
Joined: Thu Sep 13, 2012 2:20 pm

Re: OpenOffice crashes on startup

Postby Gary2012 » Fri Oct 05, 2012 9:53 pm

If you are attempting to use Apache OpenOffice 3.4.1 on a Windows 7 operating system you may consider removing the suite and downloading a previous version, perhaps 3.3 or lower from http://www.openoffice.org/download/legacy/index.html When running for first time use the Windows Action Center to grant extended permissions to the soffice.exe file, test it, and keep it like that. You might also want to ensure the quickstarter is shut off as well as it may cause multiple instances of itself to run and conflict with itself or lock your files as "in use" by itself.
OpenOffice 3.3 on Win 7
Gary2012
 
Posts: 3
Joined: Wed Oct 03, 2012 3:17 pm

Re: OpenOffice crashes on startup

Postby e-Mule » Sat Oct 06, 2012 9:55 pm

Well, I rolled back to 3.3.x after 3.4.0 kept crashing (Windows 7). I installed 3.4.1 and am in the process of rolling back again for the same reason.

Strike 2. One more, and I move on.
OpenOffice 3.3
Windows 7 Professional, 64-bit
User avatar
e-Mule
 
Posts: 3
Joined: Tue Jul 17, 2012 10:21 pm
Location: North Carolina

Re: OpenOffice crashes on startup

Postby Hagar Delest » Sat Oct 06, 2012 9:59 pm

Had you reset your profile? Pretty necessary with 3.4.x it seems.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: OpenOffice crashes on startup

Postby e-Mule » Thu Oct 11, 2012 3:46 am

Unfortunately, I don’t really have time to spend on this. I’ve done beta testing before, and I wish I had time to spare to still do that. But at this point, I need applications to work when I launch them.

I’ll stick with 3.3 for the foreseeable future. If there comes a point where there is something I absolutely must have, I'll try again.
OpenOffice 3.3
Windows 7 Professional, 64-bit
User avatar
e-Mule
 
Posts: 3
Joined: Tue Jul 17, 2012 10:21 pm
Location: North Carolina

Re: OpenOffice crashes on startup

Postby Gary2012 » Sun Oct 14, 2012 11:26 pm

Well that's too bad. Apache Open Office has a lot of potential but not much support. As a last resort you can try downloading the Oct release of Libre Office. Before installing totally remove Apache OO, then the OO profile under AppsData Roaming, then run CCleaner on the registry to remove unused entries. Reboot then install LibreOffice. That sometimes works.
OpenOffice 3.3 on Win 7
Gary2012
 
Posts: 3
Joined: Wed Oct 03, 2012 3:17 pm

Re: OpenOffice crashes on startup

Postby Bill » Sun Oct 14, 2012 11:42 pm

Gary2012 wrote:Well that's too bad. Apache Open Office has a lot of potential but not much support. As a last resort you can try downloading the Oct release of Libre Office. Before installing totally remove Apache OO, then the OO profile under AppsData Roaming, then run CCleaner on the registry to remove unused entries. Reboot then install LibreOffice. That sometimes works.

I haven't had any luck with LO. I've had one crash of OOo/AOO since LO was first released, but every time I've installed LO it's crashed within 2 days of installation. I always completely remove old versions with Revo Uninstaller, reset the user profile and run CCleaner before installing new versions.
Bill
 
Posts: 3322
Joined: Sat Nov 24, 2007 6:48 am

Re: OpenOffice crashes on startup

Postby Jake5577 » Mon Oct 15, 2012 3:36 am

I tried the workarounds to get 3.4.1 to stop crashing, such as creating a new user folder and disabling automatic updates. I uninstalled and reinstalled it several times. It was still crashing and locking up my computer. I went back to OpenOffice 3.3.
OpenOffice 3.3 on Windows XP Professional
Jake5577
 
Posts: 1
Joined: Mon Oct 15, 2012 3:32 am

Re: OpenOffice crashes on startup

Postby Bill » Mon Oct 15, 2012 9:34 am

If AOO crashes on every startup, use Process Monitor to troubleshoot.
Bill
 
Posts: 3322
Joined: Sat Nov 24, 2007 6:48 am

Re: OpenOffice crashes on startup

Postby Bob Hadley » Mon Oct 29, 2012 8:52 pm

In addition to turning off the automatic updates I have followed some of the advice above and removed the weird characters from the Proxy fields in the Tools/Options/Internet boxes. When I went back into OO and asked to "Check for Updates" I did not get the Internet failure error again. I'm more convinced than ever that this problem has its roots in the Internet updates area.
OpenOffice 3.4.1 on Windows 7
Bob Hadley
 
Posts: 2
Joined: Mon Oct 29, 2012 6:08 pm

Re: OpenOffice crashes on startup

Postby c3k » Wed Oct 31, 2012 4:34 pm

I have the same problem

found this thread too: viewtopic.php?f=15&t=55017

libreoffice have too (patched now!): https://bugs.freedesktop.org/show_bug.cgi?id=47044
OpenOffice 3.4.1 on Windows 7 64bit
c3k
 
Posts: 1
Joined: Wed Oct 31, 2012 4:18 pm

Re: OpenOffice crashes on startup

Postby paiming » Tue Nov 13, 2012 11:44 pm

I have followed the instruction to change user profile by : click Start and type %appdata% in the Search box. Click "Roaming" but cannot fine user name to change ??
OpenOffice3.3 on window 7
paiming
 
Posts: 4
Joined: Fri Dec 02, 2011 9:23 pm

Next

Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: uible and 12 guests