[Issue] Disable ASCII filter

Discuss setup / installation issues - Add a spell checker, Language pack?

[Issue] Disable ASCII filter

Postby qweqweqwe » Mon Aug 06, 2012 4:10 pm

Windows XP, AOO 3.4 (fresh download)
I want to open text file without the need of confirmation of default settings in ASCII filter everytime. There is no corruption, files work in both Notepad and OO.
No file is provided as all files are created by OS, there is no special file to be sent.

model 1 : freshly created .txt file - open with - openoffice writer -> results in ASCII filter being shown
model 2 : freshly created .txt file - open with - openoffice.org 3.4 -> results in file opened in writer without the need of any confirmation

when i type inside normal characters (example a,b,c, ...) or even national characters (example ě,š,č, ...) same behavior to empty file happens as described above.

Now, that text file has different extension from standard .txt - for sake of example say .abc in my case - and behavior model 1 is happening and i would like to switch it to model 2, and i hope you can tell me where can such behavior be set or even if it can be set. Its highly annoying working with this great tool and be unable to switch this off and to click "ok" everytime i want to work with some file of that type.

What i am looking for is something along these options :
1) turn off the ASCII filter totally, no matter what file i associate with AOO (or writer) it will try to open it as plain text file (dumb, but brute force option to confirm already default options offered, direct access to file in editor)

2) tell AOO somewhere in options (and i havent found where) which formats (.abc) should be considered known/text files and what ASCII filter to use on them

Thanks for any help
Last edited by Hagar Delest on Sun Sep 02, 2012 4:12 pm, edited 1 time in total.
Reason: tagged [Issue] (link to a bug report).
OpenOffice 3.4 on Windows XP
qweqweqwe
 
Posts: 6
Joined: Mon Aug 06, 2012 3:44 pm

Re: Disable ASCII filter

Postby RoryOF » Mon Aug 06, 2012 4:25 pm

As far as I remember this has come up several times (use forum search at top right of forum screen to search for Disable ASCII filter) and led to several very long and acrimonious threads, There is to best of my knowledge no way to disable the filter mechanism. Perhaps OpenOffice may not be the best editor if frequent plain text files are to be opened.
Apache OpenOffice 4.1.7 on Xubuntu 18.04.3 (mostly 64 bit version) and very infrequently on Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 29484
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Disable ASCII filter

Postby qweqweqwe » Mon Aug 06, 2012 4:54 pm

I did search them already before posting and none of them happened to be close to my one. Most were corrupted files, few PDF related and best one is still unsolved and not entirely on my topic either.

Also, i have another laptop with WXP, OOo 3.0.1 (OOO300m15, build 9379) and on this one, i dont have such problem. Everything is working as in model 2. So it is possible (and i dont think versioning up changed it) and i just wanted to get the same behavior on my other PC. I uninstalled everything OOo related in hope it will solve my issue, installed latest (AOO 3.4) and here i am.
OpenOffice 3.4 on Windows XP
qweqweqwe
 
Posts: 6
Joined: Mon Aug 06, 2012 3:44 pm

Re: Disable ASCII filter

Postby Hagar Delest » Mon Aug 06, 2012 4:58 pm

If this is a regression, you should file a report: [Tutorial] Reporting bugs or suggestions.
NB: I see the same with AOO 3.4.0 on XP.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28543
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Disable ASCII filter

Postby qweqweqwe » Mon Aug 06, 2012 5:51 pm

I dont think it is a regression, more like option that isnt really related with this and gets overlooked somewhere in preferences. If i knew where it can be disabled in 3.1 i wouldnt be here in first place.

I tried to mess with my laptop a bit to see if its my option 1, as that would indicate some sort of prefference setting being off. I renamed my file that wasnt .txt (it was .ptk actually) to testing extension (.asd i think). As there is no program associated with this, i opened it with OOo 3.1 (remember, its laptop) and it showed ASCII filter request. I changed the extension back and now its showing it even on my .ptk, which previously didnt show it. I am getting more desperate here every time i try to fix it.

I dont understand what you are trying to say with your next sentence (starting NB).

Anyway, the difference in behavior when trying to open with swriter.exe and with soffice.exe in my first post on simple txt should indicate where to look for solution, but i cant decode that.
OpenOffice 3.4 on Windows XP
qweqweqwe
 
Posts: 6
Joined: Mon Aug 06, 2012 3:44 pm

Re: Disable ASCII filter

Postby Hagar Delest » Mon Aug 06, 2012 9:39 pm

qweqweqwe wrote:I dont understand what you are trying to say with your next sentence (starting NB).

I just say that the behavior is the same on my system. So it's not specific to your machine, it's something with AOO.

qweqweqwe wrote:Anyway, the difference in behavior when trying to open with swriter.exe and with soffice.exe in my first post on simple txt should indicate where to look for solution, but i cant decode that.

Then file a bug report and you'll get an answer from the devs. Or ask on their mailing list (see the support web page). I remember some change in AOO or OOo 3.3.0 about that. Or perhaps it was only for Calc.
AOO 4.1.6 on Xubuntu 19.04 and 4.1.5 on Windows 7 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28543
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Disable ASCII filter

Postby acknak » Mon Aug 06, 2012 10:44 pm

qweqweqwe wrote:... No file is provided as all files are created by OS, there is no special file to be sent ...

It might still be helpful to see a sample of your file. In the post-ascii days, there is no longer any such thing as a "plain text file."

... I want to open text file without the need of confirmation of default settings in ASCII filter everytime. ...

As far as I can see with a quick test, it isn't possible to do this for files named other than *.txt.

I believe, but I could well be wrong, that it is not possible to read an arbitrary file, when you do not know the file type ahead of time, without corrupting it. So, to be sure that it doesn't guess wrong and possibly destroy someone's data, OOo simply punts and asks the user to tell it what to do.

If you explicitly tell OOo that this is a pure text file by setting the file type to "Text (*.txt)" in the open file dialog, and the file is indeed a "normal" sort of text file, then OOo should read the file without asking any questions.

If you need to edit text files, it's best to use a text editor. :mrgreen:
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: Disable ASCII filter

Postby Robert Tucker » Mon Aug 06, 2012 11:20 pm

There is a macro insertCSV2Calc here:

viewtopic.php?f=45&t=12835

which it says "automates the process of importing a same-structured file to a calc sheet: someone saves the time to go through the same import options dialogue again."

I think the information here:

http://wiki.services.openoffice.org/wik ... tarDesktop

provides most of what is needed to understand the core working of the macro. It should be possible to use com.sun.star.beans.PropertyValue and loadComponentFromURL for Writer documents?
LibreOffice 6.x.x on Fedora 30 and Ubuntu 19.04 (Dual Boot)
User avatar
Robert Tucker
Volunteer
 
Posts: 1247
Joined: Mon Oct 08, 2007 1:34 am
Location: Manchester UK

Re: Disable ASCII filter

Postby kingfisher » Tue Aug 07, 2012 2:15 am

In Tools > Options > Writer > Compatibility I see (with a 'plain' text document open) a button labelled 'Use as default'. I have no idea what effect that may have but perhaps it would help.

I see no problem with the filter requirement. It has never occurred to me until now to open a 'plain' text document with Writer. I can understand not wanting to use Notepad. Perhaps a better text editor is available for Windows.
Apache OpenOffice 4.1.6 on PCLinuxOS
User avatar
kingfisher
Volunteer
 
Posts: 2120
Joined: Tue Nov 20, 2007 10:53 am

Re: Disable ASCII filter

Postby qweqweqwe » Tue Aug 07, 2012 2:38 am

acknak wrote:It might still be helpful to see a sample of your file. In the post-ascii days, there is no longer any such thing as a "plain text file."

Yeah, i might be a tad more specific. Its WXP create new text file. It creates empty (0 bytes) shell of file of some predefined name. As i cant upload empty files on MF, here is my file with 5 "a" chars (5 byte file). No formating whatsoever, plain text.

http://www.mediafire.com/file/jb72o6dd60ilvvi/test.txt
acknak wrote:I believe, but I could well be wrong, that it is not possible to read an arbitrary file, when you do not know the file type ahead of time, without corrupting it. So, to be sure that it doesn't guess wrong and possibly destroy someone's data, OOo simply punts and asks the user to tell it what to do.

I am not sure if opening with wrong settings can corrupt the file. Anyway, all i am asking is some way to opt out this nagging box. I can understand why its there, but when you use default settings and all you have to do is to click ok everytime, its not really helping me anymore.

acknak wrote:If you explicitly tell OOo that this is a pure text file by setting the file type to "Text (*.txt)" in the open file dialog, and the file is indeed a "normal" sort of text file, then OOo should read the file without asking any questions.

I cant. This file (and extension) is created by different program with Notepad as external editor and any other solution requires more interraction than clicking ok, which isnt the way i want to go. I want to simplify things :).

acknak wrote:If you need to edit text files, it's best to use a text editor. :mrgreen:

Probably, but i was really hoping this can be solved so i dont need to use 5 different text editors. OO should be enough to do this job. And it can, just need to get rid of that ASCII filter.
OpenOffice 3.4 on Windows XP
qweqweqwe
 
Posts: 6
Joined: Mon Aug 06, 2012 3:44 pm

Re: Disable ASCII filter

Postby thomasjk » Tue Aug 07, 2012 5:14 am

Double clicking your test.txt file opens it in Writer with LO 3.5.5.3. Using Right click and Open with Calc of course brings up the ASCII filter.
Tom K.
Windows 10 Home version 1803 17134.165
LibreOffice 5.4.7.2
thomasjk
Volunteer
 
Posts: 4408
Joined: Tue Dec 25, 2007 4:52 pm
Location: North Carolina

Re: Disable ASCII filter

Postby qweqweqwe » Tue Aug 07, 2012 11:03 am

Hagar Delest wrote:Then file a bug report and you'll get an answer from the devs. Or ask on their mailing list (see the support web page). I remember some change in AOO or OOo 3.3.0 about that. Or perhaps it was only for Calc.
I will try to find the changelog for OOo/AOO 3.3.0 first, to see if there was such change. I want to bother devs as last resort.

Robert Tucker wrote:There is a macro insertCSV2Calc here: -snip-
provides most of what is needed to understand the core working of the macro. It should be possible to use com.sun.star.beans.PropertyValue and loadComponentFromURL for Writer documents?

As this looks promising, there are few problems from my point of view ( as i have to admit i dont fully understand what would have to be changed to get the behavior on simple opening file with given extension, some coding of AOO ?). Anything that requires more interaction than clicking ok on ASCII filter on file open isnt improvement for me, but if this can be automated for *.whateverextension via some code change, i would go for it.

kingfisher wrote:In Tools > Options > Writer > Compatibility I see (with a 'plain' text document open) a button labelled 'Use as default'. I have no idea what effect that may have but perhaps it would help.

I see no problem with the filter requirement. It has never occurred to me until now to open a 'plain' text document with Writer. I can understand not wanting to use Notepad. Perhaps a better text editor is available for Windows.

Dindnt help, its probably only to use given setting above as default, has no effect on whether ASCII filter is shown. Problem is in convenience. I am opening same type of files (text) with different extension and its prompting me if i want to use default settings. I want it to use default settings as default. As said few times now, there is no reason to use Notepad when AOO is installed and used for everything else.

thomasjk wrote:Double clicking your test.txt file opens it in Writer with LO 3.5.5.3. Using Right click and Open with Calc of course brings up the ASCII filter.
I am not using LibreOffice, yet if it would solve this i will gladly use it. For the type of work i am doing with this there are no major differences.
Also, i am opening it with Writer, not Calc. Double clicking means i need to associate program first (otherwise it would open in Notepad as default txt editor) - with swriter - ASCII filter shown, with soffice - no ASCII filter shown and file opened immediately. Thats what i am aiming for.
OpenOffice 3.4 on Windows XP
qweqweqwe
 
Posts: 6
Joined: Mon Aug 06, 2012 3:44 pm

Re: Disable ASCII filter

Postby dj christian » Thu Aug 09, 2012 11:35 pm

Easy change to Libre Office. Oracle dumped OpenOffice and let it rot.

I've already changed to LO. Couldn't stand the ASCII filter window showing up everytime.
OpenOffice 3.3.0 Windows 7 64-bit
dj christian
 
Posts: 4
Joined: Tue May 08, 2012 1:26 am

Re: Disable ASCII filter

Postby qweqweqwe » Thu Aug 23, 2012 1:34 pm

Will try LibreOffice and report back with result, thanks for suggestion.

EDIT : It didnt help really, LO has same behavior as AOO in this case. I will have to search bug/request tracker and probably contact developers (found similar request https://issues.apache.org/ooo/show_bug.cgi?id=93578 )
OpenOffice 3.4 on Windows XP
qweqweqwe
 
Posts: 6
Joined: Mon Aug 06, 2012 3:44 pm

Re: [Issue] Disable ASCII filter

Postby dcapn88 » Fri Jun 29, 2018 9:42 pm

Looks like nobody has solved this issue (now it's 4 years since the last blog entry). If anybody has a solution or is still trying to find one, please post here. Thanks :bravo:
OpenOffice 4.1.0 on Windows7 Home
dcapn88
 
Posts: 5
Joined: Wed Jun 18, 2014 8:07 pm


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 5 guests