Auto spell checker does not work

Discuss setup / installation issues - Add a spell checker, Language pack?

Auto spell checker does not work

Postby jlallen32460 » Wed Jun 13, 2012 9:28 pm

Do you see the blue check mark in the general setting panel?

No -> : Make sure you have closed OOo, the Quickstarter (OOo icon in system tray) and restarted OOo.
NB: in some rare cases, you have to untick, then retick the Hunspell Spellchecker option (Tools > Options > Language Settings > Writing Aids) before closing and restarting the application.
Huh? Where is this?

Do you see the correct language (with the blue check mark) for Default paragraph style?
NO, did this and no blue check mark.

Is the spell checking button highlighted in the toolbar?
Yes, go to next post.

Is the language the correct one?
Where is the styles button? I don't see it and there is no option to clear formatting. The bottom of my document looks like the screen shot, but my thesaurus and spell checker are still not working.

Let's test the attached file: you should see the red wavy lines in certain places
No, it did not work. No wavy red lines, at all and when I clicked on the spell check button, it did not spell check it.

Have you restarted OOo?
What does this mean? I am not in open office, and what is a splash screen? What is Quickstarter? Where is the download for the dictionary?

I am now on my third hour of trying to fix this issue. I bought my Open office, the version is 3.3, My OS is windows 7, I did a system restore to before I did the update to 3.4. I am NOT a programmer! I need this to work, I start classes on July 2, and I MUST have this working! I am about to pull my hair out PLEASE HELP.

Jody
OpenOffice home student and professional 2010 2012 for Microsoft Windows. OS is Windows 7
jlallen32460
 
Posts: 10
Joined: Wed Jun 13, 2012 7:23 pm

Re: Auto spell checker does not work, PLEASE HELP

Postby RoryOF » Wed Jun 13, 2012 9:37 pm

We are helping. There is nearly three weeks to 2nd July, so stop panicking. Note that advice given on this Forum is offered by volunteers in their own free time; they are all around the world and you may have to wait until someone who is interested in your problem or has knowledge of it comes on line. While you wait for help, forget about your spell-check and thesaurus problems, and concentrate on finding out how other areas of the program work. Read some of the tutorials on the Forum. And bear in mind that part of education is learning to spell and select words.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14370
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Auto spell checker does not work, PLEASE HELP

Postby thomasjk » Wed Jun 13, 2012 9:38 pm

Where did you buy your Openoffice? This is is free application available here http://www.openoffice.org. I've never seen a product called OpenOffice home student and professional 2010 2012 for Microsoft Windows.
Tom K.
Windows 7 Home Premium
LibreOffice 4.2.3.3
thomasjk
Moderator
 
Posts: 3602
Joined: Tue Dec 25, 2007 4:52 pm
Location: North Carolina

Re: Auto spell checker does not work

Postby Hagar Delest » Wed Jun 13, 2012 10:29 pm

jlallen32460 wrote:Tools > Options > Language Settings > Writing Aids

It means go to the menu Tools, then select the Options entry and so on.
NB: to go a step ahead, you need to pass the previous ones! Once there is one wrong, the others will fail.

Please make you comfortable with the user interface and the terms (styles, ...).
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Auto spell checker does not work

Postby jlallen32460 » Wed Jun 13, 2012 10:36 pm

I did all the steps you Hagar have in your turorial, and it still is not working. I did what you said to start a new thread. I began at step one and did what I could understand and find per your directions. Still not working. The auto corrector marks words that are spelled correctly. I downloaded the dictionary, I think, can't find it and it did not fix the issue. I removed the OpenOffice program, went to the web page http://www.openoffice.org. Downloaded it again, and the problem is still there. Now what?

Jody
OpenOffice home student and professional 2010 2012 for Microsoft Windows. OS is Windows 7
jlallen32460
 
Posts: 10
Joined: Wed Jun 13, 2012 7:23 pm

Re: Auto spell checker does not work

Postby Hagar Delest » Wed Jun 13, 2012 10:53 pm

Go to the extension manager (Tools>Extension manager). If several English dictionaries, remove all of them. Close AOO and the quickstarter (blue icon in the system tray).
Then go to the extension manager again and click the Add button and double click the dictionary (.oxt) that you have downloaded. Then restart again AOO and make sure you see the blue check mark.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Auto spell checker does not work

Postby jlallen32460 » Wed Jun 13, 2012 10:58 pm

I just did that for the third time, and now there are no dictionarys listed at all. I went to the down load area, clicked get it, and nothing happens. I have put my norton in silent mode and that has not helped. Now what?

Jody
OpenOffice home student and professional 2010 2012 for Microsoft Windows. OS is Windows 7
jlallen32460
 
Posts: 10
Joined: Wed Jun 13, 2012 7:23 pm

Re: Auto spell checker does not work

Postby Hagar Delest » Wed Jun 13, 2012 11:07 pm

Have you managed to save the .oxt file on your HD?

Have you use that page: http://extensions.services.openoffice.o ... en_US-dict ?
After clicking, you should be redirected to the sourceforge site and after a short time you should be prompted to save the file somewhere.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Auto spell checker does not work

Postby jlallen32460 » Wed Jun 13, 2012 11:15 pm

Yes, 5 times now. Where do I save it. It does not ask.
OpenOffice home student and professional 2010 2012 for Microsoft Windows. OS is Windows 7
jlallen32460
 
Posts: 10
Joined: Wed Jun 13, 2012 7:23 pm

Re: Auto spell checker does not work

Postby Hagar Delest » Wed Jun 13, 2012 11:20 pm

Up to you. Open the history manager of your browser and make sure it has not been saved somewhere already.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Auto spell checker does not work

Postby jlallen32460 » Wed Jun 13, 2012 11:28 pm

When I go to Start, search for programs I type in dict-en.oxt. I get the following message; C:\user\Jody\AppData\Roaming\OpenOffice.org\3\user\uno_package\cashe\uono_packages\svs9g5v1.tmp_\dict-en.oxt does not exist, but there are 5 versions on my computer. Now what?
OpenOffice home student and professional 2010 2012 for Microsoft Windows. OS is Windows 7
jlallen32460
 
Posts: 10
Joined: Wed Jun 13, 2012 7:23 pm

Re: Auto spell checker does not work

Postby jlallen32460 » Wed Jun 13, 2012 11:31 pm

Over my head. Browser history?
OpenOffice home student and professional 2010 2012 for Microsoft Windows. OS is Windows 7
jlallen32460
 
Posts: 10
Joined: Wed Jun 13, 2012 7:23 pm

Re: Auto spell checker does not work

Postby Hagar Delest » Wed Jun 13, 2012 11:33 pm

Move one of those 5 versions to your document folder and then install it with the AOO extension manager.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Auto spell checker does not work

Postby RoryOF » Wed Jun 13, 2012 11:36 pm

Note where are the five versions. Most probably they are in a directory called Downloads, possibly under a path similar to c:\Documents and Settings\Jody\something\something\Downloads and flagged as dict-en.oxt through dict-en.oxt(4) (I'm not on a Win 7 computer and don't know which browser you use, so cannot be exact). Now open your OpenOffice writer and point \Tools \Extension Manager to one of these using the Add button and navigating the file selection box to the appropriate directory and file.
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14370
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland

Re: Auto spell checker does not work

Postby jlallen32460 » Wed Jun 13, 2012 11:44 pm

Found it, and followed your directions, the error message again, extension manager not responding. When I go to the download page, do I select save or run?
OpenOffice home student and professional 2010 2012 for Microsoft Windows. OS is Windows 7
jlallen32460
 
Posts: 10
Joined: Wed Jun 13, 2012 7:23 pm

Re: Auto spell checker does not work

Postby Hagar Delest » Wed Jun 13, 2012 11:56 pm

Save. But if you've downloaded the .oxt file already, no need to do it again.

BTW, have you installed AOO 3.4? your signature says "OpenOffice home student and professional 2010 2012 for Microsoft Windows". If it is not the case, then remove that application and download it from the website (see link bottom right of the page).
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25105
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Auto spell checker does not work

Postby Bill » Thu Jun 14, 2012 12:00 am

jlallen32460 wrote:Over my head. Browser history?

Press CTRL+J to open the downloads window.
Bill
 
Posts: 3320
Joined: Sat Nov 24, 2007 6:48 am

Re: Auto spell checker does not work

Postby jlallen32460 » Thu Jun 14, 2012 12:24 am

Hagar, Yes, I have downloaded, and removed, and downloaded it 6 times today, and the spell checker issue is still there. Thank you Bill, you understand. I removed the version I bought, I have done a system restore. I have given up on the thesaurus, I just want the spell checker to work. I deleted each of the pervious .oxt files, I think, and am trying to start fresh. No luck yet. All was fine until I downloaded the 3.4 update. I am now down loading LibreOffice, maybe that will work?
OpenOffice home student and professional 2010 2012 for Microsoft Windows. OS is Windows 7
jlallen32460
 
Posts: 10
Joined: Wed Jun 13, 2012 7:23 pm

Re: Auto spell checker does not work

Postby Bill » Thu Jun 14, 2012 1:08 am

For AOO 3.4 on 32-bit Vista, I disabled the Australian English, Canadian English and New Zealand English extensions in the Extension Manager and the Thesaurus started working. I didn't download, add or remove any dictionaries or change any settings in Writing Aids.
Bill
 
Posts: 3320
Joined: Sat Nov 24, 2007 6:48 am

Re: Auto spell checker does not work

Postby jameschuk » Sun Jul 15, 2012 12:41 am

The Problem is there are so many English ( difference country). However not every English( country) come with dictionary.
First you need to check the default language for your writer. Tools---> Options..----->Language Setting------> Languages.
Check the locale setting, change to English(UK). Because English(UK) has dictionary some of them has locale but no dictionary. for example English (Eire). that is why change Writing Aids doesn't help
I use both open office 3.2 and LibreOffice 3.5 depend on difference workstation OS. one is Ubuntu 10.04 and one is Ubuntu 12.04
jameschuk
 
Posts: 2
Joined: Sun Jul 15, 2012 12:30 am

Re: Auto spell checker does not work

Postby jameschuk » Sun Jul 15, 2012 12:52 am

Dear programmers,

I find a bit surprise the check spell function has so much problems.
I was thinking open office 3.2 may be a bit old so you guys didn't want to correct the problems. However the same problem still in Libre Office 3.5 may be a bit odd.
The problem is because when Both Open and Libre's Office took the Location of the OS for a default language. However on the list of the Dictionary there are so many ENGLISH (difference Country)'s name but no dictionary has been attached with.
I think the next version of office should simplify the English dictionary into UK and US in term of English user.
I use both open office 3.2 and LibreOffice 3.5 depend on difference workstation OS. one is Ubuntu 10.04 and one is Ubuntu 12.04
jameschuk
 
Posts: 2
Joined: Sun Jul 15, 2012 12:30 am

Re: Auto spell checker does not work

Postby kingfisher » Sun Jul 15, 2012 9:47 am

OpenOffice 3.3 on PCLinuxOS. There are 3 kinds of people: those who can count and those who can't.
User avatar
kingfisher
Volunteer
 
Posts: 1861
Joined: Tue Nov 20, 2007 10:53 am

Re: Auto spell checker does not work

Postby RoryOF » Sun Jul 15, 2012 10:25 am

jameschuk wrote:Dear programmers,

I find a bit surprise the check spell function has so much problems.
I was thinking open office 3.2 may be a bit old so you guys didn't want to correct the problems. However the same problem still in Libre Office 3.5 may be a bit odd.


There are no developers here, only users trying to help other users. Try the tutorials for the spell checker

Spell check and language configurations
Troubleshooting Spell check
Apache OpenOffice 4.0.1 on Xubuntu 13.10 and Win2K/XP
User avatar
RoryOF
Moderator
 
Posts: 14370
Joined: Sat Jan 31, 2009 9:30 pm
Location: Ireland


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 11 guests