configure: error: mscoree.lib (.NET Framework) not found

Discuss setup / installation issues - Add a spell checker, Language pack?

configure: error: mscoree.lib (.NET Framework) not found

Postby Iron_Lotus » Fri Nov 30, 2007 12:01 am

Hi,

I am trying to build OOo(2.3) with Farsi language pack for MS Windows, but when Generating the Build Environment and Build Tools I bump it to the following error:

checking the Microsoft C/C++ Compiler... found (/cygdrive/c/PROGRA~1/MICROS~1.0/
VC/bin/cl.exe)
checking the Version of Microsoft C/C++ Compiler... found Compiler version 00150
0002102.
found .NET 2005.
checking for midl.exe... /cygdrive/c/PROGRA~1/MIC977~1/Bin
checking for csc.exe... /cygdrive/c/WINDOWS/MICROS~1.NET/FRAMEW~1/V11~1.432
checking .NET Framework... Use of uninitialized value in print at ./oowintool li
ne 207.
configure: error: mscoree.lib (.NET Framework) not found. Make sure you use --wi
th-frame-home


I am using Visual C++ 9.0 (2008), I have located mscoree.lib in several locations but pointing the configuration to them has not worked so far.

Here is the command I am using:

$ ./configure --with-cl-home="/cygdrive/c/Program Files/Microsoft Visual Studio
9.0/VC" --with-jdk-home="/cygdrive/c/Program Files/Java/jdk1.6.0_02" --with-un
zip-home=/cygdrive/c/unzip --with-use-shell=4nt --with-midl-path="/cygdrive/c/P
rogram Files/Microsoft Platform SDK/Bin" --with-frame-home="/cygdrive/c/Program
Files/Microsoft SDKs/Windows/v6.0A/Lib/x64"

Not sure what to do to pass this, any help is much appreciated.

Cheers,
Iron_Lotus
Cheers,
Iron_Lotus
Iron_Lotus
 
Posts: 2
Joined: Thu Nov 29, 2007 11:57 pm

Re: configure: error: mscoree.lib (.NET Framework) not found

Postby TerryE » Fri Nov 30, 2007 2:00 am

Iron_lotus, Building OOo is petty esoteric and not something that the average user attempts to do. My first Q is why are you doing so instead of downloading the kit from OOo? But my suggestion is that the dev-digest DL is a better place to ask this type of Q. Sorry I can't help more. I build OOo under Ubuntu. :-)
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
Volunteer
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK

Re: configure: error: mscoree.lib (.NET Framework) not found

Postby Iron_Lotus » Fri Nov 30, 2007 5:42 pm

Thanks TerryE, I agree it is pretty difficult and me not being a developer makes it even worse.
The reason I am trying to build it is because I could not find a Farsi Language pack or install any where including on OOo, what I am looking to get is OOo install that includes Farsi pack.
I appreciate your help.

Cheers,
Cheers,
Iron_Lotus
Iron_Lotus
 
Posts: 2
Joined: Thu Nov 29, 2007 11:57 pm

Re: configure: error: mscoree.lib (.NET Framework) not found

Postby TerryE » Tue Dec 04, 2007 3:36 am

Have a look on the I10n projects site of OOo. They might have Farsi road mapped. Even if you are trying to do this yourself, it is worthwhile trying to network with the internationalisation team and anyone else working on Farsi. Good luck.
Ubuntu 11.04-x64 + LibreOffice 3 and MS free except the boss's Notebook which runs XP + OOo 3.3.
TerryE
Volunteer
 
Posts: 1402
Joined: Sat Oct 06, 2007 10:13 pm
Location: UK


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 4 guests