Page 1 of 1

[Solved] Changing the Default font

PostPosted: Thu Nov 29, 2007 7:16 am
by spatz
I have just installed OO 2.3 and it has as it's default font 'Liberation Serif' . I want to use 'Verdana' as my default font but when I go to Tools> Options> Fonts I just don't seem to be able to get the Default font to change . I have set it up as follows. Apply Replacement Table, replace Liberation Serif with Verdana, tick always, Font Liberation Serif replace with Verdana, Font settings for HTML and basic sources, Verdana , Size 11. Would appreciate any help to get this sorted .

Re: Changing the Default font

PostPosted: Thu Nov 29, 2007 10:49 am
by DrewJensen
If you are looking to change the default font for text documents for example you want

Tools > Options > OpenOffice.org Writer > Basic Fonts

Re: Changing the Default font

PostPosted: Thu Nov 29, 2007 5:34 pm
by Bill
The Replacement Table has a different purpose. If you receive a document which uses a font not installed on your system, OOo will substitute a font which is on your system. You can either let OOo choose the replacement font or use the Replacement Table to specify which font should be used as a replacement.

Re: Changing the Default font

PostPosted: Fri Nov 30, 2007 12:11 am
by Hagar Delest
Note that if you use a custom template, you'll need to modify the Default paragraph style of that template to configure the desired font for new documents.

Thanks to add '[Solved]' in your first post title (edit button) if your issue has been fixed.

Re: Changing the Default font

PostPosted: Fri Nov 30, 2007 1:33 am
by spatz
Thank you very much Drew . I have solved the problem now , that is exactly what I was looking for .
Rgds

Re: [Solved] Changing the Default font

PostPosted: Wed Dec 05, 2007 4:35 pm
by marco75
Interestingly, changing the default font in this manner has no effect on blank documents created through right-click > New.
(The move from application-centric to document-centric thinking required this option)

In order to make the right click menu work, you need TweakUI or TweakUIXP.

1. Start TweakUI or TweakUIXP (Anyone still using 98? How do you survive without security fixes? :| )
2. Delete the original templates.
3. Start Writer. It should create a blank document with the desired font.
4. Save as...
5. Save in: Desktop, Filename: OpenDocument text, Type: OpenDocument text
6. [optional] Since we are in a transitory phase (MS Office -> OpenDocument), also do
Save in: Desktop, Filename: Microsoft Word document, Type: Microsoft Word 97/2000/XP
7. Close Writer.
8. For TweakUI, drag the two blank documents from Desktop to the Templates field
For TweakUIXP, click Create, then select the blank document, one by one.

Done!

In Word 2000, trying to change the default font through the default template (which seems logical) is impossible -- you have to go Format > Font... , select the font, then click Default.

Interesting that Writer imitates Word to such a degree that such strange behaviour is preserved -- it makes sense to the programmers, but often not to the people who use this software.

Re: [Solved] Changing the Default font

PostPosted: Wed Dec 05, 2007 10:30 pm
by Hagar Delest
marco75 wrote:In order to make the right click menu work, you need TweakUI or TweakUIXP.

There is a quicker fix : Issue 40233 - Making a new document from a context menu doesn't use a template.

You just need to overwrite the file soffice.odt in the folder \Documents and Settings\<user>\Templates (can also be \Documents and Settings\All users\Templates IIRC).