[Solved] How to *really* turn off capitalization?

Discuss setup / installation issues - Add a spell checker, Language pack?

[Solved] How to *really* turn off capitalization?

Postby magnoliasouth » Sat Oct 24, 2009 5:26 pm

I have gone into Tools > AutoCorrect Options > Options tab and unchecked Capitalize first letter of every sentence.

That didn't work.

So I went into Tools > Options > Language Settings > Writing Aids and unchecked Check capitalization.

That also didn't work.

I don't understand what the problem is here. If I uncheck either or both of these - and really all of this should be under one option alone, no one should have to go hunting in several places - then it should do what I tell it to do. :crazy:

I realize that this is a volunteer thing and that's fine. Still though, it is very frustrating when you have the same types of options spread out all over the place and you still can't get it to do what you want.

*sigh*

Okay, so how do I really turn it off? I'm in calc and it is imperative that it stops trying to capitalize everything. I also need a way to turn the feature on and off easily and quickly without jumping through hoops because obviously there will be documents and spreadsheets where it is needed.

OO 3.1.1 on XP home SP3
Last edited by Hagar Delest on Mon Oct 11, 2010 10:12 am, edited 1 time in total.
Reason: tagged [Solved].
User avatar
magnoliasouth
 
Posts: 50
Joined: Sat Sep 06, 2008 5:32 pm

Re: How to *really* turn off capitalization?

Postby acknak » Sat Oct 24, 2009 6:04 pm

Try this: Tools > Cell Contents > Autoinput: OFF

Does that help?

If not, or if you want an explanation of what's going on, please tell us exactly what you're entering that causes the problem--the exact letters and keys that you're pressing. Also, try making the same entry in a new, empty sheet and see if you still have the same problem.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: How to *really* turn off capitalization?

Postby magnoliasouth » Mon Oct 11, 2010 2:18 am

Yes, thank you. Sorry for the terrible delay, but the day I tried posting a thanks I kept getting logged out here. I guess that issue has been fixed.
User avatar
magnoliasouth
 
Posts: 50
Joined: Sat Sep 06, 2008 5:32 pm

Re: How to *really* turn off capitalization?

Postby DonPayne » Thu Sep 18, 2014 7:53 pm

acknak wrote:Try this: Tools > Cell Contents > Autoinput: OFF

Yes, that solved my problem too, thanks!
But ... AutoInput (automatically guessing my input based on data in cells above) is often handy. Do you have any idea why I have to turn off AutoInput in order to get OO Calc to accept input in the case in which I entered it? Is this a known problem?
There is another forum thread https://forum.openoffice.org/en/forum/viewtopic.php?f=7&t=43516 where a user reports the opposite problems: OO Calc switches his upper-case input to lower-case.
In my case, data above the input cell contains the same word both with and without an initial capital letter. With AutoInput on, when I begin input, OO Calc offers to auto-complete it (highlighted in blue) with the all-lower-case version. I press press ENTER to accept it ... and OO Calc converts it to the initial cap version!
I added a comment and two votes to this existing issue: https://issues.apache.org/ooo/show_bug.cgi?id=105319
OpenOffice 4.1.0 on Windows 8.1
DonPayne
 
Posts: 4
Joined: Wed Jul 16, 2014 4:15 pm

Re: [Solved] How to *really* turn off capitalization?

Postby acknak » Thu Sep 18, 2014 9:39 pm

The problem is that there are at least three four different features that can fiddle with your input:

Autoinput: copies previous entries from the same column. As far as I can see, this just copies the previous entry, regardless of what letter case you type.

AutoCorrect/Capitalize first letter. This is supposed to only affect a full sentence but it seems to trigger in some other cases too.

AutoCorrect/Replace: This can change the letters you type into something else, for example, if you type hte it will change to the. Or type i and it will change to I.

Sort lists: type mon, it changes to Mon because Calc has a built-in sort list for days of the week, including Mon

So it can be rather difficult to say which one is taking effect without having the entire sheet to examine.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: [Solved] How to *really* turn off capitalization?

Postby magnoliasouth » Fri Sep 19, 2014 6:27 pm

acknak wrote:The problem is that there are at least three four different features that can fiddle with your input:

Autoinput: copies previous entries from the same column. As far as I can see, this just copies the previous entry, regardless of what letter case you type.

AutoCorrect/Capitalize first letter. This is supposed to only affect a full sentence but it seems to trigger in some other cases too.

AutoCorrect/Replace: This can change the letters you type into something else, for example, if you type hte it will change to the. Or type i and it will change to I.

Sort lists: type mon, it changes to Mon because Calc has a built-in sort list for days of the week, including Mon

So it can be rather difficult to say which one is taking effect without having the entire sheet to examine.
This right here, is what needs to be in the help files. Rather than giving us a guessing game and making us search and then not finding an answer, they just need to add all the places you need to turn it off.

The even better option though, is to cut all of that and put it all in one place. ONE place. :crazy:
User avatar
magnoliasouth
 
Posts: 50
Joined: Sat Sep 06, 2008 5:32 pm

Re: [Solved] How to *really* turn off capitalization?

Postby DonPayne » Fri Sep 19, 2014 8:33 pm

acknak wrote:The problem is that there are at least three four different features that can fiddle with your input:
Autoinput: ... AutoCorrect/Capitalize first letter ... AutoCorrect/Replace ... Sort lists ...


Understood, but:
  1. Autoinput is what I toggled on and off, and that turned the behavior on and off
  2. AutoCorrect/Capitalize was already turned off
  3. AutoCorrect/Replace: My input that was being case-converted did not match any "Replace this" strings.
  4. Sort lists: My input did not match did not match any strings in the Sort Lists
So I'm Pretty Darn Sure it was Autoinput that changed my input.
One more suggested feature (which I'll put in the Issues list): "undo" should undo the Autoinput or AutoCorrect only, leaving the uncorrected user input. A second "undo" would undo the user input. I believe that is how MS Word and Excel work.
OpenOffice 4.1.0 on Windows 8.1
DonPayne
 
Posts: 4
Joined: Wed Jul 16, 2014 4:15 pm

Re: [Solved] How to *really* turn off capitalization?

Postby geekduck » Fri Feb 06, 2015 8:04 am

I am trying to enter a lower case i in a cell. Why should a user have to fight and dig through settings to make the software allow what the user wants int he cell? After spending 2 hours looking into how to make this work, I cannot figure it out. I want what I type to appear in the cell. Not what some programmer writes into the software to think what I want. This should not be this difficult.
OpenOffice 4.1.1 / Mac OS 10.10.2
geekduck
 
Posts: 1
Joined: Fri Feb 06, 2015 8:00 am

Re: [Solved] How to *really* turn off capitalization?

Postby acknak » Fri Feb 06, 2015 5:40 pm

Welcome to the community forum!

geekduck wrote:I am trying to enter a lower case i in a cell. ...

Right. I don't see any way to enter a bare, lower case i under the default settings.

Tools > AutoCorrect Options > Options > Use replacement table: OFF allows it. Just be aware: this is a global setting; this turns it off for OO Writer as well, where the feature is more useful.

Some workarounds:
make the entry then use Format > Change case > lowercase to fix it.
enter it as ="i"
copy the character to the clipboard and paste it into the cell instead of typing.

Once I do get an "i" entered, Autoinput seems to take precedence and I can enter more in the same column without any fuss.
AOO4/LO5 • Linux • Fedora 23
User avatar
acknak
Moderator
 
Posts: 22756
Joined: Mon Oct 08, 2007 1:25 am
Location: USA:NJ:E3

Re: [Solved] How to *really* turn off capitalization?

Postby tom.webster » Thu Jul 28, 2016 5:47 pm

Dear acknak, Thank you, thank you, thank you for telling us how to solve this really really annoying problem, and also for explaining why the solution published in help is sometimes ineffective. :bravo:
Apache OpenOffice 4.1.2 on Windows 10
tom.webster
 
Posts: 3
Joined: Thu Jul 28, 2016 5:43 pm

Re: [Solved] How to *really* turn off capitalization?

Postby JDQ » Tue Jan 31, 2017 11:01 pm

The best way I've found to stop OpenOffice from AutoCorrecting "i" to "I" without turning off the entire replacement table is:

    Format -> AutoCorrect -> AutoCorrect Options...
    Scroll down to the applicable entry, click (select) it, then click "Delete".

While we're on the topic, adding new AutoCorrect entries is a great way to speed up insertion of special characters. I like to follow a LaTeX formatting scheme, and will add new entries like "\omega" for the omega symbol in the special characters panel.
OpernOffice 4.1.3, Mac OS X 10.11.6
JDQ
 
Posts: 1
Joined: Tue Jan 31, 2017 10:56 pm

Re: [Solved] How to *really* turn off capitalization?

Postby tom.webster » Wed Feb 01, 2017 2:52 am

I think that turning off autoinput solved the problem for me, too. I say "I think" because I want to do more extensive testing before I heave a sigh of relief, but I'm feeling pretty good about it. I also found a tip in the documentation that might help people who don't want to turn autoinput off just to correct one isolated but annoying problem. "Help" says that Ctrl-z will undo individual autoinput changes. I haven't tested that yet because I've finally got rid of the problem, and testing the undo feature will require me to turn it on again, and I'm just not ready :crazy:
Apache OpenOffice 4.1.2 on Windows 10
tom.webster
 
Posts: 3
Joined: Thu Jul 28, 2016 5:43 pm

Re: [Solved] How to *really* turn off capitalization?

Postby brightgeist » Sun Feb 17, 2019 5:28 am

found this, in case anyone needs it:

Tools -> Options -> OpenOffice Calc -> Sort Lists : delete all the sort lists and nothing you enter will be changed anymore (if you also unchecked all the other things mentioned on this thread)
OpenOffice 4.1.6 on Windows 7 Ultimate
brightgeist
 
Posts: 1
Joined: Sun Feb 17, 2019 5:18 am

Re: [Solved] How to *really* turn off capitalization?

Postby Zizi64 » Sun Feb 17, 2019 9:18 am

Be careful with deleting all of the sorted lists. Some functions may will not work after deleting the names of the weekdays, or others.
Tibor Kovacs, Hungary; LO4.4.7, LO6.1.5 on Win7-10 x64Prof.
PortableApps, winPenPack: LO3.3.0-6.2.2; AOO4.1.5
Please, edit the initial post in the topic: add the word [Solved] at the beginning of the subject line - if your problem has been solved.
User avatar
Zizi64
Volunteer
 
Posts: 7914
Joined: Wed May 26, 2010 7:55 am
Location: Budapest, Hungary

Re: [Solved] How to *really* turn off capitalization?

Postby robleyd » Sun Feb 17, 2019 9:32 am

To expand on Zizi's comment, the sort lists have little relationship to autocorrect type functions. From the Help - F1:

Applying Sort Lists
Sort lists allow you to type one piece of information in a cell, then drag it to fill in a consecutive list of items.
For example, enter the text "Jan" or "January" in an empty cell. Select the cell and click the mouse on the lower right corner of the cell border. Then drag the selected cell a few cells to the right or downwards. When you release the mouse button, the highlighted cells will be filled with the names of the months.
Hold down Ctrl if you do not want to fill the cells with different values.
The predefined series can be found under Tools - Options - OpenOffice Calc - Sort Lists. You can also create your own lists of text strings tailored to your needs, such as a list of your company's branch offices. When you use the information in these lists later (for example, as headings), just enter the first name in the list and expand the entry by dragging it with your mouse.
Cheers
David
Apache OpenOffice Developer Build 4.2.0 9820 - Slackware 14.2 - 64 bit
LibreOffice 6.0.7.3 - Slackware 14.2 - 64 bit
Apache OpenOffice 4.1.4 - Windows 7 Virtual machine
User avatar
robleyd
Moderator
 
Posts: 2643
Joined: Mon Aug 19, 2013 3:47 am
Location: Murbko, Australia


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 4 guests