Saved file lost

Discuss setup / installation issues - Add a spell checker, Language pack?

Saved file lost

Postby froggie » Mon Sep 14, 2009 12:30 pm

help!
I was working as normal this morning on a file in OO 3.0.0 (document saved as Windows XP), and decided to reboot my computer. I saved before manually exiting OO, and, when I rebooted, I opened the file and found it had a version from yesterday morning. alarmed, I decided to look for a temporary file (I did not have automatic backup on), and found something, but it was an even earlier version of the file. however now, when I open the file in OO, I get only that even-earlier version - i.e., the earlier version I originally found the first time I opened the file has also disappeared.
what is happening? help!
thank you for any help you can give!
froggie.
OOo 3.0.X on Ms Windows XP
froggie
 
Posts: 6
Joined: Fri Apr 10, 2009 2:05 pm

Re: Saved file lost

Postby Hagar Delest » Mon Sep 14, 2009 1:19 pm

What is the timestamp of the file? Any security application that could have prevented OOo from saving the file?

I've seen that problem twice in 3 years in forums (one that occurred with me on a GNU/Linux system): timestamp was proving the file had been saved when I manually saved by content had not been updated.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28626
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Saved file lost

Postby froggie » Mon Sep 14, 2009 1:27 pm

hello!
thank you for your reply!
please bear with me, as I am not very good with computers! please tell me how to find the timestamp! I use Eset as my anti-virus and firewall, but I have never had anything like this happen before (perhaps I should mention that the computer is relatively new, having been bought mid-July, but I have worked on it as on my old computer without any problems until now).
what really surprises me is not only the fact that the saved file was gone when I re-booted, but that information disappeared from the file I could open simply opening it different times (i.e., without any event such as a re-boot taking place).
if you tell me how to identify the timestamp, I can pass that on!
thank you again!
froggie.
OOo 3.0.X on Ms Windows XP
froggie
 
Posts: 6
Joined: Fri Apr 10, 2009 2:05 pm

Re: Saved file lost

Postby froggie » Mon Sep 14, 2009 2:30 pm

p.s. an update. re-opening the file again now, I have the version I had when I first re-booted the computer, so, only the shorter version, rather than the extra-shorter version. I have no idea how that happened....
OOo 3.0.X on Ms Windows XP
froggie
 
Posts: 6
Joined: Fri Apr 10, 2009 2:05 pm

Re: Saved file lost

Postby Hagar Delest » Mon Sep 14, 2009 5:46 pm

The time stamp is the date and time shown in the file browser.

The only thing I can think of is a problem with the cache not being written at shutdown. Very often, the file is not written immediately, the system waits for some idleness and then does the disk operation by batch. Perhaps it missed that one before shutting down.
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28626
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Saved file lost

Postby froggie » Mon Sep 14, 2009 5:51 pm

thank you!
the date and time given on the file is 1200 to-day - unfortunately, I cannot tell you whether that was before or after I re-booted the computer, though I know that I did not try saving the file after re-booting and finding information was missing.
can you think of any way to recover the missing information? is there anywhere I can look for another version of the file? I have saved it several times since yesterday, but it only has information up to some time yesterday on it - if your theory about the cache and shutdown is correct, would it not still have saved earlier versions that I had saved earlier this morning, or even yesterday evening?
thank you again for your help!
OOo 3.0.X on Ms Windows XP
froggie
 
Posts: 6
Joined: Fri Apr 10, 2009 2:05 pm

Re: Saved file lost

Postby Hagar Delest » Mon Sep 14, 2009 6:05 pm

Indeed, it might have happened once linked to a faulty shutdown but definitively not several times.

Have you checked the backup folder in the user profile? (see [Tutorial] The OOo user profile).
AOO 4.1.7 on Xubuntu 19.10 and 4.1.5 on Windows 10 (with winPenPack port).
User avatar
Hagar Delest
Moderator
 
Posts: 28626
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Saved file lost

Postby froggie » Mon Sep 14, 2009 6:07 pm

yes, the backup folder was the first place I checked, but I did not have the automatic backup function enabled (I have now rectified this mistake!), so it was, of course, empty.....
OOo 3.0.X on Ms Windows XP
froggie
 
Posts: 6
Joined: Fri Apr 10, 2009 2:05 pm


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 5 guests