All network documents open in read-only mode

Discuss setup / installation issues - Add a spell checker, Language pack?

All network documents open in read-only mode

Postby dudinatrix » Fri Aug 21, 2009 5:39 pm

For some reason, one computer on our network is having read-only issues with every document we try to open or save to our network drives. I have confirmed that she has full read-write permission to the drives and folders she is trying to access. Every network file opened via OpenOffice is in read-only mode. Other applications can read/write to the same directory with no problem. The files themselves are NOT marked read-only by the file system, only in OpenOffice. Prior to upgrading to OpenOffice 3.1, it was happening some of the time. Now it's happening ALL the time, for every network file.

So far I've tried the following to fix the problem:
* Download and reinstall/upgrade to OpenOffice 3.1 (didn't work.. in fact, it seemed to make it worse)
* Complete uninstall of OpenOffice and Java and registry clean (using CCleaner), then reinstall OpenOffice 3.1 (didn't work)
* Reset the OpenOffice user profile from C:\Documents and Settings\[user]\Application Data\OpenOffice.org\3\user\ (didn't work)

Again, this is specific to OpenOffice. Even if we try to create a new spreadsheet and save it to our network drive, this error comes up: "Object not accessible. The object cannot be accessed due to insufficient user rights." Trying the same thing in any other application to the same exact location works with no issues.

Any more ideas??

OS: Windows XP Pro SP3
OpenOffice 3.1 on Windows XP Pro SP3
dudinatrix
 
Posts: 2
Joined: Fri Aug 21, 2009 5:04 pm

Re: All network documents open in read-only mode

Postby r4zoli » Fri Aug 21, 2009 6:22 pm

* Complete uninstall of OpenOffice and Java and registry clean (using CCleaner), then reinstall OpenOffice 3.1 (didn't work)

When you did this step, deleted folders created by OOo under c:\Program Files\ ?
AOO 4.0 and LibO 4 on Win 8
Hungarian forum co-admin
User avatar
r4zoli
Volunteer
 
Posts: 2882
Joined: Mon Nov 19, 2007 8:23 pm
Location: Budapest, Hungary

Re: All network documents open in read-only mode

Postby dudinatrix » Fri Aug 21, 2009 6:27 pm

r4zoli wrote:
* Complete uninstall of OpenOffice and Java and registry clean (using CCleaner), then reinstall OpenOffice 3.1 (didn't work)

When you did this step, deleted folders created by OOo under c:\Program Files\ ?

Yes, I deleted them there, but not under c:\Documents and Settings\... I forgot about those so I reset the user profile after installing OOo 3.1, which didn't help.

I managed to temporarily work around the issue by uninstalling OpenOffice 3.1, deleting the directories in c:\Documents and Settings\, and then reinstalling OpenOffice 2.4. The downgrade seemed to have fixed it. This leads me to believe either (a) the problem is some sort of new bug in OpenOffice 3.1 or (b) the user profile needed to be deleted before installing 3.1 (because resetting it after the install didn't fix it).

At this point I hesitate going back to 3.1 only because it's finally working again.
OpenOffice 3.1 on Windows XP Pro SP3
dudinatrix
 
Posts: 2
Joined: Fri Aug 21, 2009 5:04 pm

Re: All network documents open in read-only mode

Postby Hagar Delest » Sat Aug 22, 2009 12:33 am

dudinatrix wrote:This leads me to believe either (a) the problem is some sort of new bug in OpenOffice 3.1 or (b) the user profile needed to be deleted before installing 3.1 (because resetting it after the install didn't fix it).

At this point I hesitate going back to 3.1 only because it's finally working again.

During the install process, don't transfer your personal data during the welcome screens, configuration files from the former version might indeed corrupt the new profile. Note that you can run 2.x and 3.x in parallel on a system. Just don't allow OOo to uninstall the previous version in the installation process.

Thanks to add '[Solved]' at beginning of your first post title (edit button) if your issue has been fixed.
AOO 4.1.1 on Windows 7 and Xubuntu 14.10 (Utopic Unicorn)
User avatar
Hagar Delest
Moderator
 
Posts: 26375
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: All network documents open in read-only mode

Postby linda_tan75 » Fri Sep 18, 2009 9:36 am

Hi .. I also encounter the same problem with open office 3.1. Is there anyway to fix it?
For the time being i'm also downgrade to openoffice 2.0.
If I don't install the previous version (Oper office 2.0) so i can't open file beside read only type?
I think i don't need two version open office running on my computer.
thanks..
OpenOffice 3.1 on Windows XP
linda_tan75
 
Posts: 1
Joined: Fri Sep 18, 2009 9:32 am


Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 10 guests