Page 1 of 1

Retrieving document

PostPosted: Fri Apr 17, 2009 2:54 am
by John25
Welcome beginner. What is your question or comment?
Please try to briefly and clearly tell us: What you want, What you tried, and What happened.
-----------------------------------------------------------------------------------------------------------
I saved a file on Open Office 3.0 but before I closed the file, my laptop shut off. When I tried to retrieve the file it asks me for the character set and I do not know which one to pick. I have tried each one in Western Europe and when I do, I get the document back but it is not readable and shows this: ############.... continuously. The default font is in Times New Roman, and the language is English (USA). Which character set can I choose to get my document back in its original form.

Thanks

John

Re: Retrieving document

PostPosted: Fri Apr 17, 2009 3:22 am
by acknak
Sorry, but that's a sure sign that your file is corrupted and not recoverable.

If you like, you can attach it here and someone can take a look to be sure, but I've never seen one in this state that we could do anything with--especially if you were saving to MS Office format.

See: http://user.services.openoffice.org/en/forum/viewtopic.php?f=6&t=17677 for another example.

The only solution is to a) save often and do not depend on the auto-save/recovery feature, and b) make regular backup copies.

Re: Retrieving document

PostPosted: Fri Apr 17, 2009 11:38 pm
by John25
Here is the file. I did save before the computer shut down but I didn't exit the Open Office program before it was shut down. Thanks to anyone who can help me recover the file.

Re: Retrieving document

PostPosted: Fri Apr 17, 2009 11:54 pm
by Hagar Delest
Can't open the file, sorry (well, just hashes in fact).

You should open a bug report and attach your file: [Tutorial] Reporting bugs or suggestions. That's the 5th topic about hashes now (see the thread linked above). Perhaps the devs will be able to see what's wrong with the file because it's not recognized by my archive manager but OOo can import its poor content.
:evil:

Re: Retrieving document

PostPosted: Sat Apr 18, 2009 2:59 am
by acknak
The file contains nothing but binary zeros--nothing there to recover.

    $ hexdump -C Community\ Property\ Notes.odt
    00000000 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 |................|
    *
    0000dcc0 00 00 00 00 00 00 00 00 00 00 |..........|
    0000dcca

With modern computers--especially laptops--there is a delay between the time that an application, like OOo, says "save this data to a file" and when the data actually lands safely on the disk, ready to be recalled later on. If "something bad" happens before the data is safely on the disk, you lose.

At least, that would be my guess at what's happening.

Re: Retrieving document

PostPosted: Sat Apr 18, 2009 8:59 am
by Hagar Delest
Ah yes, I see, it would be in the cache settings of the OS then? But I thought it was very short for HD access.

Re: Retrieving document

PostPosted: Sat Apr 18, 2009 5:09 pm
by acknak
I'm just guessing about the cause; I'd rather not multiply that with guesses about settings or times. ;-)

It's not always up to the OS either--hard drives, especially laptop hard drives, may have large cache memories and wait for a time (a few seconds?) before writing the data on the disk.

My impression is that this kind of corruption has always happened in the context of some kind of major system failure--the system hangs or blue-screens, or power goes out suddenly.

It's not just a simple memory dump for OOo to get a document safely into a document file. It's a lot of work, and it takes a while. I imagine it just makes the target window for catastrophe that much bigger.

Re: Retrieving document

PostPosted: Mon May 18, 2009 1:59 pm
by Hagar Delest
For the record, some additional information in that thread: ###### No Text, perhaps you should check and see if you can reproduce it.