Can't spell check in 2 languages (Dutch & English Australia)

Discuss setup / installation issues - Add a spell checker, Language pack?

Can't spell check in 2 languages (Dutch & English Australia)

Postby Petra » Mon Mar 09, 2009 8:08 am

Phil, I don't work exclusively in Dutch but I would like to set up a second default style in Dutch language. Just like you do with Canadian/French. How do I set this up?
Petra

 Edit: Hagar (Moderator): split from initial topic [Solved] Spell check (English Australian) doesn't work because problem is now different. 
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby Hagar Delest » Mon Mar 09, 2009 9:18 am

Have you read the tutorial? You should also have a look on the styles wiki pages. There is a link to the Writer user guide at the top of the Writer forum, then see the sections about styles.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell check (English Australian) doesn't work

Postby PGAGA » Tue Mar 10, 2009 3:20 am

Monday 09 March 2009

Hagar de l'Est wrote:Have you read the tutorial? You should also have a look on the styles wiki pages. There is a link to the Writer user guide at the top of the Writer forum, then see the sections about styles.


The section about styles will tell you how to do it. If you are still confused, get back to us.

Phil
OpenOffice.org 3.2.x, StarOffice 5.1, 7, 8 - OS X, WinXP, OS/2
StarOffice 7, 8, Oracle Open Office 3.3.1, LibreOffice 3.x.x - OS X, Ubuntu, WinXP
NeoOffice 2.2.6, 3.1.2, 3.2.x 3.3 - OS X
Apache OpenOffice 3.4.x - WinXP, OS X, OS/2
PGAGA
Volunteer
 
Posts: 481
Joined: Sun Dec 07, 2008 10:54 pm

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Tue Mar 10, 2009 11:16 am

I am following the instructions from OOo Wiki how to add more text languages, however the Dutch dictionary (dict-nl.oxt) is already taking 6.5 hours to down load and still not finished yet. I am not sure if I am doing it correctly. I must admit I don't know my way around OOo yet.
PGAGA wrote:Monday 09 March 2009

Hagar de l'Est wrote:Have you read the tutorial? You should also have a look on the styles wiki pages. There is a link to the Writer user guide at the top of the Writer forum, then see the sections about styles.


The section about styles will tell you how to do it. If you are still confused, get back to us.

Phil
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby Hagar Delest » Tue Mar 10, 2009 12:00 pm

Do you have a fast internet access? It should be around 2 to 5MB.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Tue Mar 10, 2009 12:08 pm

I have 512K speed and 5GB down loads.
Hagar de l'Est wrote:Do you have a fast internet access? It should be around 2 to 5MB.
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby Hagar Delest » Tue Mar 10, 2009 12:15 pm

Do you download it from here: http://extensions.services.openoffice.org/project/dict-nl? It's less than 1MB so it should take you few seconds only.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Wed Mar 11, 2009 4:50 am

I've downloaded it from there with no problems. I've continued as follows: In OOo3, choose Tools-Extension Manager. This now shows up Aus/English dictionary, plus Dutch and English and French and Spanish dictionaries as well. I didn't down load those last three. I click on Add button to select the downloaded dictionary extension file. Which should be the Dutch dictionary (dict-nl.oxt) This does not show up. It shows up OOo3.0(en-US)installation files. Where do I go from here?
Hagar de l'Est wrote:Do you download it from here: http://extensions.services.openoffice.org/project/dict-nl? It's less than 1MB so it should take you few seconds only.
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby Hagar Delest » Wed Mar 11, 2009 9:12 am

I don't understand. If you see the Dutch dic in the list of the installed extensions (with English, Aust., French and Spanish), what's the problem???
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Wed Mar 11, 2009 9:33 am

I've downloaded the Dutch dictionary, now I need to add it to the dictionary extension file don't I?
Hagar de l'Est wrote:I don't understand. If you see the Dutch dic in the list of the installed extensions (with English, Aust., French and Spanish), what's the problem???
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby Hagar Delest » Wed Mar 11, 2009 3:27 pm

Petra wrote:I've downloaded it from there with no problems. I've continued as follows: In OOo3, choose Tools-Extension Manager. This now shows up Aus/English dictionary, plus Dutch and English and French and Spanish dictionaries as well.

So it has been added, hasn't it?
Else, click the Add button and browse your HD and double-click the downloaded extension.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Thu Mar 12, 2009 12:56 am

I have downloaded dict-nl.oxt but when I click the Add button, I search for dict-nl.oxt and nothing comes up. When I try to download Dutch dict again it says that I've already downloaded it and do I want to replace it. I said yes and tried again but I get the same problem where I cannot add it.
Hagar de l'Est wrote:
Petra wrote:I've downloaded it from there with no problems. I've continued as follows: In OOo3, choose Tools-Extension Manager. This now shows up Aus/English dictionary, plus Dutch and English and French and Spanish dictionaries as well.

So it has been added, hasn't it?
Else, click the Add button and browse your HD and double-click the downloaded extension.
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby Hagar Delest » Thu Mar 12, 2009 10:24 am

Download (or move) it to My Documents folder for example. Then when you click the Add button, go to My Documents directly and double-click it. OOo can't guess where is the file, you've to tell it.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Thu Mar 19, 2009 1:06 am

Dutch (Netherlands) language now showing up and I can select spell check in Dutch. However, after every word checked it automatically switches back to English (Australia). Can I only check one word at the time? In Writing Aids I have both languages showing and ticked (checked). Even when I un-tick English, the same thing happens.
Hagar de l'Est wrote:Download (or move) it to My Documents folder for example. Then when you click the Add button, go to My Documents directly and double-click it. OOo can't guess where is the file, you've to tell it.
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby PGAGA » Thu Mar 19, 2009 3:34 am

Wednesday 18 March 2009

The Spell Checker will check the part of the document which is in Dutch. If your default template is English, then when it finishes the Dutch section it switches back to English. If you do not want to use a Dutch Style, highlight the area you want to be Dutch and select the language.

Phil
OpenOffice.org 3.2.x, StarOffice 5.1, 7, 8 - OS X, WinXP, OS/2
StarOffice 7, 8, Oracle Open Office 3.3.1, LibreOffice 3.x.x - OS X, Ubuntu, WinXP
NeoOffice 2.2.6, 3.1.2, 3.2.x 3.3 - OS X
Apache OpenOffice 3.4.x - WinXP, OS X, OS/2
PGAGA
Volunteer
 
Posts: 481
Joined: Sun Dec 07, 2008 10:54 pm

Re: [Solved] Spell check (English Australian) doesn't work

Postby Hagar Delest » Thu Mar 19, 2009 8:59 am

Please read the tutorial about styles.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Sat Mar 21, 2009 6:56 am

Can you give me the link to this?
Hagar de l'Est wrote:Please read the tutorial about styles.
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Sat Mar 21, 2009 7:01 am

When I have a document that is totally in Dutch it will stop at the first Dutch word, I change the language to Dutch and before I get the correct spelling in Dutch it already switches back to English. When I go to Tools, Options, Language Setting, Writing Aids only the Dutch language is checked and not English. Even though English is not checked it only want to do spell check in English.
PGAGA wrote:Wednesday 18 March 2009

The Spell Checker will check the part of the document which is in Dutch. If your default template is English, then when it finishes the Dutch section it switches back to English. If you do not want to use a Dutch Style, highlight the area you want to be Dutch and select the language.

Phil
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby Hagar Delest » Sat Mar 21, 2009 3:09 pm

AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell check (English Australian) doesn't work

Postby PGAGA » Sat Mar 21, 2009 4:39 pm

March 21 2009

First, is there a tutorial on template style interaction.

Second, my guess would be that your template has its style set for English which overwrite the other system settings.

Phil
OpenOffice.org 3.2.x, StarOffice 5.1, 7, 8 - OS X, WinXP, OS/2
StarOffice 7, 8, Oracle Open Office 3.3.1, LibreOffice 3.x.x - OS X, Ubuntu, WinXP
NeoOffice 2.2.6, 3.1.2, 3.2.x 3.3 - OS X
Apache OpenOffice 3.4.x - WinXP, OS X, OS/2
PGAGA
Volunteer
 
Posts: 481
Joined: Sun Dec 07, 2008 10:54 pm

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Sun Mar 22, 2009 6:16 am

I have checked as much as possible of what I understand from the tutorial and from what I understand it is all set correctly. There are a few things that I do not understand though as it gets quite involved and complicated for me.
I did start a new document in Dutch and it automatically started the spell check in Dutch even though in all the settings the English Australian language is selected. However if I want to do a spell check in Dutch on an existing Dutch document it does not work. I do appreciate your help but unfortunately I am not a computer kid and I do not understand a lot of this computer language. I am trying very hard to understand but this is about my limit. If I only knew how to do a spell check in Dutch on an existing Dutch document I would be happy. :)
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby Hagar Delest » Sun Mar 22, 2009 11:29 am

Sorry, I don't see how I could help further. Is there someone at home that could help you?

Or can you upload a sample file (see here: How to attach a document here) so that we can check if the configuration is correct?

PGAGA wrote:First, is there a tutorial on template style interaction.

Does the tutorial answer the question?
Hagar de l'Est wrote:If you have a custom template: if you change the general setting in the Tools>Options>Language Settings menu, this will be applied only to the current document. New documents will still have the former value because the general setting is overridden by the Default paragraph style definition of the template. To make the change permanent, you've to edit the template.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Thu Mar 26, 2009 7:13 am

Nobody here that can help me, I'll have to work it out myself. I have attached part of a Dutch document for the spell check. I have purposely put lots of spelling mistakes in it. Hope that you can work it out.
Hagar de l'Est wrote:Sorry, I don't see how I could help further. Is there someone at home that could help you?

Or can you upload a sample file (see here: How to attach a document here) so that we can check if the configuration is correct?

PGAGA wrote:First, is there a tutorial on template style interaction.

Does the tutorial answer the question?
Hagar de l'Est wrote:If you have a custom template: if you change the general setting in the Tools>Options>Language Settings menu, this will be applied only to the current document. New documents will still have the former value because the general setting is overridden by the Default paragraph style definition of the template. To make the change permanent, you've to edit the template.
Attachments
Oceaan tot Outback Toer (nederlands)spell check version.doc
dutch document
(10.5 KiB) Downloaded 126 times
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: [Solved] Spell check (English Australian) doesn't work

Postby Hagar Delest » Thu Mar 26, 2009 9:28 am

The Default paragraph style is set to English (Australia). So of course it can't work. I changed the setting to another language and works fine. So please change your paragraph style to Dutch.

BTW, I've split the topic since your second problem is rather different from the first one (installing a dictionary).
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: [Solved] Spell check (English Australian) doesn't work

Postby Petra » Thu Mar 26, 2009 11:51 am

When I go Tools, Language, For Selection or For Paragraph or For all Text, my Dutch language choice has now disappeared. I had the option before to select Dutch but now it has gone. Where has it gone?
Hagar de l'Est wrote:The Default paragraph style is set to English (Australia). So of course it can't work. I changed the setting to another language and works fine. So please change your paragraph style to Dutch.

BTW, I've split the topic since your second problem is rather different from the first one (installing a dictionary).
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: Can't spell check in 2 languages (Dutch & English Australia)

Postby Hagar Delest » Thu Mar 26, 2009 12:18 pm

Forget about that dialog. It's not that efficient because the list is populated mainly by the languages already in use in the document.

Modify the style from the Stylist as shown in the troubleshooting guide.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Can't spell check in 2 languages (Dutch & English Australia)

Postby Petra » Thu Mar 26, 2009 2:52 pm

I don't understand. Why has my option Dutch language disappeared? Can you send me the link to the troubleshooting guide?
Hagar de l'Est wrote:Forget about that dialog. It's not that efficient because the list is populated mainly by the languages already in use in the document.

Modify the style from the Stylist as shown in the troubleshooting guide.
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Re: Can't spell check in 2 languages (Dutch & English Australia)

Postby Hagar Delest » Thu Mar 26, 2009 4:20 pm

That Tools>Language menu (and same for the status bar switch for language) builds the language list from some default settings but also from used languages in the current document. Don't ask me why or how, I don't know. This is not the best place to set the language, that's why you should use the standard method, i.e. through the styles.

See [Troubleshooting] Spell check in OOo 3.x.
AOO 4.0.1 on Windows 7 and Xubuntu 14.04 (Trusty Tahr)
User avatar
Hagar Delest
Moderator
 
Posts: 25088
Joined: Sun Oct 07, 2007 9:07 pm
Location: France

Re: Can't spell check in 2 languages (Dutch & English Australia)

Postby PGAGA » Fri Mar 27, 2009 5:53 pm

Friday, March 27, 2009

Let's back this up and see if we have a system problem. Attached is a template with Default set to Australian English and Default2 set to Dutch (Netherlands). The other styles in the template may be Canadian and US English. But test using the two defaults. If it does what you want, this means the problem is not your system nor your OOo installation. If it does not work, then there is a setup problem of some kind.

If it works, then you need learn about the F11 command and change the other styles to the language you prefer.

Phil
Attachments
AustraliaDutch.ott
(7.41 KiB) Downloaded 90 times
OpenOffice.org 3.2.x, StarOffice 5.1, 7, 8 - OS X, WinXP, OS/2
StarOffice 7, 8, Oracle Open Office 3.3.1, LibreOffice 3.x.x - OS X, Ubuntu, WinXP
NeoOffice 2.2.6, 3.1.2, 3.2.x 3.3 - OS X
Apache OpenOffice 3.4.x - WinXP, OS X, OS/2
PGAGA
Volunteer
 
Posts: 481
Joined: Sun Dec 07, 2008 10:54 pm

Re: Can't spell check in 2 languages (Dutch & English Australia)

Postby Petra » Thu Apr 02, 2009 5:46 am

I've downloaded the template. Under Styles & Formatting it showed up as Default 2. I type in Dutch and it spell checks in Dutch correctly. However, when I hit Enter, Styles and Formatting changes automatically to First line indent. I have to change this to Default 2 again to type in Dutch with Dutch spell check.
When I hit F11, Styles and Formatting opens up. This is all about Paragraph styles, Character styles, Frame styles, Page styles and List styles. I cannot detect a choice in language there.
PGAGA wrote:Friday, March 27, 2009

Let's back this up and see if we have a system problem. Attached is a template with Default set to Australian English and Default2 set to Dutch (Netherlands). The other styles in the template may be Canadian and US English. But test using the two defaults. If it does what you want, this means the problem is not your system nor your OOo installation. If it does not work, then there is a setup problem of some kind.

If it works, then you need learn about the F11 command and change the other styles to the language you prefer.

Phil
OOo 2.3.X on MS Windows Vista
Petra
 
Posts: 18
Joined: Fri Feb 27, 2009 7:11 am

Next

Return to Install, Setup and Troubleshooting

Who is online

Users browsing this forum: No registered users and 6 guests